Welcome to the Linux Foundation Forum!

[finished] No graphical interface (stops booting at: "starting timidity alsa midi emulation")

vex7 Posts: 5
edited March 2012 in Ubuntu

Alright, I did it. ;)

My Kubuntu doesn't load the login screen or the graphical interface anymore but stops booting when it prints "Starting TiMidity++ ALSA midi emulation... [ OK ]".

However, I can't tell exactly which action has caused this:

Before some parts of my workspace have crashed and restarted, and afterwards the workspace was rather slow.

Yet before I restarted the system, I've also changed the owner of the folders /var and /etc to root (stupid idea? ^^) in order to fix another problem (message was sth like "... is owned by uid 1000, should be 0").

So I was wondering now, if there's a way to fix this problem without a complete reinstallation.

Thanks in advance and just ask if you think you need to know some more things. :)


  • Goineasy9
    Goineasy9 Posts: 1,114
    The folders /etc and /var are owned by root, although the user (you) has access to some of the files in these folders. Did you try installing some midi software that could have changed permissions? Were the permissions listed for /etc and /var shown to be owned by someone other than root and that's why you had to change them back to root? UID 1000 is usually the UID given to the first user (you). If some system files were changed to give you as the user access, I don't see why that would cause the system to fail, but, I have never changed the access of my system files, I've only accessed them as root.
    Maybe you could tell us what you were doing/installing in regards to the midi device that may have caused your problems to start. Permissions for the /etc and /var folders should not have been changed from root in the first place, but I don't know what could have caused that error.
  • vex7
    vex7 Posts: 5
    Hi, I received the permissions error when I tried to run the plasmapkg-command in order to install a plasmoid (with sudo, of course). Strangely this has worked out fine a few times before even though I can't remember to have changed any configurations in the mean time.
    So I think I actually did not do anything that seemed to me to have something to do with the main error...
  • mfillpot
    mfillpot Posts: 2,177
    I do not use kubuntu, but is there a recovery menu item in the bootloader option that you can try to see if it can buypass the error and get you to a working state?

    If that can be located, then you can check the files in /var/log to determine the point of failure.
  • vex7
    vex7 Posts: 5
    Thank you very much for your help, but unfortunately I did not manage to solve this problem. And because I did not really know whether this was actually possible, I took this as the occasion to switch from Kubuntu to OpenSUSE.
    So this issue can be seen as "solved". :)
  • Goineasy9
    Goineasy9 Posts: 1,114
    Oh well, I guess better luck next time. I can't say I have taken bad situations as an excuse to move on myself.
  • vdbk
    vdbk Posts: 1
    Hi guys,
    I had that problem with boot hanged on Timidity+Alsa emulation after a regular update through apt-get. I tried to figure out what was the faulty package but could not.

    I initially tried to relaunch graphical interface through sudo restart lightdm. I was not successful in that but in /var/log/lightdm I found lightdm.log and x-0.log which were helpful to diagnose.

    In the last one, I could find warnings (WW) about fglrx which is the main process for ATI drivers.
    It was talked about 'unallocated seat' and other stuff making me think the driver was a problem.

    I uninstalled my ATI driver through sudo aticonfig --uninstall then rebooted the computer.
    Graphical interface was back and I just had to reinstall the driver with sudo sh ./ati-xxxxx.run

    Hope this will help

    Ubuntu 12.04 through an Ultimate distribution (3.4)
    Gigabyte 990XA-UD3 / Phenom II X4 / 8 Go Ripjaws / Sapphire 7870 2Go
    ... and many hard drives... :)


Upcoming Training