Welcome to the Linux Foundation Forum!

clueless/need help/direction asap

I recently accquired this laptop, which has Linux Mint 12 as the OS. I have heard of, yet never been exposed to any version of Linux, and am now trying to figure out how to do everything, but the language/wording used is so different from Windows-I AM LOST, and getting aggrevated. Is there anyplace to go for help-such as learning how to use/navigate Linux by comparing to Windows-to facilitate this transitation. Any advice/info would be greatly appreciated, as I am sure I will enjoy Linux much better if I can figure out how to use it!!!


  • Goineasy9
    Goineasy9 Posts: 1,114
    Navigating Linux menus, is no different than navigating Windows menus, although sometimes the names of programs can be a little difficult to get used to. GIMP, for example, is a premier graphics application, but, you'd never know it just from looking at the name.
    I haven't seen a Mint install in a while. I use Fedora Linux with a KDE desktop environment and most of the menu items now come up with their description and the application name as a subtitle. Is this where your confusion starts?
    The best way to find out how Mint works is to click on icons and see what's underneath them, see what programs come up. Go through the menus and do the same, cancel out after you take your first look. Mint is made especially for new users so, it should be easy to navigate.

    Maybe what you ought to do is give us some specific examples of what's got you pulling your hair out. We can probably be more help with problems we can address first hand.

    You might also want to look at the Linux Mint User Guide, link here:
    Like I said, Mint was made for users that are new to Linux, and, their documentation is written so it's easily understandable.
  • squeek78
    squeek78 Posts: 11
    edited March 2012
    You're right, it is set up similar to Windows, and it is the unfamiliarity of the names that are used more so than how it works probably, althought, I do still have a long way to go before understanding how to do many things, regardless of the OS, so doubly confusing I guess.
    Occasionally, in the lower right corner, something about the nepomunk shows up-its not currently up, so I cannot say for sure what it says-have no clue about nepomunk.
    When I try to open different downloads, apps, documents, etc., it asks me to choose what to open it with, and lists everything, and seems to want specifics as to what to use to open the program, but having no idea exactly what I am looking for, as well as what it would be called is very frustrating-seems like in Windows maybe there were just more defaults, and less choices, wow, not meaning choices are a bad thing, just overwheming when you dont know what you're doing.
    Another thing I am having trouble locating is the system information-how much hard drive free/empty, RAM? Haven't been able to locate that anywhere, as well as a system restore, or disk defrag (read shortly after my post that no defrag is needed with Linux?)
    So far I have noticed a few instances where holding the cursor over the icon gives a little description, and I have explored, and discovered how to do a few things-Im determined to learn, just taking in a lot at a time.
    My cousin sent me her very nice laptop to use for school when she upgraded, as my 4 year old seems to have taken over the laptop with Windows (Vista). Whatever OS she was using she kept for her new laptop, and she installed Linux Mint 12 so I could use, however encourages me to install Windows if I have trouble with Linux, as she is unfamiliar as well. And so far all the computer classes I have taken at school have been Windows based, some even inaccessible without Windows.
    Once again-any help appreciated, and I will def be looking over the links posted...I think what I am looking for is something like a Linux for Dummies maybe?
    And what is Root, terminal?
  • Goineasy9
    Goineasy9 Posts: 1,114
    edited March 2012
    Sorry, I've had some long work days which are limiting my time online. Let me see if I can answer some of your questions.

    Nepomuk is a way of indexing files and folders to make desktop search quicker. There's really nothing you need to do, it works in the background.

    As far as the "Open with" - you have to get used to the application names that certain files open with. Usually the choices given are the correct applications and you can choose any of them. Text files will give you the choice of apps like kwrite or kate, both will open text files. They'll also open program files, as they were developed to be able to deal with program languages such as Python and C++ or Ruby etc. HTML files will give you a choice of using Firefox or Chrome or Konqueror or Opera etc. MP3 or other sound files will give you the option of opening them in Amarok, or mplayer, or VLC. All will open and play sound files, and, mplayer and VLC will also open and play video files.

    In KDE, I have "Disk Utility" or "Disk Usage Statistics" or "Kinfocenter" or Kwikdisk" that show disk usage. I also have gkrellm installed that shows RAM, CPU usage, Temperature, Voltage, Time online, Memory used. I find this very useful and keep it up on the screen at all times. There is no defrag in Linux, no need. Fragmentation is so low with Linux file systems that we don't worry about it.

    BTW - In KDE "Dolphin", or in Gnome "Nautilus" (File Managers) can be configured to show you the file size or folder size and room left in your partitions. If you go into Settings in either app, you'll find the configure entry. Play around with the configuration. Once you apply the change, it will show up, so, if you don't like what you see, you can set it back immediately. If you go into "View" in either of their menu's, you can set the information that appears on or under the icons to display info that you might want to appear each time you open the file manager.

    Root is your system administrator. It is a user just like you are on your machine. One of the reasons Linux is so secure is that the system files are owned by root, the system administrator, and, unless you log in with root privileges, you cannot access and change system files. Windows also has a system administrator, unfortunately, it is not as secure as the Linux based root. I'm just touching the surface here, but I guess it's a start.

    If you want us to explain more, just ask, I'm sure others who are just starting can use the info also. Heh, just be patient, we have outside jobs like everyone else, so, we are not always here to respond right away, but, we do like to share our knowledge.

    Keep us posted on how you're doing.
  • squeek78
    squeek78 Posts: 11
    I completely understand having other things to do, and completely appreciate you taking the time to provide assistance in learning how to use Linux. I am working towards a business degree, mostly online, and trying to transition from windows vista to Linux Mint 12, with until quite recently, limited exposure to most computer related activities.

    I occasionally get a notification that Nepomuk has been disabled, (some dialogue underneath). Now that I have an idea of what Nepomuk is, I should probably enable it? How? How did it get disabled?

    I get another notification "could not find a usable proxy configuration script". That usually pops up when switching between sites/pages on the web. Wondering if that could just be due to the wifi not keeping a constant connection? She did mention the wifi card was cracked, making it impossible to maintain a constant internet connection, which affected her with gaming, but wouldn't interfere with schoolwork, etc.

    About opening files-I found something on the Linux site that I was interested in, Stellarium. I downloaded it (accidentally several times I believe). I found where it is stored on the computer, in many files, but cannot figure out how to use it. I tried opening it, obviously with the wrong thing, and it went beserk. It seemingly planned to go beserk for a long time, until I restarted the computer. I believe I chhose something under the heading media player-should I have chosen a different option. Choosing between which (of many) files associated with the download, and matching with each option to open with seems to quickly become a tedius/wary task of process of elimination-I need to learn how to do this better to do many things I have tried to do.

    I mentioned on another thread I was looking for a snipping tool. I followed the link provided by another helpful member, chose which tool I wanted to use, but cannot figure a way to download, then I will probably need help learning where it is-how to get it to where I can use it.

  • marc
    marc Posts: 647
    Hey squeek78, I'll be quick and might seem rude but it's only because I'm busy!

    I see you are using Linux Mint <--- that's a Linux distribution, aka (also known as) "distro" (a question from another thread)

    You say that you have trouble with nepomuk... I guess you are using KDE (K Desktop Environment) (please confirm: are you using this? http://blog.linuxmint.com/?p=1927 )

    I would suggest to disable nepomuk as of right now to minimize the things we need to check. SystemSettings -> Desktop Search-> Uncheck "Enable Nepomuk Semantic Desktop" and reboot the machine. (nepomuk is usefull but we need first to figure out what's wrong with your internet connection and we want to avoid other things in between ;) )

    For the proxy thing: SystemSettings-> Network Settings->Proxy... what do you have selected here? try with browsing without a proxy :)


  • marc
    marc Posts: 647
    OffTopic: where did you get the laptop?

    I'm amazed on how outside Spain people cat get computers without windows on them... and with linux!!!
  • squeek78
    squeek78 Posts: 11
    Thank you-that was very helpful! I followed the directions you gave-the box wasnt checked, therefore nepomuk wasnt enabled at all, so enabling it may fix the problem.

    As far as the proxy thing goes-the box that is checked says automatically detect proxy configuration, then prompt as needed.

    As far as where the computer came from-my cousin sent it to me. From what I understand she had this computer built for her. She recently needed to upgrade and sent me this one. She kept her OS, but loaded Linux for me. She said the only thing that is really wrong with it, is the wifi board is cracked and may, at times lose a connection.

    I thank you very much for your time and assistance.
  • Goineasy9
    Goineasy9 Posts: 1,114
    If the only thing that is wrong with the laptop is the wifi card, you can always by a usb wifi stick to take its place, they're not expensive.
    As far as the proxy thing. Maybe the checkbox for using a proxy was accidently checked, or something was put in the proxy address box so it thinks you want to use a proxy. Check and see. If the box is checked that is on the line with the proxy settings, uncheck it and see if that gets rid of the notification. If not, you can use the screenshot apps that I talked about in the other thread and take a picture of the message and post it here. At least then we would be able to tell you exactly what's going on.
  • mfillpot
    mfillpot Posts: 2,177
    Wow you, you guys have been busy with this thread.

    I did not see anyone touch on the software installations, please remember that windows .exe based software does not work out of the box in Linux based systems. When using Linux Mint KDE you will use the software manager (which is documented in the user guide) to find and install software from a trusted online repo, there will not be a need to download any files from websites.
  • squeek78
    squeek78 Posts: 11
    Ok, so I got the nepomuk to stop alerting (checked a box), I switched the proxy box to be the one that says 'connect to internet directly', so far I haven't seen the message again just yet, so that may be good as well.

    I found where to get to the software manager, and how to view the different programs available, as well as those installed on the computer. When I click on a program I want to use, nothing happens-doesn't matter what I click on, no change.

    Any ideas?


Upcoming Training