Welcome to the Linux Foundation Forum!

(SOLVED) Arch doesn't recognize root fs

Spartacus1 Posts: 20
edited March 2012 in Installation

Hello to all!

For some odd reason, my recently installed arch won't recognize it's root filesystem. I installed arch on /dev/sda10

GRUB 0.97 Config (arch line):

title Arch Linux
root (hd0,0)
kernel /vmlinuz-linux root=/dev/sda10 rw vga=795
initrd /initramfs-linux.img


tmpfs /tmp tmpfs nodev,nosuid 0 0
/dev/sda10 / ext4 defaults 0 1
/dev/sda1 /boot ext4 defaults 0 1
/dev/sda12 swap swap defaults 0 0

Thanks for the help!


  • Goineasy9
    Goineasy9 Posts: 1,114
    edited March 2012
    Your root is pointing to the first partition (hd0,0). I'm not positive about the pointer, but, if root for arch is on sda10, then, shouldn't root point to (hd0,9)? I'm assuming that's where you installed grub when installing arch. You're not showing us what the other partitions are doing, so, I'm just assuming.

    Edit: Or did you install grub to /boot, along with bootloader options that point to other distros?
  • I have set up a separate /boot partition on /dev/sda1
    Thanks for the quick response
  • marc
    marc Posts: 647
    Might it be possible that the count starts in your sda1? (just a random though, might be a stupidity)

    However... why don't you use UUIDs? that doesn't change ever!
  • I've tried UUID, same result
  • I'm in!
    I had to add the hook "usb" to initramfs.
    Thanks for the help!
  • marc
    marc Posts: 647
    Is your hard drive a usb one?


Upcoming Training