Welcome to the Linux Foundation Forum!

Elinks crashing with javascript enabled


I using Fedora 16 64 bit and elinks crashes when I have javascript enabled. I have tried compiling both elinks and javascript (Spidermonkey, ECMA-script) with the same results. There are no upgrade packages for either. Has anyone else this problem or know what I can do? I use elinks a lot because I have a dial up internet connection. Graphical browsers are required for some things but I like to use elinks when I can because it is so much faster with dial up. I have posted this problem on two other forums with no helpful replies. Thanks in advance.


  • Goineasy9
    Goineasy9 Posts: 1,114
    elinks 0.12-0.26.pre5.fc16 is in my F16 repositories. It's going to be hard to find many folks who are still using dialup with Fedora who will have the same problem you are having, so, I'm not surprised you haven't gotten any helpful replies.

    Your self compiling of these programs might be one of the problems, as Fedora tweeks it's applications so they compile properly with the way Fedora sets up its distro. Since you know how to compile you're own applications, you must be aware that compiling from source is a bit troublesome since the packages in the fedora repository may be patched to work properly, and, the ones you're compiling from source may not have the same patches, or, any patches at all.

    I have to admit, I'm not qualified to help you with the javascript problem, since I don't play with it at all. If you're patient there might be some folks around who do use it and can help you with that aspect of it.

    If you look at the Changelog for the most recent elinks on koji:
    You'll see that a the js patch was improved (I'm assuming that is a javascript patch), so, there might be a bug that's being worked on.

    There seems to be only one bug reported for this version of elinks:
    Which may or may not have something to do with javascript, but I'm not experienced enough with it to tell.

    You can always sign up on the bugzilla and report your problem and see if you can get a technical answer from them. If it's suppose to work with javascript enabled, and it crashes, then it's a bug worth filing. The main page for sign up and search is here:

    You may want to start by removing your compiled version and installing the official version of elinks from the fedora repos and use that version for further testing. BTW - it seems that the version for the forthcoming F17 is no different than the one available for F16, it was just rebuilt for F17. Actually, from what I can see, the version in the fedora repos is the latest upstream version, so, there is nothing to gain by compiling it yourself.

    And like I said before, if you are a bit patient, someone more familiar with elinks might drop by and give you some better info than I'm able to. So, let's see who else responds.

    Hope this at least helped a little.

  • SharpyWarpy
    Thank you, GoinEasy9 for your reply. I compiled elinks a couple of different ways, one to make sure the js patch was applied. I untarred the tarball from the Fedora source file and patched with the js patch before conigure and make with no difference in behaviour, and I compiled the Fedora source rpm with "rpmbuild --rebuild" and no joy. I tried compiling the stable version -- 0.11.2 -- and it errored out with javascript errors. I will preuse the link pertaining to the bug and also the https://bugzilla.redhat.com/ site. I'll sign up for the latter and report back here if I find a solution. Thanks very much for the informative post.
  • SharpyWarpy
    I registered with Bugzilla and submitted the bug. It was eventually solved. Here is the URL:
    It was fixed with a change to the patch for js-1.8.5. An update will be available in the Fedora Update repo in the next day or so.
  • Goineasy9
    Goineasy9 Posts: 1,114
    Good going. When I started using Fedora I registered with the Red Hat Bugzilla and have had a few problems solved that way myself. Your also helping others by reporting problems and getting them fixed. Open Source is a community experience, reporting bugs is part of that, welcome to the community.


Upcoming Training