Welcome to the new Linux Foundation Forum!

X11 session manager

I had an old Sony Vaio a PCG-F801 which would only boot from Hard drive or floppy. I decided the only way was move the HD to a Toshiba laptop and install Zenwalk. This I did an reinstalled the HD back into the Sony, twice. The first time I allowed xorg to choose display, the 2nd time I set it to svga. On both occasions it seemed to load everything until it reached xorg and then went into a loop, the difference being that with svga the xorg symbol reacted to mouse movements.

If someone knows the answer to my problem could you please spell it out in detail, as this is is my first attempt at Linux and I know absolutely nothing about command lines, even how to get there, but willing to learn.

Some details I know.- 12.1"LCD TFT screen, 3D-graphic accelerator with shared video memory.

Comments

  • Goineasy9Goineasy9 Posts: 1,116
    edited February 2012
    This is what I found when searching for your laptop.

    From: http://reviews.cnet.com/laptops/sony-vaio-pcg-f801/1707-3121_7-31103195.html
    Sony VAIO PCG-F801 - 12.1" - K6-2+ - Win98 SE - 64 MB RAM - 6 GB HDD

    That 64mb of RAM might be your problem. Zenwalk requires 128mb of RAM as a minimum.

    You might want to try AntiX or Puppy Linux. Their minimum requirements might fit the 64 mb of memory. Myself I would try AntiX, as I have installed it on an old Thinkpad i1413 which had low memory and a 6Gb hard disk. I forget how much memory it had, but the creator of AntiX has said that it will install with even 64mb, even though that would be pushing the minimum requirements.

    Home page for AntiX is here: http://antix.mepis.org/index.php?title=Main_Page

    Download mirror (One of many, but I'm posting the link so you know which version to download):
    http://mirror.cs.vt.edu/pub/MEPIS/antix/
    Look for this version - "antiX-M11-486.iso"

    Since you're learning, you should try the version I suggested, although on the AntiX home page, it states that machines with K6 processors might have to use the new Core version, then build on that until you've reached the limits of memory. Hopefully, the M11-486 version will work out of the box for you.

    The other problem that I see you might be having is installing it on a laptop with one type of video card and then moving it to a laptop with a different video card. While in normal circumstances this shouldn't be a problem, the low amount of memory might be hindering the video. Sometimes adding the vesa cheatcode to the kernel line at the grub menu might help with that problem.

    It's difficult explaining to a beginner, but, when Linux is booting up, the grub screen, which contains the kernel that is being used, comes up for a few seconds. It's one of the first screens that you see during boot up. There will be options listed at the bottom, such as, to edit the boot line, change parameters etc.. If you press "e" (different on different distros, but it may be the same in Zenwalk) you can go to the line that starts with "kernel", and, after leaving a space write xvideo=vesa at the end of the line, then press "enter" or F10 to boot the kernel with the new vesa option. It may even help with the booting of the Zenwalk distribution you are using.

    Hint: When you see the Grub screen (The one with the kernel choices, or it may have a memtest option, or a safe booting option), if you press the down arrow, then the up arrow, it will suspend grub and let you read what the options are. You can then add the vesa option and press the option to continue to boot.

    BTW - If this all seems confusing, it is to me also. I don't have a Zenwalk install in front of me, so, I'm just passing ideas. If you have any specific questions after looking for the grub screen and can tell us what you find, I may be able to give you some more specific instructions. I'm sorry, but I looked at the Zenwalk site, and, couldn't find any pictures that would show me what their default grub screen looks like. If this seems to be too complicated for you as a beginner, you may just want to download AntiX and start from scratch.
  • Thank you for your carefully thought out reply, you have certainly given me a lot to think about. Regarding the Ram I had already upgraded the laptop to 256MB in it's previous life, and also when I installed Zenwalk on the other laptop I removed the HD into the Sony prior to it rebooting. I don't know if this was wise but it was the only way I could think of to avoid it loading everything from the surrogate laptop. The boot loader is Lilo, and at this point I hav'nt had time to check if it has options.I will follow your suggestions and should I get stuck I would like to contact you.
  • Goineasy9Goineasy9 Posts: 1,116
    Hi alawor

    I'm not familiar with lilo, although I know one of the mods using Slackware is. Hopefully, he'll see the thread and give an opinion. Lilo was used many years ago before grub came around, so I missed playing with it, and I have so much more to learn myself, that I don't really go back looking at the older technology. A quick look at the lilo man page shows a vga cheat code, but that deals with screen size and doesn't seem to have xvideo graphics options.

    It's good to hear that you have 256mb of memory. It makes running Linux a lot easier. My old Thinkpad had 256mb of memory (I just looked), and it was able to run AntiX quite well, even with its 4.6 GB hard drive (Heh, you got me to look at that also). It uses Fluxbox as the DE, and , while it's not as full of eye candy as KDE or Gnome, it's certainly full functioning.

    I just Googled for Zenwalk pics and came across this article: http://www.halterlein.net/misc/tech/zenwalk_thinkpad.html . A couple of paragraphs down it explains the importance of answering the framebuffer question during install as "No", and then explains what problems arise from answering "Yes", which is easy to do since it is the deafult answer. I may be pushing the coincidence factor here, but, do you remember the answer you gave? It just may be the answer you were looking for.
    Quoted from the article: "Bottom line is that if you have an older Thinkpad, or an older graphics card in general, make sure that you select the NO FRAMEBUFFER boot option during the Zenwalk install process. Otherwise, you'll run into these same problems."

    You may just need to reinstall and choose the correct answer ("NO") and you may not need to switch distros. Just a thought.

    BTW - If you get stuck, putting a question here in this thread is the easiest and fastest way of contacting me, since I'm subscribed to the thread. I get emails when a new post comes in. Besides, you're not the only one trying to get Linux to run on an older computer and we like sharing the solutions here in the forum.

    Anyway, keep us posted on how you make out.

    Tom
  • Hi Tom
    I hav'nt solved anything with Zenwalk so I have downloaded and burnt to disc Antix as you suggested. Once again I will have to remove the HD from the Sony and load from my other Laptop to install. I have tried the Live disc and it looks interesting, but how do I install it to the HD. Will it install over the Zenwalk or will I need to partition the drive, something I am not familiar with. Should it run on the Sony, how would I connect to my LAN? I know I will get familiar with these things once I am up and running, but getting there is the problem.
    Sorry to dump these problems on you.
    Alan
  • Goineasy9Goineasy9 Posts: 1,116
    You can install it the same way you did Zenwalk. I believe AntiX uses the Mepis installer which will allow you to do an automatic install, where it configures the partitions and sets it up for you before the actual install starts. Choose the automatic install option, and if you are asked any other questions, just choose the default option. After it's installed, then you can worry about networks and wifi drivers etc.
  • mfillpotmfillpot Posts: 2,180
    Sorry for the delay in reading this thread, I have been busy with other things.

    Lilo requires framebuffer support to operate, if you are unsure of the optimum resolution you will use the option "vga=normal" which will just use the framebuffer settings.

    As for installations on your computer, installing on another machine would be easiest, but if you have lilo or grub installed on the disk then you can extract a usb based installer onto the disk and configure the bootloader to boot the image for a full native installation.
  • woboylewoboyle Posts: 501
    Have you looked for a BIOS upgrade that will allow either CD or USB booting? I've had to do this in the deep, dark past.
  • Thanks for all your answers. The BIOS upgrade I have looked for ,there isn't one, so I have decided for the time being to use AntiX on the Sony. I have installed AntiX and got it networking, but now I find I have no sound card driver. The card is a ES9835 Maestro-3 which I downloaded the driver on to my iMac, it gave me a tarball? which I clicked on, it unzipped it or untarballed it, whatever. This I copied to a USB stick, which I mounted in the Sony laptop. I got alsa-firmware-1.0.16, which when clicked gives all sorts of folders and options. So my questions are what do I do next?, and assuming I have got it right so far, where would the driver be installed?.
  • Goineasy9Goineasy9 Posts: 1,116
    I know your still new to Linux, but the link below explains how to get the snd_maestro module working in Debian (which is what AntiX is based on). The driver was originally in the kernel, but, was then removed due to licensing problems. It seems one had to go through the compiling motions in order to get it running. The alsa-firmware you downloaded should be unzipped on the Linux machine, not on the sony. If you have the machine attached to a network, you can just copy/paste the commands (from the link provided below) in a terminal and download the newer file and use it with the rest of the instructions.

    http://wiki.debian.org/snd-maestro3
Sign In or Register to comment.