Welcome to the Linux Foundation Forum!

Syncronizing Creative zen mp3 player to Banshee

stellla Posts: 28

Hello again,

I have been trying unsucessfully to syncronize my mp3 player to Banshee to transfer the music. Everytime I mount the device, the program closes. It shows up on my laptop and even on Unity as an added device. I can open the device with Banshee,too. It showed up a couple a times for a few seconds, but closed before I had a chance to do anything. I had no problems on my desktop. I am presently using wifi, could that be the problem? Do I need ethernet? Is there any command that I can use,(I am presently learning how to use the terminal.)

Any help would be greatly appreciated.




  • Goineasy9
    Goineasy9 Posts: 1,114
    What operating system is running on your desktop? Most likely your mp3 player is using a windows based filesystem, such as, ntfs. There is a utility in Linux that helps read ntfs filesystems call "ntfs-3g". It might be named slightly different on Ubuntu. I run Debian Sid, which Ubuntu is based and the program is called ntfs-3g. Take a loook in your Add/Remove Software application (Package Management) and see if ntfs-3g is installed. Or, in a terminal, type:
    apt-cache policy ntfs-3g
    And the result will tell you if it's installed or not.

    If it's not installed, install it from the package manager, and see if it helps. If that is not the problem, give us some more infomation about the mp3 player (Brand, model number etc.) and tell us about the desktop that it's working with. The fact that is appears then bombs out when you try to mount it is curious. I would suspect that it wouldn't show up at all if ntfs-3g wasn't installed, but, most of my installs come with ntfs-3g, and, I've never had your particuar problem.

    It also might just be a configuration problem. I'm not an Ubuntu user (some here are), but, if there's an option in the settings for automount of removeable devices, make sure that is enabled. That may make a difference.
  • stellla
    stellla Posts: 28

    I solved the problem with gMTP media apt. I had to import each song seperately, but it works. You can't make playlists, but that's ok. Sometimes it's not necessary. Sometimes less IS more.
    I did everything you mentioned, maybe that helped too. All those apts and packages are installed.

    Thanks again,

    (Hopefully, my experience will help others who have similar problems... just because a distribution has a certain apt as default, it doesn't necessarily mean we must use only that. Linux has many nice apts, some are more complex than others... and some are really quite simple.)

  • Goineasy9
    Goineasy9 Posts: 1,114
    Congrats on solving your problem, and, yes, it will help others will similar problems. I found that app on sourceforge and in Debian, but, not in the Fedora repos. I'm glad you found it. It's not the first time I didn't have an answer concerning mp3 players.



Upcoming Training