Welcome to the Linux Foundation Forum!

Problem installing ubuntu server

Hi i am trying to install linux server 10.04 on a tower i have but having problems.

I have set up a usb stick and boot to it and get the language selection screen then the option to install ubuntu server it goes through the keyboard setup and progresses through the network setup it then asks for a mirror to access archives or something and says its downloading but just sticks at 0% i can not get past this point i have even tried different countries but still the same

alo tried burning the iso to disc and it does the same thing

I have also tried a more uptodate version and the upto date version once selecting install ubuntu the screen seems to go off as if the resolution is not supported and sticks there

can anyone at all help me please

thanks in advance


  • marc
    marc Posts: 647
    Might sound stupid but... are you sure you have internet connection?

    ctrl+alt+fx to get to a terminal and try there ;)

  • well i have vista running on it now and the internet works fine but going through the installation process i'm not sure how to check
  • woboyle
    woboyle Posts: 501
    This may be due to a bad download of the .iso image file. You need to verify the md5sum, sha1sum, or sha256sum checksum for the image with what is posted on the download site for that image. I have often had downloads of iso images that seemed to work, but generated the wrong checksum, so I had to download them again.
  • I have downloaded now 7 copies of linux server and come up with the same results can i just ask what is the archive download trying to download ?
  • marc
    marc Posts: 647

    Are you on ethernet? on wifi? do you use dhcp? static ip? do you have any kind of firewall no your router? or maybe you are connecting directly to internet...


  • i am on a wired connection straight to my virgin media super hub dhcp connection the internet works fine on the tower in vista so i have no reason to think its not working during the installation
  • marc
    marc Posts: 647
    ...so i have no reason to think its not working during the installation...

    Yes you do have reason to think it's not working: you cannot download the files neede!

    First thing you should do is test the internet connection, the dns config in /etc/resolv.conf and these kind of things.


    PS: no offense but... why do you ask for help if you are not going to listen to suggestions?
  • I am quiet willing ro try any suggestions just another question though how can i test the connection when i can not finish the installation ?
  • mfillpot
    mfillpot Posts: 2,177
    You can test the connection by booting a live CD of the same distro and checking the network connection state or seeing if a webbrowser can connect to the internet.

    Now one question seems to have been avoided, have you used a tools such as md5summer to check the md5sum of the ISO after it was downloaded and used the verify function in your cd burning software to confirm that the file was not corrupted when downloaded or written?
  • check sum is

    881D188CB1CA5FB18E3D9132275DCEDA *ubuntu-11.10-server-i386.iso
  • mfillpot
    mfillpot Posts: 2,177
    Did the checksum match the official checksum from the server you used?
  • Yay had some success with this i have now got linux ubuntu server succesfully intalled on the tower although as earlirt suggested it seems i have no internet connectivity i have tried with dhcp and also with setting to static ip but nothing i do seems to get it online i have tried to ping google but it wont ping

    i use these instructions to set to static

    1. give your server a static ip. put this line in and press enter

    nano /etc/network/interfaces

    change the dhcp to static then under it put like this

    ofcourse these are my ips so please change to your own ips

    once done hold ctrl+x press y then enter
    now to restart network put this line in

    /etc/init.d/networking restart

    but the restart fails
  • mfillpot
    mfillpot Posts: 2,177
    It still sounds like the ethernet device either is not registering a driver or that the driver may have issues. Can you please try the command "sudo lspci -vvv|grep -i ethernet -A 35". This will check your pci hardware and output the 35 lines following lines matching the word ethernet, you can adjust the number 35 to how ever many lines are necessary to get to a blank line following the end of the description.

    Once you get that information, please paste it here so we know what hardware you are using and what driver is in use.
  • yay have finally got this sorted the problem was a typo in the interfaces file

    auto eth0
    iface eth0 inet did read

    auto eth0
    iface eth0 unet static

    so i changed it to inet and its all working now

    thanks everyone who contributed in suggestions :)


Upcoming Training