Welcome to the Linux Foundation Forum!

Display on ssh [SOLVED]

linuxque Posts: 10
edited January 2012 in Command Line



Shell - csh

distro - rhel 4.5

Applications like adobe, open office which are on Server, are added in client machine's .cshrc file

When ssh'ed from machine "A" to "B" as a normal user, i am able to open the documents related to pdf but not able to open office org documents (excel, doc's etc)

I have couple of questions:

a) Is Open office org not supported or am I missing a trick?

b) My ssh syntax is ssh -X @. Is it a good practice to use -X? They say it opens up security, so any hacker can keylog...

Kindly elaborate...




  • saqman2060
    saqman2060 Posts: 777
    edited January 2012
    To answer your first question, openoffice.org 2.0 is compatible with RHEL 4.5. You will have to download the package from the rhel repos. To open any gui app via ssh, you have to set "FORWARDX11 THROUGH SSH=no" to "yes" from /etc/ssh/ssh_config or from your local profile.

    As for using "-X" to forward X11, use -Y which will ensure X11 is forwarded with security restrictions.
  • Thank you very much...It worked


Upcoming Training