Welcome to the Linux Foundation Forum!

Realtek RTL8188SU 802.11n WLAN Adapter


I've just installed Backtrack on my Vmware.

I need to install a driver to my wlan adapter because backtrack doesn't support this driver.

I have downloaded the driver and placed it on the desktop.

I'm very new to the Linux enviroment so I hope you can give me a newbie guide to installing a driver from the command prompt.

I've tried to locate a step-by-step guide in the read me file but I can't find anything.

The driver is named:


I've tried to post in the backtrack forum without any luck.

Best regards:



  • woboyle
    woboyle Posts: 501
    This site has most of the information you need: www.linuxwireless.org

    In any case, this file is a compressed tar archive. You need to decompress it and then run the configuration and/or installation scripts - usually using the 'make' command. Example (assuming the file is on your desktop):
    tar -zxvf rtl8712_8188_8191_8192SU_usb_linux_v2.
    cd rtl*
    # if you are not root, then switch to root or try sudo
    make install
    Then reboot your system.
  • zubmit
    Thank you very much for your support.
    I get an error because there isn't a folder called configure so I can't install the driver.

    These are the folders located in the driver:

    I will also look at the website you linked to.

    Thank you kind sir (:
  • saqman2060
    Make sure the gcc compiler is installed to compile the package.

    #whereis gcc

    If you don't have it, install it using your package manager.


Upcoming Training