Welcome to the Linux Foundation Forum!

64-bit CPU confusion

I have hit a bit of a confusing point while trying to virtualize Gentoo and Slackware under QEMU+XEN and VirtualBox.

Whenever I try to run them, they report an error saying that my CPU doesn't support 64-bit instructions, yet I am using OpenSUSE 64-bit (Native) without any errors or issues.

Any thoughts on what I should do?



  • marc
    marc Posts: 647
    Maybe your qemu configuration is not 64bits ready?

  • RSims
    RSims Posts: 146
    Did enable virtualization in your bios?
  • @marc:
    I tried to append "-cpu qemu64" to the program and still no go. I also built qemu from source.

    I don't think my CPU has virtualization instructions, but I have successfully virtualized 32-bit OSes before

    FYI: I have a Intel Pentium D 820 dual-core CPU
  • Should I just burn a DVD and see what result I get? And if it works, install them naitive? (I have LOTS of disk space on my HDD)
  • RSims
    RSims Posts: 146
    You need to check your BIOS and see if you can find an option for virtualization and enable it if you do have this option. If you do not have this option than your cpu does not officially support virtualization and could be the reason your having weird issues such as being successful in 32 bit but not 64 bit.

  • mfillpot
    mfillpot Posts: 2,177
    In order to run 64-bit guest operating systems your CPU and bios must both support the virtualization option. In some cases you will need to enable it in the bios.
  • Virtual box doesn't support 64 bit guests. You can quickly see what your cpu supports by using cat /proc/cpuinfo, 'vmx' is Intel's virt flag. Of course your cpu may support it but the bios may not depending on the make.
  • mfillpot
    mfillpot Posts: 2,177
    As I stated above, virtualbox does support 64-bit guest if your hardware is configured to allow it by enabling the virtualization features.


Upcoming Training