Welcome to the new Linux Foundation Forum!

LILO configuration in Slackware

Hai,

Due to some discussions about Arch linux with other distros, I just decided to give a try with Arch to see what are all the things it has. And more over I installed Ubuntu too .

I tried to configure the lilo but I can not able to do that. Currently Ubuntu boot loader is in MBR. And it list all the OS that I have. But, I want the lilo to be in MBR. Here are my sda details,

sda1 - Windows 7

sda10 - Slackware

sda13- Arch

sda14 - Ubuntu

sda15- Fedora - [ / - partition ]

sda16 - Fedora

In LILO , currently I have

#Slackware
image = /boot/vmlinuz
root = /dev/sda10
label = Slackware
read-only

#Windows
other = /dev/sda1
label = Please_DO_NOT_CHOOSE
table = /dev/sda


To configure Fedora15 in lilo i added,

image = /vmlinuz-2.6.38.6-26.rc1.fc15.i686
root = /dev/sda15
label = Fedora_Love_Lock


And for Arch,

image = /boot/vmlinuz26
root = /dev/sda13
label = Arch_Linux


when tried to install lilo, I got

fatal : open /vmlinuz-2.6.38.6-26.rc1.fc15.i686: No such file or directory


I tried with giving absolute path,

image = /dev/sda15//vmlinuz-2.6.38.6-26.rc1.fc15.i686

and I got

/dev/sda15//vmlinuz-2.6.38.6-26.rc1.fc15.i686 - Not a Directory


If I comment the Fedora config then I get the same error for Arch linux too.

How can I configure all 5 OS in lilo.

Thank you

Comments

  • chekkizharchekkizhar Posts: 182
    ok. By referring Slackbook, I used "liloconfig" to configure the system. The only difference is,

    Instead of
    /vmlinuz-2.6.38.6-26.rc1.fc15.i686 
    
    ,
    the "liloconfig" loaded
    /boot/vmlinuz/
    

    I took those from Ubuntu GRUB loader config file.
    But, the lilo is looking for, "/boot/vmlinuz" only. Need to dig around with this more.
  • mfillpotmfillpot Posts: 2,180
    Lilo is reading the current root partition when writing the mbr image, which is why you are getting the error message.With lilo I store all of my boot images onto a single partition which is mounted by all OSs to avoid this issue.

    However since Ubuntu is the default you should be able to use the os-probe option for grub2 in Ubuntu to have it detect and append the other operating systems to the boot loader.
  • chekkizharchekkizhar Posts: 182
    I tried to edit Ubuntu [ though It listed all correctly, I want to change the label name ] . But, its like a Essay . Though it was easy to understand that, I want the lilo, which is very very cool boot loader screen .

    I managed to load all Linux and one NTFS os in lilo and currently things are going fine.
    So far not booted with Arch . Need to give a try in weekend.

    I was unaware about the reason for the error . Thanks for explaining that. And thats a nice trick .
  • mfillpotmfillpot Posts: 2,180
    Now that I think about the issue I may have taken the hard approach, I know that it does not see the other partitions because they are not mounted, thus it cannot verify the records. What I would like you to try is mounting the other partitions within slackware before running the update command, if this works then the problem would be due to limited visibility.
  • chekkizharchekkizhar Posts: 182
    I added all of my Linux and NTFS partitions in fstab and during boot time all are get mounted automatically. And when updating LILO I cross checked the availability of the partition. It was there.

    I took,
    /vmlinuz-2.6.38.6-26.rc1.fc15.i686 
    

    from UBUNTU GRUB conf. But, LILO is always using
    /boot/vmlinuz/ 
    
    But, still there are some problems with Arch and Fedora . I am trying to solve . If not get done, I will get back to forums concern threads.
Sign In or Register to comment.