Welcome to the new Linux Foundation Forum!

Trying to get load HylaFax 6.0.5 on Fedora 15

kd5ywakd5ywa Posts: 28

OK... I hylafax 6.0.5 and this is what I get now...

"Compilation of the following test program failed:

----------------------------------------------------------

#include

#include "tiffio.h"

main()

{

printf( "header_ver=%d lib_ver=%s", TIFFLIB_VERSION, TIFFGetVersion() );

exit(0);

}

----------------------------------------------------------

TIFFINC=

LIBTIFF=-ltiff

Verify that you have the TIFFINC and LIBTIFF configuration parameters

set correctly for your system (see above) and that any environment

variables are setup that are needed to locate a libtiff DSO at runtime

(e.g. LD_LIBRARY_PATH). Also be sure that any relative pathnames are

made relative to the top of the build area.

Unrecoverable error! Once you've corrected the problem rerun this script."

What does this mean and how do I fix it????

Comments

  • kd5ywakd5ywa Posts: 28
    well I figured out that part... and then another part, and now I am at an impass.

    I need a Internet Fax service like "Extreme Fax" ... one that will allow me to send faxes and recieve them via the internet.

    Any ideas for Fedora 15?
  • Goineasy9Goineasy9 Posts: 1,116
    Any fax service that would work with Linux would work for Fedora 15. I'm sorry, but I don't use the fax anymore since I can scan and attach a document in email. Hopefully someone else can come along and give you a suggestion from experience. A quick search gave me the name of eFax:
    http://www.efax.com/
    The wiki says it has GUI's for Linux based programs.
    http://efax-gtk.sourceforge.net/
    Like I said I never used it, but, it may be worth looking into.
  • kd5ywakd5ywa Posts: 28
    OK, it tryed out the GUI's for Linux based programs for the efax, and I try to configure it in the terminal for install, and the last thing it said was....


    configure: error: Library requirements (gtk+-2.0>=2.12.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libararies are in a nonstandard prefix so pkg-config can find them.


    any ideas what to do now?
  • Goineasy9Goineasy9 Posts: 1,116
    Try "yum info installed gtk+" and see if you have gtk+ installed. If it comes up empty do "yum install gtk+". My default install did not include gtk+.
    Then try again, and let us know how you make out.

    Edit: Just to make sure, doing yum info installed gtk+ is in terminal, either as user or root. yum install gtk+ needs to be done as root in the terminal.
  • kd5ywakd5ywa Posts: 28
    It did not come up empty, but looked as though it loaded, but I tryed the configure of the efax again and the same error message came up.
  • kd5ywakd5ywa Posts: 28
    It said this....after I did the "yum info installed gtk+"

    Loaded plugins: langpacks, presto, refresh-packagekit
    adobe-linux-i386 | 951 B 00:00
    rpmfusion-free-updates | 2.7 kB 00:00
    updates/metalink | 17 kB 00:00
    updates | 4.7 kB 00:00
    updates/primary_db | 2.9 MB 00:47
    updates/group | 1.8 MB 00:28
    Error: No matching Packages to list
  • kd5ywakd5ywa Posts: 28
    Ok I succeded at installing the efax, but now I am having a problem with it... the efax....

    And I seem to have this problem with other programs, such as my user doen't have access, such as admin powers...

    my new error message in efax says...

    "can't open pre-lock file /var/lock/TMP..02286: Permission denied"

    it is like I don't have access to my own documents!
Sign In or Register to comment.