Welcome to the new Linux Foundation Forum!

OpenSUSE ethernet driver issues.

I recently installed a new Realtek 8139too fast ethernet card with OpenSUSE 11.4. I had no problem with my internet connection through my ethernet connection on my motherboard. Now, when I run mesg | more I have the message

"piix4_smbus [i0x0b00-0xb07] conflicts with ACPI region SOR1 [??? 0x00000b00-0x00000b0f flags0x31]"

as pertains to the ethernet driver.How do I resolve this?

Comments

  • Goineasy9Goineasy9 Posts: 1,116
    It's a kernel acpi bug. I don't think there's anything you can do to resolve it. If it's only a message, I'd ignore it unless it's causing problems. Some things I read say it's a chip bug.
    Is it a problem, or is it just a message you saw?
  • WPringleWPringle Posts: 3
    I have no connection. I don't know if something is wrong in the setup or if it is a driver issue. It only started after I installed the new card. I found a linux driver for my card at Realtek but I'm not sure how to install it or if that is even the problem.
  • marcmarc Posts: 647
    WPringle wrote:
    I have no connection. I don't know if something is wrong in the setup or if it is a driver issue. It only started after I installed the new card. I found a linux driver for my card at Realtek but I'm not sure how to install it or if that is even the problem.

    Can you try disabling the motherboard ethernet card in the bios and try again?

    Regards
  • WPringleWPringle Posts: 3
    Ok, I disabled the onboard LAN controller and still have the same problem and message. The full boot message reads as follows:

    14.238379] 8139cp: 8139cp: 10/100 PCI Ethernet driver v1.3 (Mar 22
    , 2004)
    [ 14.238547] 8139cp 0000:02:05.0: This (id 10ec:8139 rev 10) is not
    an 8139C+ compatible chip, use 8139too
    [ 14.257367] 8139too: 8139too Fast Ethernet driver 0.9.28
    [ 14.257522] 8139too 0000:02:05.0: PCI INT A -> GSI 20 (level, low)
    -> IRQ 20
    [ 14.258375] 8139too 0000:02:05.0: eth0: RealTek RTL8139 at 0xfafdec
    00, 00:e0:4c:ec:1e:24, IRQ 20
    [ 14.303326] ACPI: resource piix4_smbus [io 0x0b00-0x0b07] conflict
    s with ACPI region SOR1 [??? 0x00000b00-0x00000b0f flags 0x31]
    [ 14.303329] ACPI: If an ACPI driver is available for this device, y
    ou should use it instead of the native driver
  • marcmarc Posts: 647
    What motherboard are you using?

    We could try disabling the piix4_smbus module which seems to be conflicting.

    Try adding a file /etc/modprobe.d/whatever.conf with
    blacklist piix4_smbus
    

    And reboot.
Sign In or Register to comment.