Welcome to the new Linux Foundation Forum!

How to make SUBdirectories in Dovecot...

Hi!

I wonder how i can get subdirectories (.INBOX/***/*** etc...) in dovecot...

I just stardet a mail server and when i tried to create it from the mail client (MS Outlook) it says that the server wont allow it...

Anyone who knows a solution?

Comments

  • marcmarc Posts: 647
    Theatre wrote:
    Hi!

    I wonder how i can get subdirectories (.INBOX/***/*** etc...) in dovecot...
    I just stardet a mail server and when i tried to create it from the mail client (MS Outlook) it says that the server wont allow it...

    Anyone who knows a solution?

    Could you please try with a different mail client, say Thunderbird, to exclude the possibilty that there's some problem with Outlook?
  • saqman2060saqman2060 Posts: 777
    Theatre wrote:
    Hi!

    I wonder how i can get subdirectories (.INBOX/***/*** etc...) in dovecot...
    I just stardet a mail server and when i tried to create it from the mail client (MS Outlook) it says that the server wont allow it...

    Anyone who knows a solution?

    Perhaps your mail server is not compatible with "MS Outlook" or your server is blocking it with it's firewall. Check your firewall settings and check compatibility. Which then brings me to the next question, what type of server are you using? And of course, try Thunderbird.:laugh:
  • marcmarc Posts: 647
    saqman2060 wrote:
    Theatre wrote:
    Hi!

    I wonder how i can get subdirectories (.INBOX/***/*** etc...) in dovecot...
    I just stardet a mail server and when i tried to create it from the mail client (MS Outlook) it says that the server wont allow it...

    Anyone who knows a solution?

    Perhaps your mail server is not compatible with "MS Outlook" or your server is blocking it with it's firewall. Check your firewall settings and check compatibility. Which then brings me to the next question, what type of server are you using? And of course, try Thunderbird.:laugh:

    He is running dovecot...

    It's not a matter of firewall as he can connect to the email server, there must be something wrong somewhere else

    Regards
  • TheatreTheatre Posts: 5
    Thanks for your answers guys!

    Its true, i can connect to the server and it works fine... Its just when i try to create a subfolder under INBOX that the server rejects. I can create a folder in the root.. but when i tried to create a sub folder in THAT folder it rejects again...

    Anyone who knows what to do?
  • marcmarc Posts: 647
    Theatre wrote:
    Thanks for your answers guys!

    Its true, i can connect to the server and it works fine... Its just when i try to create a subfolder under INBOX that the server rejects. I can create a folder in the root.. but when i tried to create a sub folder in THAT folder it rejects again...

    Anyone who knows what to do?

    Have you tried with another client as we suggested?

    Have you tried creating a subfolder whithin that directory you created?

    Maybe Outlook needs a special way of configuring the folders ("/" instead of "."). Check http://wiki.dovecot.org/MailLocation/Maildir

    Regards
  • TheatreTheatre Posts: 5

    Have you tried with another client as we suggested?

    Have you tried creating a subfolder whithin that directory you created?

    Maybe Outlook needs a special way of configuring the folders ("/" instead of "."). Check http://wiki.dovecot.org/MailLocation/Maildir

    Regards

    I have tried with another client, but its the same result.

    i cant create a folder because all mail is stored in 1 file... not in folders.
    i think the problem is because of that.

    But im rather a newbie so i dont know that much of how it works...
  • marcmarc Posts: 647
    Theatre wrote:

    Have you tried with another client as we suggested?

    Have you tried creating a subfolder whithin that directory you created?

    Maybe Outlook needs a special way of configuring the folders ("/" instead of "."). Check http://wiki.dovecot.org/MailLocation/Maildir

    Regards

    I have tried with another client, but its the same result.

    i cant create a folder because all mail is stored in 1 file... not in folders.
    i think the problem is because of that.

    But im rather a newbie so i dont know that much of how it works...

    Are you using mbox or maildir format?

    EDIT: stupid question, forget about it.
  • TheatreTheatre Posts: 5
    marc wrote:
    Theatre wrote:

    Have you tried with another client as we suggested?

    Have you tried creating a subfolder whithin that directory you created?

    Maybe Outlook needs a special way of configuring the folders ("/" instead of "."). Check http://wiki.dovecot.org/MailLocation/Maildir

    Regards

    I have tried with another client, but its the same result.

    i cant create a folder because all mail is stored in 1 file... not in folders.
    i think the problem is because of that.

    But im rather a newbie so i dont know that much of how it works...

    Are you using mbox or maildir format?

    EDIT: stupid question, forget about it.

    Dunno :)

    I haven't change anything in the /etc/dovecot.conf
    it just worked... :)

    Im using fetchmail to fetch the mail and it stores the mail in /var/spool/mail/"username"

    EDIT: mail_location = mbox:~/mail:INBOX=/var/spool/mail/%u <- that's the conf im using...
Sign In or Register to comment.