Welcome to the new Linux Foundation Forum!

Natty Narwhal Fail?

RickSMORickSMO Posts: 123

Well, I am posting this from my newly installed Ubuntu 10.10 Maverick Meerkat system. For god knows what ever reason, almost any issue I ran into on Natty Narwhal made my whole screen turn black and lose input:angry: .

If it didn't do that, it simply didn't work:S . Natty Narwhal Ubuntu 11.04 right now is like a Microsoft OS when it first comes out. Is this normal or did they really screw it up?:blink: This is the first project move I've been through with Ubuntu being a new Linux user.

Everything that I had an issue doing in Ubuntu 11.04, works fine in 10.10

**UPDATE** Problem solved, reffer to "ATI DRIVER & UBUNTU 11.04+ PROBLEM SOLVED" Thread.

Comments

  • saqman2060saqman2060 Posts: 777
    Canonical made 11.04 to compete with windows. Bad move. MS is in a very different league and trying to compete with them is like playing with fire. MS made that same mistake when they tried to go after Mac.

    Unfortunately, 11.04 needs a system with powerful 3D accelerations. If you do not have that brand of GPU, then you won't be able to run unity which is the new DE for ubuntu. However, you can still use it 11.04. Just switch to the classic DE witch is gnome 2.32. It should work fine.
  • RickSMORickSMO Posts: 123
    That isn't my issue at all tho, I'm a avid computer gamer, my computer reflects that much. I have a dualboot system, the other is Windows 7 since it can't run all the games I like to play. I have a ATI RADEON HD 4850 graphics card with 1 GB VRAM.

    However, what your saying may be true in the sense that the proprietary driver for my video card does not work on Natty Narwhal at the moment, so that may still be why i am having so many issues.... Interesting didn't even occur to me. However, it works perfect in 10.10 for me. Suppose i'll just wait for 11.10 to make the switch.
  • mfillpotmfillpot Posts: 2,180
    This sounds like another issue that was posted that was due to the AIT proprietary drivers not working correctly on the kernel that ubuntu 11.04 is using. It is just odd that the included drivers are havin similar issues. Have you filed a bug report in luanchpad for this issue?

    As for the difference, I think canonical changed to unity to make a unified interface for desktops, netbooks and tablets sp that they can offer a seamless appearance for all platforms and simplify support. The idea is sound, but the jump to unity was drastic for most users despite the fact that they had plenly of warning.
  • RickSMORickSMO Posts: 123
    I installed Fedora 15 and the ATI's drivers, works perfectly fine, same linux kernal. What the heck is going on lol.
  • mfillpotmfillpot Posts: 2,180
    RickSMO wrote:
    I installed Fedora 15 and the ATI's drivers, works perfectly fine, same linux kernal. What the heck is going on lol.

    Both Fedora and Ubuntu use modified kernels, most distros customize their kernels with extra modifications prior to shipping. It sounds like the ubuntu specific modifications are the source of your problems.
  • Goineasy9Goineasy9 Posts: 1,116
    As someone who uses fedora, I can tell you that the open source drivers that come with fedora 15 are the latest versions. I've also heard that some consider the most recent open drivers for ATI to be superior to the closed drivers. It's not surprising, at least to me, that they are working successfully with fedora.
  • RickSMORickSMO Posts: 123
    so I installed ubuntu 10.10 again and works perfect. Thinking about waiting until Ubuntu 11 is their LTS version, should have all the bugs worked out by then right? hopefully?
Sign In or Register to comment.