Welcome to the new Linux Foundation Forum!

Incorrect screen size

IzzzIzzz Posts: 7

I just recently installed ubuntu 11.04 on an old Inspiron 1100 laptop. Everything works fine except it's only displaying in the upper left half of the screen. An older netbook edition displayed correctly. Any help is very appreciated,thank you.

Comments

  • marcmarc Posts: 647
    Are you using an external monitor?
  • IzzzIzzz Posts: 7
    No I'm not using an external monitor.
  • atreyuatreyu Posts: 216
    Perhaps you need to change which video driver Xorg is using? Check the config file - /etc/X11/xorg.conf - if it is using 'vesa' try 'i810' (for Intel graphics). You might also need to put the proper values for HorizSync and VertRefresh in there.

    Also, i've heard removing the splash screen sometimes helps...
  • IzzzIzzz Posts: 7
    The monitors resolution is correct when running Ubuntu off the flash drive. Does that mean anything.
  • IzzzIzzz Posts: 7
    Sorry I'm really quite the linux newbie. Do you have any guides on how to do this.
  • atreyuatreyu Posts: 216
    I'll try to help, but I don't know all the right Ubuntu commands (hopefully someone can jump in and correct me).

    Before editing the Xorg config file, I assume you've tried running any Preferences-type settings that can be launched from within the Desktop environment (Gnome, etc.) itself to change the res?

    Assuming you have, and you've still had no luck, then you can try:

    1) Manually editing the Xorg config file
    2) Installing missing drivers

    1) To edit the xorg config file, do this in a terminal:
    sudo gedit /etc/X11/xorg.conf
    

    and look for a section like:
    Section "Device"
            Identifier  "Videocard0"
            Driver      "vesa"
    EndSection
    

    To try the intel driver, change "vesa" to "i810" (or "intel", not sure which).

    To add the HorizSync/VertRefresh info, find those values from some laptop documentation, then put them under the monitor section of the xorg file, e.g.:
    Section "Monitor"
            Identifier   "Monitor0"
            VendorName   "Monitor Vendor"
            ModelName    "Dell E193FP"
            HorizSync    30.0 - 83.0
            VertRefresh  56.0 - 76.0
            Option      "dpms"
    EndSection
    
    Don't use the above values, those are for my monitor!

    2) For 1) to work, you might have to install the Intel Graphics driver first, if it is missing. It'll be some "apt-get install ..." command (help anyone?). I think you can do "apt-cache search ..." for it, or something like that.

    To test your changes you have to restart the X server. You can do that by simply rebooting, but sometimes the Ctrl+Alt+Backspace key combo does it, too.

    hth
  • mfillpotmfillpot Posts: 2,180
    have you tried running xrandr to see what modes are possible for the monitor before attempting to change the xorg.conf file?
  • marcmarc Posts: 647
    mfillpot wrote:
    have you tried running xrandr to see what modes are possible for the monitor before attempting to change the xorg.conf file?

    Well, that will help us find why it's not working but I'm afraid we'll need to modify the xorg.conf file in the end anyway.

    Regards
  • RSimsRSims Posts: 146
    All advice these people gave you is good, but since quick and easy is always good. In Ubuntu 11.04 there is an application called "Monitors" that lets you change your monitor resolution and such. Have you tried simply using that? I've fixed some of my own problems using this simple program.
  • nina220nina220 Posts: 2

    etc/X11/xorg.conf - if it is using 'vesa' try 'i810' (for Intel graphics). You might also need to put the proper values for HorizSync and VertRefresh in there https://audacity.onl/ https://findmyiphone.onl/ https://origin.onl/

  • arnoud55arnoud55 Posts: 1

    @atreyu said:
    I'll try to help, but I don't know all the right Ubuntu commands (hopefully someone can jump in and correct me).

    Before editing the Xorg config file, I assume you've tried running any Preferences-type settings that can be launched from within the Desktop environment (Gnome, etc.) itself to change the res?

    Assuming you have, and you've still had no luck, then you can try:

    1) Manually editing the Xorg config file
    2) Installing missing drivers

    1) To edit the xorg config file, do this in a terminal:
    sudo gedit /etc/X11/xorg.conf

    [url=http://www.rachat-de-credit-simulation.com/rachat-de-credit] Rachat de crédit trésorerie travaux[/url]
    and look for a section like:Section "Device" Identifier "Videocard0" Driver "vesa"EndSection

    To try the intel driver, change "vesa" to "i810" (or "intel", not sure which).

    To add the HorizSync/VertRefresh info, find those values from some laptop documentation, then put them under the monitor section of the xorg file, e.g.:Section "Monitor" Identifier "Monitor0" VendorName "Monitor Vendor" ModelName "Dell E193FP" HorizSync 30.0 - 83.0 VertRefresh 56.0 - 76.0 Option "dpms"EndSection

    Don't use the above values, those are for my monitor!

    2) For 1) to work, you might have to install the Intel Graphics driver first, if it is missing. It'll be some "apt-get install ..." command (help anyone?). I think you can do "apt-cache search ..." for it, or something like that.

    To test your changes you have to restart the X server. You can do that by simply rebooting, but sometimes the Ctrl+Alt+Backspace key combo does it, too.

    hth

    Hello everyone. The information is important. Thank you for entrusting them to us. By the way, I would like to know more about a specific topic among this information please if it is possible. Thank you for your return.  Good luck and strength to us. Sincerely

Sign In or Register to comment.