Welcome to the new Linux Foundation Forum!

Trying to connect to a RealTek Router

I am attempting to connect to a RealTek RTL8191SU wireless router from my Acer All-in-one Aspire Z3100-U3072. I am currently running Ubuntu software. I am not able to find my wireless connection. I have gone to the network connections panel in the top right hand corner (logical thing to do) and pressed "Add new Connections" or the equivalent. I typed my network name and included that it is an unsecured network. After completing these steps I was unable to connect, a little box pop'd up saying "network unavailable you are offline". I am stuck, if someone could walk me through this process that would be greatly appreciated. Thank you.

Michael Paxton

Comments

  • **Update**
    After continuing my expedition with trying to get online I have found my way to the help screen. I went through all of the wireless internet help database to no avail. I did however come across some interesting articles that brought some questions to mind. Quote -- 5.2.1 --- Step 1: Many wireless network devices can be turned on and off. Check to see if there is a hardware switch, some devices can be switched off from Winslows and may be needed to be turned back on from Winslows. -- After finding the related information in my partitioned Windows 7 OS I found a disable/ enable switch in my components details screen, didn't work. What is the correct way to make sure Windows hasn't somehow decided that it would like to hide my device orientation from me, like a hijacker? Second issue/question -- Quote -- 5.2.4 Open a Terminal and type command [ iwconfig ] If the ESSID for our router is shown there (which it was shown in the dialog box) there may be a problem with ACPI support. Boot the kernel with the [ pci=noacpi ] option. -- I discovered that the ESSID was shown in the dialog box, which points me towards the kernel. How do I 'Boot the kernel with the [ pci=noacpi ] option? Might this solve my problem connecting to the router?
    Thank you again,

    Michael Paxton
  • After inputting command ispci not a none command
    After inputting command isusb not a none command
    Instructed to input lpci, results varied, closet related result - nVidia Corporation MCP77 Ethernet
    Instructed to input lusb, result to the point, closest related result - Realtek Semiconductor RTL81915 wlan adapter.
  • http://www.wireless-driver.com/realtek-rtl8185l-wireless-driver-utility/

    Realtek RTL8185L Wireless LAN Driver for Unix /Linux:

    Linux driver for kernel 2.4.X and 2.6.X 1031 2010/1/27 1937k GO (download)

    I have now found this driver information, is this a useful download? Is this the driver information that I needed to find? This is a copy for a website that I found with google search results for "Realtek Semiconductor RTL81915 wlan adapter"
  • solved ???
  • That is what I am not sure of. I do not know how to load that driver onto linux without internet access...
  • No, my neighbor and I share a network. My wireless internet works for Win7, would that imply that the adapter is physically switched on? Also, I have an all in one pc, sucks, how would I attain access to the internals of the pc when there are no screws? I am using Ubuntu 10.10. Guessing this is the most updated version?
  • saqman2060saqman2060 Posts: 777
    Hold off on trying to gain internal access of your system. There is a driver that is need for the OS to properly use your off-and-on Realtek Semiconductor RTL81915 switch. Ask this individual about that driver.
  • mfillpotmfillpot Posts: 2,180
    I think the issue is not with the driver, but with the availablity of the wifi card. Does your computer have a switch or button that is used to enable and disable the wifi card?
  • I will contact that individual. I have no way of seeing the wifi card, as there is not a way to the internals of an all in one pc, at least not one that I can see.
Sign In or Register to comment.