Welcome to the Linux Foundation Forum!

Problem to install VLC and xmms on RHEL 5

Hi Team,

I have RHEL-5 on one box and would like to see movie and run mp3 on it

i tried to install vlc-0.9.9a-7.el5.rf.i386.rpm but its giving my following error

[[email protected] Players]# rpm -ivh vlc-0.9.9a-7.el5.rf.i386.rpm

warning: vlc-0.9.9a-7.el5.rf.i386.rpm: Header V3 DSA signature: NOKEY, key ID 6b8d79e6

error: Failed dependencies:

libBasicUsageEnvironment.so.0 is needed by vlc-0.9.9a-7.el5.rf.i386

libQtCore.so.4 is needed by vlc-0.9.9a-7.el5.rf.i386

libQtGui.so.4 is needed by vlc-0.9.9a-7.el5.rf.i386

libSDL_image-1.2.so.0 is needed by vlc-0.9.9a-7.el5.rf.i386

libUsageEnvironment.so.0 is needed by vlc-0.9.9a-7.el5.rf.i386

liba52.so.0 is needed by vlc-0.9.9a-7.el5.rf.i386

libaa.so.1 is needed by vlc-0.9.9a-7.el5.rf.i386

libartsc.so.0 is needed by vlc-0.9.9a-7.el5.rf.i386

libavcodec.so.52 is needed by vlc-0.9.9a-7.el5.rf.i386

libavcodec.so.52(LIBAVCODEC_52) is needed by vlc-0.9.9a-7.el5.rf.i386

libavformat.so.52 is needed by vlc-0.9.9a-7.el5.rf.i386

libavformat.so.52(LIBAVFORMAT_52) is needed by vlc-0.9.9a-7.el5.rf.i386

libavutil.so.50 is needed by vlc-0.9.9a-7.el5.rf.i386

libavutil.so.50(LIBAVUTIL_50) is needed by vlc-0.9.9a-7.el5.rf.i386

libcaca.so.0 is needed by vlc-0.9.9a-7.el5.rf.i386

libcddb.so.2 is needed by vlc-0.9.9a-7.el5.rf.i386

libcv.so.1 is needed by vlc-0.9.9a-7.el5.rf.i386

libcvaux.so.1 is needed by vlc-0.9.9a-7.el5.rf.i386

libcxcore.so.1 is needed by vlc-0.9.9a-7.el5.rf.i386

libdca.so.0 is needed by vlc-0.9.9a-7.el5.rf.i386

libdirac_decoder.so.0 is needed by vlc-0.9.9a-7.el5.rf.i386

libdirac_encoder.so.0 is needed by vlc-0.9.9a-7.el5.rf.i386

libdvbpsi.so.6 is needed by vlc-0.9.9a-7.el5.rf.i386

libdvdnav.so.4 is needed by vlc-0.9.9a-7.el5.rf.i386

libdvdread.so.3 is needed by vlc-0.9.9a-7.el5.rf.i386

libebml.so.2 is needed by vlc-0.9.9a-7.el5.rf.i386

libfaad.so.2 is needed by vlc-0.9.9a-7.el5.rf.i386

libfribidi.so.0 is needed by vlc-0.9.9a-7.el5.rf.i386

libgroupsock.so.0 is needed by vlc-0.9.9a-7.el5.rf.i386

libhighgui.so.1 is needed by vlc-0.9.9a-7.el5.rf.i386

libid3tag.so.0 is needed by vlc-0.9.9a-7.el5.rf.i386

libixml.so.2 is needed by vlc-0.9.9a-7.el5.rf.i386

libkate.so.1 is needed by vlc-0.9.9a-7.el5.rf.i386

liblirc_client.so.0 is needed by vlc-0.9.9a-7.el5.rf.i386

libliveMedia.so.0 is needed by vlc-0.9.9a-7.el5.rf.i386

libmad.so.0 is needed by vlc-0.9.9a-7.el5.rf.i386

libmatroska.so.2 is needed by vlc-0.9.9a-7.el5.rf.i386

libml.so.1 is needed by vlc-0.9.9a-7.el5.rf.i386

libmodplug.so.0 is needed by vlc-0.9.9a-7.el5.rf.i386

libmpcdec.so.5 is needed by vlc-0.9.9a-7.el5.rf.i386

libmpeg2.so.0 is needed by vlc-0.9.9a-7.el5.rf.i386

libportaudio.so.2 is needed by vlc-0.9.9a-7.el5.rf.i386

libpostproc.so.51 is needed by vlc-0.9.9a-7.el5.rf.i386

libpostproc.so.51(LIBPOSTPROC_51) is needed by vlc-0.9.9a-7.el5.rf.i386

libshout.so.3 is needed by vlc-0.9.9a-7.el5.rf.i386

libswscale.so.0 is needed by vlc-0.9.9a-7.el5.rf.i386

libswscale.so.0(LIBSWSCALE_0) is needed by vlc-0.9.9a-7.el5.rf.i386

libtag.so.1 is needed by vlc-0.9.9a-7.el5.rf.i386

libtwolame.so.0 is needed by vlc-0.9.9a-7.el5.rf.i386

libupnp.so.3 is needed by vlc-0.9.9a-7.el5.rf.i386

libvga.so.1 is needed by vlc-0.9.9a-7.el5.rf.i386

libvgagl.so.1 is needed by vlc-0.9.9a-7.el5.rf.i386

libxosd.so.2 is needed by vlc-0.9.9a-7.el5.rf.i386

libzvbi.so.0 is needed by vlc-0.9.9a-7.el5.rf.i386

same issue for xmms also

[[email protected] Players]# rpm -ivh xmms-mp3-1.2.10-16.el5.rf.i386.rpm

warning: xmms-mp3-1.2.10-16.el5.rf.i386.rpm: Header V3 DSA signature: NOKEY, key ID 6b8d79e6

error: Failed dependencies:

libgdk-1.2.so.0 is needed by xmms-mp3-1.2.10-16.el5.rf.i386

libglib-1.2.so.0 is needed by xmms-mp3-1.2.10-16.el5.rf.i386

libgmodule-1.2.so.0 is needed by xmms-mp3-1.2.10-16.el5.rf.i386

libgthread-1.2.so.0 is needed by xmms-mp3-1.2.10-16.el5.rf.i386

libgtk-1.2.so.0 is needed by xmms-mp3-1.2.10-16.el5.rf.i386

libxmms.so.1 is needed by xmms-mp3-1.2.10-16.el5.rf.i386

[[email protected] Players]#

I dont understand whats wrong with this so please help me to resolve this issue so i can enjoy movie and MP3 songs while working on RHEL-5:(

Comments

  • Goineasy9Goineasy9 Posts: 1,116
    Where are you trying to install vlc from? If you downloaded just vlc into a local folder and are trying to install it from there, that may be the problem. Are you connected to the internet? If so, why not just try
    yum install vlc
    
    ... if you have your repos set up correctly, it should install.
    I just looked at my system ... You can get by this by installing vlc-core along with vlc. Installing using the yum command would have brought vlc-core in with vlc.
  • jabiralijabirali Posts: 157
    I second GoinEasy9's suggestion.

    The error messages you got indicates that some of the software libraries required by vlc and xmms are not installed, or you've got the wrong versions installed. Although you could manually hunt down and install the missing libraries, it is usually preferable and a lot more convenient to simply invoke yum, and let the system do all the dependency hunting for you.
  • woboylewoboyle Posts: 501
    As Jabir and GoinEasy9 said. In short, you are trying to use rpm to install the package, which is not recommended for RHEL/CentOS 5 because it doesn't deal with installing dependencies for you. Do what GoinEasy9 said:
    yum install vlc
    
    Yum will install all of the dependencies for you as well as vlc. No muss, no fuss (usually). Remember, you do need to do that as root.
  • marcmarc Posts: 647
    What does "not recommended" mean? Of course you can use it but you must know it's capabilities (and lack of).

    Anyway, Vlc is not in any repo by the default config in CentOS. Therefore you should add a repo with vlc in it in order for yum to find it.

    ( check http://wiki.centos.org/AdditionalResources/Repositories?highlight=(repos) )

    You can try the localinstall option as well:

    yum localinstall rpm_of_your_chose

    If your repos have all the dependencies VLC needs there won't be any problem :)

    Regards
  • old thread but, for those searching ...

    On RHEL 5 or 6 i would NOT even try to install VLC ,or mplayer, nor totem.

    it is, by far, WAY to easy to kill he install using incompatible software repos that it is not worth the hassle.

    if you NEED to listen to music or watch movies RHEL is not a good choice of Operating System
Sign In or Register to comment.