Welcome to the new Linux Foundation Forum!

inittab entries do not start components in Red Ha

Hello guys,

I did an a new installation of Red Hat 5 with kernel version 2.6.18-194.el5. I noticed that when i tried installing Oracle clusterware on the servers , the crs deamon inserted in the inittab does not startup. The reason attributed to it was because of init problem . A quick test was to insert the entry test:5:once:echo "HELLO TEST" > /test.log in the inittab and use init q command. This should create a file test.log if its fine but I discovered that the entires in the inittab are not executed. Kindly assist in proferring solution to the init problem. My inittab is as below :

[[email protected] ~]# cat /etc/initab

#

# inittab This file describes how the INIT process should set up

# the system in a certain run-level.

#

# Author: Miquel van Smoorenburg,

# Modified for RHS Linux by Marc Ewing and Donnie Barnes

#

# Default runlevel. The runlevels used by RHS are:

# 0 - halt (Do NOT set initdefault to this)

# 1 - Single user mode

# 2 - Multiuser, without NFS (The same as 3, if you do not have networking)

# 3 - Full multiuser mode

# 4 - unused

# 5 - X11

# 6 - reboot (Do NOT set initdefault to this)

#

id:5:initdefault:

# System initialization.

si::sysinit:/etc/rc.d/rc.sysinit

l0:0:wait:/etc/rc.d/rc 0

l1:1:wait:/etc/rc.d/rc 1

l2:2:wait:/etc/rc.d/rc 2

l3:3:wait:/etc/rc.d/rc 3

l4:4:wait:/etc/rc.d/rc 4

l5:5:wait:/etc/rc.d/rc 5

l6:6:wait:/etc/rc.d/rc 6

# Trap CTRL-ALT-DELETE

ca::ctrlaltdel:/sbin/shutdown -t3 -r now

# When our UPS tells us power has failed, assume we have a few minutes

# of power left. Schedule a shutdown for 2 minutes from now.

# This does, of course, assume you have powerd installed and your

# UPS connected and working correctly.

pf::powerfail:/sbin/shutdown -f -h +2 "Power Failure; System Shutting Down"

# If power was restored before the shutdown kicked in, cancel it.

pr:12345:powerokwait:/sbin/shutdown -c "Power Restored; Shutdown Cancelled"

# Run gettys in standard runlevels

1:2345:respawn:/sbin/mingetty tty1

2:2345:respawn:/sbin/mingetty tty2

3:2345:respawn:/sbin/mingetty tty3

4:2345:respawn:/sbin/mingetty tty4

5:2345:respawn:/sbin/mingetty tty5

6:2345:respawn:/sbin/mingetty tty6

# Run xdm in runlevel 5

x:5:respawn:/etc/X11/prefdm -nodaemon

test:5:once:echo "HELLO TEST" > /test.log

Warmest regards

Comments

  • atreyuatreyu Posts: 216
    What is the exact command in your inittab that is failing?

    your test line worked in my inittab on CentOS 5.2 (should be pretty much identical to RH5 system). well, actually, change your test line to:
    test:5:respawn:echo "HELLO TEST" > /test.log
    
    then do
    telinit q
    
    btw, i assume you ARE in runlevel 5?

    one other thing I can think of: be sure you use full path to whatever command you are calling in inittab, too.

    -bill
Sign In or Register to comment.