Welcome to the new Linux Foundation Forum!

scp: /lib/libc.so.6: version `GLIBC_2.8' not found

Dear Team

I am getting this error. I cannot scp any data from the server giving this error to any other server.

scp: /lib/libc.so.6: version `GLIBC_2.8' not found (required by scp)

Linux 2.6.23.8-34.fc7 #1 SMP Thu Nov 22 23:05:33 EST 2007 i686 i686 i386 GNU/Linux

i have not done any updates ...

Please help....

Comments

  • saqman2060saqman2060 Posts: 777
    It seems you are missing a dependency for scp. This is strange since scp is installed by default. Try updating your system to see if that fixes the problem. What distro are you using?
  • asedtasedt Posts: 96
    If you are using a Debian based system. Test this:

    Open the Synaptic Package Manager.
    Search for openssh-client.
    Mark it for reinstallation.
    Press the Apply button.

    To check up stuff I did this in terminal:
    Find what package scp is in
    dpkg --search /usr/bin/scp
    
    See if it is installed
    dpkg -l | grep openssh
    
    See what it depends on
    apt-cache depends openssh-client
    
  • Goineasy9Goineasy9 Posts: 1,116
    2.6.23 kernel ... is it possible you never did updates (for years? )? Or could you have mistyped the kernel version number? What distro are you running? When was it installed?
    just an FYI- if you install something new on an old system, unless all dependencies are updated something will fail.

    Edit. I just noticed it's fedora core 7, considering we're getting ready to install fedora 15 next month, that version is 4 years old. The repos are no longer active, time to upgrade. I understand that's hard for some, but, there's little that can be done to an end of life distro with no repos.
Sign In or Register to comment.