Welcome to the Linux Foundation Forum!

HELP--Network Manager Deleted

My Recent Ubuntu 10.10 update recommended that i remove 4 programs, one of which was my network manager. Because this is gone i can no longer access the internet. The connection logo is no longer in the top-right corner either.

Any help would be much appreciated,

Thanks alot,

Carson M


  • Jain
    Jain Posts: 2
    you can install it again using synaptic package manager ot

    apt-get install network-manager
    or you can configure you network settings in /etc/network/interfaces


    auto eth0
    iface eth0 inet static

    Hope this helps

    Swapnil Jain
  • Goineasy9
    Goineasy9 Posts: 1,114
    Did you physically remove network-manager or did you see the old version being removed at the end of the update?

    You can check by running this command in the terminal:
    apt-get policy network-manager

    If nothing comes up you can install it again using the instructions Swapnil gave you. Although, I'm wondering what kind up update would ask for the removal of network-manager.
  • Thanks A lot for the Help,
    When i entered that in, it replied, "E: Invalid operation policy".
    Does that mean it's completely removed?
  • Goineasy9
    Goineasy9 Posts: 1,114
    Sorry, you must need permissions to run that command. Try using "sudo" to set permissions. That is:
    sudo apt-get policy network-manager

    I haven't run a Debian based distro in a couple of years and I'm getting rusty on my apt-get's.
  • Thanks for Helping,
    I tried using the Synaptic approach by getting the network-manager off of the Ubuntu CD but wasnt sure how to get it. I also tried your second approach:
    auto lo
    iface lo inet loopback
    gateway 192,168,104,1
    I wasnt sure on how to get the DNS Servers through another computer.
    Am i supposed to run the ppoeconf command after this?
  • Thanks for the help,
    It still says the same thing about and "Invalid Operation Policy"
    I dont think that the policy exists seeing as how it was deleted.
  • You can find the DNS server by typing sudo nslookup, then type "--help" at the prompt. It will give you the DNS server associated with you network. Make sure that you use one DNS nameserver.


Upcoming Training