Welcome to the Linux Foundation Forum!

Installing Fedora in Dual Boot Configuration

My first attempt to install fedora on my laptop was a failure. I'm unable to partition the hard drive. I have a 146 gig hard drive with 18 gig of free space. Is this enough free space to install fedora in a dual boot configuration? This is a Dell Inspiron with Vista Ultimate.

Comments

  • Goineasy9
    Goineasy9 Posts: 1,114
    18 gig would be enough, but what prevented you from installing? What happened during disk partitioning? Are you using the LiveCD or the DVD? The DVD allows for a lot more options when installing.
  • Thanks for the response...I'm using the DVD that I burned from the fedora download site. The error message I get is 'Could not allocate partition. Not enough free space on disk.' I tried partitioning at the size the program identified by default and I also tried partitioning as low as 500 Meg with the same error message.

    Another user (ahrrrgh) suggested I purchase a larger hard drive. I was hoping to avoid that but maybe I'll just go that route.
  • Goineasy9
    Goineasy9 Posts: 1,114
    That HD is big enough, the question is, is the Fedora installer being pointed to the correct partition, or maybe, it is pointed to the partition that holds the restore partition for Vista.

    The first thing I do when I want to put Linux as a dual boot with windows is defrag the drive twice. Windows scatters files all over the place, and, sometimes once is not enough.

    Then I use the Windows partitioner. I find that shrinking Windows partitions works better, at least for Windows, when you use their own partitioner. While this may not be a problem for you, I'm just going through the steps.

    When I use the DVD to install, I change the default LVM partitions to ext4, I don't think the LVM partitions are giving you a problem, but it's hard debugging them, due to a lack of common tools.

    I also use EasyBCD 2.0 as the boot loader to retain a Windows bootloader in a case a Windows update requires it.

    OK, Just a little nutshell of what I do when installing.

    This is my fdisk of my dual Windows 7 and Fedora 14 install:

    [[email protected] GoinEasy9]# fdisk -l

    Disk /dev/sda: 500.1 GB, 500107862016 bytes
    255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0x5b9914f7

    Device Boot Start End Blocks Id System
    /dev/sda1 63 80324 40131 de Dell Utility
    /dev/sda2 80325 30800324 15360000 7 HPFS/NTFS
    /dev/sda3 * 30800325 450236868 209718272 7 HPFS/NTFS
    /dev/sda4 450237690 976768064 263265187+ 5 Extended
    /dev/sda5 450237753 452334904 1048576 83 Linux
    /dev/sda6 452334906 536220984 41943039+ 83 Linux
    /dev/sda7 536220986 552998200 8388607+ 82 Linux swap / Solaris
    /dev/sda8 552998202 976766264 211884031+ 83 Linux

    You'll see that sda1, which contains the MBR should not be where the installer is pointed. Sda5-8 is where my Linux install is located, sda5 is /boot, sda6 is /home, sda7 is swap and sda8 is root.. How are you setting up the partitions? Are you using a /boot partition or putting everything into /root? I'd be interested what choices your making up to the point where you get the "Could not allocate partition" error. Are you trying to shrink Windows partitions with the Fedora installer, or does this happen when your setting up you /root, /home, /boot and/or swap partitions.

    A copy of your fdisk -l output (I think you can run it in Windows also) can help with a diagnosis. Or if you have a Linux LiveCD you can run fdisk -l from there also.

Categories

Upcoming Training