Welcome to the new Linux Foundation Forum!

Open ports for ftp, ssh and webserver

Hi

I'm looking for the code to open my ports from my ftp, ssh and webserver to the internet.

I've tried several things but none of those worked.

I'm running my ftp, ssh and webserver on a virtual machine on my laptop.

I think the ports are 21 (ftp), 23 (ssh) and 80 (web server)

Can someone help me?

Comments

  • ThijsM ,

    When you say you want to open the port to the internet do you mean you want to access your VM from the internet?

    Questions:

    1.Do you have valid IP of your laptop? (Public IP)
    2. does your VM had firewall setup? or your laptop has firewall setup on it.
    3. What particular VM are you using? how did you deploy your networking settings on your VM?

    Please advise so that we can help you. Thanks.
  • benben Posts: 135
    Are you referring to your router and port forwarding stuff ? can you please explain ?
  • mfillpotmfillpot Posts: 2,180
    If the services are running you need to verify that the ports are open in both the local machine and the router. If you have not implemented a local firewall then your issue is with your router to the internet which in most cases block the ports by default.
  • Ben: Yes my ports at the router are open and I direct those ports to the ip-address from my web server.

    csorhand: I have connection from my vm to the internet. I just want people to see the websites I place on my webserver. At this moment I can't ping from another computer to the ipaddress from my web server but the other way around does work.
    1) I have a dynamic ip on my laptop
    2) firewall on laptop is dissabled and the one from the ubuntu web server aswell (ufw and firestarter)
    3) VM Workstation 6.5 - 7.0. The network settings are NAT.

    mfillpot: all the ports are open on the router. On the local machine (my laptop) how do I open those?
  • mfillpotmfillpot Posts: 2,180
    That seems to explain the issue if the client you are attempting to contact is networked in vmware as NAT.

    NAT works by opening ports on the server to allow the client traffic to pass through the ports, so according to the router the client system does not exist, only the server is visible.

    You will need to switch the vmware network type to bridged which will make the server treat the client as a new machine on the network in which it will be assigned it's own ip address which you can route to via the router.
  • thanks mfillpot it works :)
    now I can start going through security and naming instead of using the ipaddress.
    topic can be closed as solved
  • mfillpotmfillpot Posts: 2,180
    I am glad that the vmware networking configuration fixed your issue. I recommend reading about the different network types in vmware so future virtual machines are on the best possible networks.
Sign In or Register to comment.