Welcome to the Linux Foundation Forum!

Anyone using a Dell XPS 13 m1340? Kernel problems.


I didn't want to put this under Fedora, even though that's my distro of choice. I want to see if anyone else has this laptop and is using it with any other distro that has a 2.6.34 or 2.6.35 kernel.

The last Fedora kernel to boot properly on this laptop is the 2.6.33 kernel. Since this laptop has dual Nvidia cards and is using nouveau, I'm having the feeling that the inclusion if Nvidia SLI support in the kernel starting with the 2.6.34 kernel might have something to do with it.

Graphics: Card-1 nVidia G98 [GeForce 9200M GS] Card-2 nVidia C79 [GeForce 9400M G] Fedora X.org 1.9.1 Res: 1280x800@59.9hz

GLX Renderer Gallium 0.4 on NVAC GLX Version 2.1 Mesa 7.9 Direct Rendering Yes

I'm putting together a bugzilla entry, and I'm hoping to get some feedback from others who might have this particular laptop. I've got to say, I'm not having much luck so far.

Keeping my fingers crossed, Anyone?


  • woboyle
    woboyle Posts: 501
    You don't give any particulars on the problems/errors you are getting. Please be more specific about what is happening.
  • Goineasy9
    Goineasy9 Posts: 1,114
    Thanks for the interest Rubberman. My reason for posting a short question here and on identi,ca and on a few other Linux friendly sites was just to see if anyone else was using this laptop with Linux and to see if it caught anyones eyes.
    I had Fedora 13 running flawlessly on this laptop (Dell XPS 13 m1340) for quite some time with the 2.6.33 kernel. The problems only started when F13 graduated to using the 2.6.34 kernel. The boot would stop with a clear screen and 2 lines showing a problem with nouveau.

    [drm] nouveau 0000:03:00.0 gpio tag 0xff not found
    [drm] nouveau 0000:03:00.0 gpio tag 0xff not found

    You can see the whole explanation at https://bugzilla.redhat.com/show_bug.cgi?id=630811

    When Fedora 14 blossomed out of rawhide, and a 2.6.35 kernel was released without debugging code, I tried it with F13 on the laptop and it seemed to work. At that point I should have left it as the default kernel, but I felt more comfortable with the 2.6.33 kernel, so I didn't really give it extensive testing. I figured, when F14 came out, I would just upgrade, and use the new version with the 2.6.35 kernel and all would be well with the world. Oh, well.

    It seems that none of the 2.6.35 kernel boot successfully. Once in a while, one will boot, especially true if it's right after install. Unlike the 2.6.34 kernels, with the 2.6.35 kernels, there are no nouveau messages when the boot fails, now, there are nm-applet, modprobe Tainted and I caught one firmware error in the messages file. More specifics can be seen in the bugzilla entry I finally got to file today. Link here:

    For the last 2 weeks I've been trying different things to find the root of the problem. Using xserver=vesa on the kernel line, removing rhgb to inhibit plymouth, disabling ivp6tables, running Memtest to see if I had memory problems. I am very much an amateur when it comes to things kernel related, so, needless to say it has been frustrating.

    One bit of information I've found was that support for Nvidia SLI has been added to the kernel starting with 2.6.34, and, since this dual Nvidia card laptop contains such a setup, I'm wondering if that may have something to do with it, possible because nouveau isn't advanced enough for that. Anyway, thanks for the interest. Any ideas?
  • Goineasy9
    Goineasy9 Posts: 1,114
    Just to close up this thread. Today I found out it was the broadcom-wl driver that was causing the boot to blow up on the 2.6.35 kernels. Fedora uses akmods and kmods to build drivers. The kmods are pre-built, if a new kernel comes out and the new drivers are currently unavailable, if you have the akmod installed, it will build the kmod during the next boot. Well, I had akmod-wl installed and up to the 2.6.33 kernel, it worked flawlessly. Something happened with the broadcom-wl driver, or its interaction with the kernel starting with 2.6.34, so, when the akmod built the kmod-wl, it created a faulty driver, which caused the boot problem. I tried installing the driver directly, and still had the problem, so, my next project on this laptop will be finding out why the broadcom-wl driver is malfunctioning with the newer kernels. Until then, I'll keep a copy of the 2.6.33 kernel installed so if I ever need to use wifi, I have a working driver.
    I'm assuming the nouveau messages back with the 2.6.34 kernel were a side effect of the memory corruption caused by the bad wl driver.


Upcoming Training