Welcome to the new Linux Foundation Forum!

Trouble installing Lubuntu 10.10 on HP Laptop

Hello,

I just recently acquired an old HP ze4805 laptop from an acquaintance of mine that doesn't have an OS installed on it (previously had WinXP and might actually still be installed, but does not load). I've been interested in Linux but never actually had the courage to use it on any of the other computers I've owned, so I decided to use this opportunity to try out the lightweight version of Ubuntu, given the older hardware on the laptop.

So I bought a live cd of Lubuntu 10.10 and had a go, but once I tried to install or use the live cd mode at the boot screen, I just get the Lubuntu loading screen for several hours until I get an error that says this:

(process:253): GLib - warning getpwnid_r(): failed due to unknown userID

Also, I tried the option on the boot screen of 'check memory', and it goes through several tests, but then ends up crashing and shutting down the computer.

Any advice would be wonderful.

Specs that I know of:

AMD Athlon XP 2.1GHz

256MB RAM

Comments

  • Goineasy9Goineasy9 Posts: 1,116
    A check memory app that runs and then fails is usually a sign you have bad memory. The Glib error is fairly common with the newest Ubuntu and points to Grub2 and the UUID (disk ID number) used in grub, which may point to a corrupt file or a malfunctioning hard disk. I haven't seen any definitive answers about a solution or the exact cause of the error, so I think it depends on different problems on different types of hardware.
    You really need to run some diagnostics on the laptop to see if what the condition of the hardware is. If you have access to a systemrescuecd or partedmagic disk, you might be able to find out more about what is happening.
  • Ok, so I downloaded SysRescueCd and put it on a USB drive. But then after I boot I get a message that says
    "No bootable partition in table"

    What does that mean??
  • Goineasy9Goineasy9 Posts: 1,116
    It means the computer can't boot the usb. Does the usb boot on other machines?
  • Yes, the USB works fine on other computers.
  • Goineasy9Goineasy9 Posts: 1,116
    Then there's a possibility of a hardware problem with that old laptop. When it's booting up, can you press the key that gets you into the bios? F9, F10 or F12 depending on the bios. You might want to see if anything can be diagnosed from the bios settings.
Sign In or Register to comment.