Welcome to the Linux Foundation Forum!

Kernel Installation Problem.

Hi Friends..

I am using RHEL5. and i am trying to install new version of "kernel 2.6.35.2"

i am compiling it for installation.

But their are some problem its showing gcc miscompilies.

please friends suggest me some links and path.

Thanks in advance.

Comments

  • Hi Rahul,

    Can you tell what is the exact message that shows up?

    -=Srijan
  • Yes, please give the exact procedures of the compile and quote the error messages.
  • Goineasy9Goineasy9 Posts: 1,116
    My guess is that it might need a newer version of gcc, but we won't know that for sure until we see the error output. The next RedHat release will be based around what was/is Fedora 12. The RHEL 5.5 release was still based , I believe, around the 2.6.18 kernel. There have been many advancements since then.
  • woboylewoboyle Posts: 501
    This may not be possible. The latest kernel for RHEL 5 is 2.6.18-194.11.3 (just released in the past couple of days). Around 2.6.30 or 32 there were major kernel structure changes. You would essentially have a completely new system and would have to replace all system tools, drivers, applications, libraries, etc. If you want to run the kernel you mention, then you will need to update to the latest Fedora Core - you will not be able to install or run it on RHEL as far as I can tell, and it certainly would NOT be supported by Red Hat.
Sign In or Register to comment.