Welcome to the Linux Foundation Forum!

Xsane Problem: Recognizes Webcam as Scanner (?)


Due to a sale at my university's computer store, I decided to purchase a new HP Deskjet F4480 all-in-one unit. I have tested its printing abilities and it works remarkably well in Ubuntu 10.04 x86_64. However, the scanning function is malfunctioning and I know that it is not a hardware issue.

I have found that I have been able to scan documents with other HP models via Trisquel (the FSF's answer to Ubuntu) within VirtualBox. My theory is that there is something wrong with my build of SANE and/or Xsane and have tried compiling the former from source to fix my problem.

Every time I run "sane-find-scanner", I get the following output in my terminal:

device `v4l:/dev/video0' is a Noname BisonCam, NB Pro virtual device

When I run lsusb, it displays Bus 001 Device 015: ID 03f0:7711 Hewlett-Packard

Does anyone know how I can 1.) disable my webcam as being recognized as my scanner, and 2.) how to get my scanner functioning properly in Ubuntu 10.04?

Thank you to anyone in advance for helping me out with this predicament.


  • GrouchoMarxist
    Update: I solved this problem by backing up my hard drive, "nuking" my computer and reinstalling Ubuntu 10.04.1


Upcoming Training