Welcome to the Linux Foundation Forum!

Zoom wireless-n usb not connecting


I've been trying to get a Zoom wireless-n usb adapter to work. It works under Windows once I enable file & printer sharing. Here's the output from some commands.

red@Homebrew:~$ sudo ifconfig -a

[sudo] password for red:

eth0 Link encap:Ethernet HWaddr 00:0d:61:68:d7:81

inet addr: Bcast: Mask:

inet6 addr: fe80::20d:61ff:fe68:d781/64 Scope:Link


RX packets:3043 errors:0 dropped:0 overruns:0 frame:0

TX packets:2978 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:2639340 (2.6 MB) TX bytes:518873 (518.8 KB)


lo Link encap:Local Loopback

inet addr: Mask:

inet6 addr: ::1/128 Scope:Host


RX packets:8 errors:0 dropped:0 overruns:0 frame:0

TX packets:8 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:0

RX bytes:480 (480.0 B) TX bytes:480 (480.0 B)

wlan0 Link encap:Ethernet HWaddr 00:40:36:3c:0a:d9

inet6 addr: fe80::240:36ff:fe3c:ad9/64 Scope:Link


RX packets:7435 errors:0 dropped:0 overruns:0 frame:0

TX packets:3121 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:1754267 (1.7 MB) TX bytes:227012 (227.0 KB)

red@Homebrew:~$ sudo lsmod | grep rt

rt2870sta 461811 1

gameport 9089 2 ns558

parport_pc 25962 1

agpgart 31724 3 ttm,drm,amd64_agp

parport 32635 3 ppdev,parport_pc,lp


red@Homebrew:~$ sudo iwconfig

lo no wireless extensions.

eth0 no wireless extensions.

wlan0 RTxx70 Wireless ESSID:"" Nickname:"RT3070STA"

Mode:Auto Frequency=2.417 GHz Access Point: 00:24:01:6F: DA:F1

Bit Rate=1 Mb/s

RTS thr: off Fragment thr: off

Encryption keyff

Link Quality=10/100 Signal level:-49 dBm Noise level:-97 dBm

Rx invalid nwid: 0 Rx invalid crypt: 0 Rx invalid frag: 0

Tx excessive retries: 0 Invalid misc: 0 Missed beacon: 0

Windows shows the adapter as rt2780 but here you can see it's claiming rt3070. The wireless icon shows it's getting a signal and I can connect to the local network, or so it seems. I'm running it thru a D-Link DIR-628 router. Is there something else I'm missing?

Thank you.


  • mfillpot
    mfillpot Posts: 2,177
    You output is showing that it is using the rt2870sta module as the driver, so at least that is working. We are also seeing that it it being detected and showing. I don't know if you are aware, but that driver is currently in the staging area which means that they have not worked out all of the kinks, and I am seeing a lot of problems on that driver.

    It may just be having problems communicating with a 802.11n router, have you tried dropping the router mode to g or making it multi-channel to see if it works?
  • RealGomer
    I just checked. The router is in multi-mode - b, g, & n. Should I blacklist the .sta drive and "whitelist" another one? There are 4 files shown named rt2870.*
  • RealGomer
    Right. I tried to connect directly to the D-Link router using its IP4 address. I received the message the site could not be found. I used network manager (I think. I'm new to wireless ubuntu networking) and manually set the computer's IP4, Gateway, and netmask addresses. Nothing. I connect the ethernet patch cable and I'm in. Network Manager show the wireless network, set as automatic log in, as never used even tho I've connected to it manually several times.
  • mfillpot
    mfillpot Posts: 2,177
    It sounds like you network manager had bad preferences assigned to that wireless connection that are stopping it from connecting. have you tried changing all options for that device and ssid to automatic or the defaults?
  • RealGomer
    Well, I got rid of the Zoom usb wireless adapter and tried another usb adapter that claimed to have the Linux drivers on disk. Of course, I need to figure out how to load them. Anyway, are there other settings that need to be made in Lucid to get a connection from the PC thru a router to the internet. I've run the commands, set the IP addresses, and tried what's been suggested. I checked with D-Link and they suggested turning off WEP/WPA and wireless security. (YIKES!!) I did notice that even tho both Network Manager & WICD say the adapter is working and connected, neither the router not the other PC's are seen.
    So, what do the mavens of Linux suggest? Who knows. Maybe we'll un up with a sticky on how to set up a wireless usb adapter.
  • RealGomer
    Well, I finally got the usb adapter to work. The solution was so simple I could kick myself. There are TWO passwords on the network. The first is the network password. The second, which I had completely forgotten about, was the WPA password. Once I entered the WPA password, everything worked as advertised.


Upcoming Training