Welcome to the new Linux Foundation Forum!

Cant find any wireless networks

I installed Ubuntu today itself.

Although internet and wifi is running absolutely fine on other OS,

but cant find any wireless networks on Linux.

Pls help

«1

Comments

  • jabiralijabirali Posts: 157
    Can you try opening a terminal (in the menu, Applications -> Accessories -> Terminal) and enter the following commands:
    ifconfig -a
    iwconfig
    
    If you post the output of those commands here, that should help us determine whether or not Linux has loaded the correct network drivers yet :)
  • gomergomer Posts: 158
    The output of
    dmesg
    
    and
    lshw | grep -A12 '\-network'
    
    would be a big help, too.
  • David1729David1729 Posts: 17
    I have exactly the same problem: WiFi works in Windows, ethernet cable works in Ubuntu (Hardy Heron), but WiFi doesn't work in Ubuntu. Since the original poster seems to have abandoned this thread, I'm taking over the position of n00b :huh:

    When I boot up in Windows, the light that says "WIFI" usually comes on. But in Linux it doesn't come on even if I press the button, and if I go back to Windows I have to press the button to turn it on again.

    The output from "dmesg" was 28K, so I've tried to attach it as a separate file, but I'm not sure if it's worked: [file name=dmesg_output.txt size=28714]http://www.linux.com/media/kunena/attachments/legacy/files/dmesg_output.txt[/file]

    The output from the other 3 commands was as follows:
    [email protected]:~$ ifconfig -a
    eth0      Link encap:Ethernet  HWaddr 00:1d:60:ec:47:75  
              BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
              Interrupt:20 Base address:0xdead 
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:2530 errors:0 dropped:0 overruns:0 frame:0
              TX packets:2530 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:126500 (123.5 KB)  TX bytes:126500 (123.5 KB)
    
    [email protected]top:~$ iwconfig
    lo        no wireless extensions.
    eth0      no wireless extensions.
    
    [email protected]:~$ lshw | grep -A12 '-network'
    WARNING: you should run this program as super-user.
    137:        *-network DISABLED
    138-             description: Ethernet interface
    139-             product: 191 Gigabit Ethernet Adapter
    140-             vendor: Silicon Integrated Systems [SiS]
    141-             physical id: 4
    142-             bus info: [email protected]:00:04.0
    143-             logical name: eth0
    144-             version: 02
    145-             serial: 00:1d:60:ec:47:75
    146-             width: 32 bits
    147-             clock: 33MHz
    148-             capabilities: bus_master cap_list ethernet physical
    149-             configuration: broadcast=yes driver=sis190 driverversion=1.2 latency=0 module=sis190 multicast=yes
    --
    172:           *-network UNCLAIMED
    173-                description: Ethernet controller
    174-                product: AR242x 802.11abg Wireless PCI Express Adapter
    175-                vendor: Atheros Communications Inc.
    176-                physical id: 0
    177-                bus info: [email protected]:02:00.0
    178-                version: 01
    179-                width: 64 bits
    180-                clock: 33MHz
    181-                capabilities: cap_list
    182-                configuration: latency=0
    183-        *-pci:2
    184-             description: PCI bridge
    
    [email protected]:~$ sudo lshw | grep -A12 '-network'
    209:        *-network DISABLED
    210-             description: Ethernet interface
    211-             product: 191 Gigabit Ethernet Adapter
    212-             vendor: Silicon Integrated Systems [SiS]
    213-             physical id: 4
    214-             bus info: [email protected]:00:04.0
    215-             logical name: eth0
    216-             version: 02
    217-             serial: 00:1d:60:ec:47:75
    218-             size: 10MB/s
    219-             capacity: 100MB/s
    220-             width: 32 bits
    221-             clock: 33MHz
    --
    283:           *-network UNCLAIMED
    284-                description: Ethernet controller
    285-                product: AR242x 802.11abg Wireless PCI Express Adapter
    286-                vendor: Atheros Communications Inc.
    287-                physical id: 0
    288-                bus info: [email protected]:02:00.0
    289-                version: 01
    290-                width: 64 bits
    291-                clock: 33MHz
    292-                capabilities: pm msi pciexpress msix cap_list
    293-                configuration: latency=0
    294-        *-pci:2
    295-             description: PCI bridge
    
  • David1729David1729 Posts: 17
    OK, I looked at the other post. When I type "uname -r" it says "2.6.24-27-generic". I looked on Synaptic Package Manager. It lists a package named linux-restricted-modules-2.6.24-27-generic, and it says my installed version (of linux-restricted-modules-2.6.24-27-generic) is 2.6.24.18-27.5. This seems like a mixed message, to my untrained eyes. (Is the version number 2.6.24-27-generic or 2.6.24.18-27.5?) And there are also a few more versions installed:
    - linux-restricted-modules-2.6.24-16-generic, version 2.6.24.12-16.34
    - linux-restricted-modules-2.6.24-21-generic, version 2.6.24.14-21.51
    - linux-restricted-modules-2.6.24-26-generic, version 2.6.24.18-26.3
    - linux-restricted-modules-common, version 2.6.24.18-27.5
    - linux-restricted-modules-generic, version 2.6.24.27.29
    I tried following the link to the madwifi page, but the link was broken and their main page says they've delegated their software distribution to sourceforge, and I couldn't find madwifi-ng on sourceforge.
    What do I do now?
  • mfillpotmfillpot Posts: 2,180
    madwifi is outdated now because the atheros kernel drivers are built right into the kernel with names such as ath5k, ath7k or ath9k. Can you please run "sudo lsmod|grep ath" and tell me if you see any of the module names I listed above or anything that starts with ath?
  • David1729David1729 Posts: 17
    [email protected]:~$ sudo lsmod|grep ath
    [sudo] password for david: 
    ath_pci               101024  0 
    wlan                  207856  1 ath_pci
    ath_hal               192592  1 ath_pci
    
  • mfillpotmfillpot Posts: 2,180
    That is odd, I am seeing that your wifi card is supported by the ath9k driver, but it does not appear to be loaded. Go into the terminal and enter "sudo modprobe ath9k" to load the driver, if that does not fix the issue then I would like you to post the output of "sudo lspci|grep -i ath" to this site.
  • David1729David1729 Posts: 17
    It still doesn't work:
    [email protected]:~$ sudo modprobe ath9k
    [sudo] password for davidknipe: 
    FATAL: Module ath9k not found.
    [email protected]:~$ sudo lspci|grep -i ath
    02:00.0 Ethernet controller: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)
    
  • mfillpotmfillpot Posts: 2,180
    It looks like it may not be setup as a module in your kernel, have you tried going to the Hardware Drivers option in the administration menu to see if it detects the card and recommends drivers?
  • David1729David1729 Posts: 17
    It lists 2 device drivers: "Atheros Hardware Access Layer (HAL)" and "Support for Atheros 802.11 wireless LAN cards". They both have ticks beside them to say they are both enabled and in use. I don't see any error messages.
  • mfillpotmfillpot Posts: 2,180
    If they are both installed according to the hardware driver tool then the device support is available. What exactly is the current issue that you are having with interacting with your wireless card?
  • genomegagenomega Posts: 7
    You may need to install a newer kernel. 2.6.32.xx
  • David1729David1729 Posts: 17
    mfillpot, I don't know what the issue is, only that WiFi doesn't work at all from Linux, even though it works in Windows and ethernet works in Linux.

    How do I install a new kernel? Is this liable to be a troublesome process, and will I lose compatibility with already-installed software?
  • mfillpotmfillpot Posts: 2,180
    By checking for updates and installing all updates it should give you the newest versions of everything including the kernel.

    I think the problem has to do with how ubuntu links hardware, it should work, but doesn't. You should report this to the ubuntu developers so they can troubleshoot their processes. The instructions for reporting problems are at https://help.ubuntu.com/community/ReportingBugs
  • UniverseUniverse Posts: 3
    Hi,

    Try using " wifi-radar ". If its not available in your repository, download it from some where. It will allow you to select your wireless network, enter WEP key, and switching to network available. More details can be found here:

    http://packages.ubuntu.com/dapper/wifi-radar

    Best Regards,

    Syed Muhammad Shahbaz
  • gomergomer Posts: 158
    David, sorry I've been terribly busy and wasn't able to get back to you. Matt is probably right, you probably just need a kernel upgrade. What version of Ubuntu are you running?
  • gomergomer Posts: 158
    Actually, David, I take that back. I suspect that Madwifi is still the best option for you. Try the following if you would:
    sudo apt-get install linux-headers-generic build-essential subversion
    
    svn co http://svn.madwifi-project.org/madwifi/branches/madwifi-0.9.4/
    
    cd madwifi-0.9.4/
    
     make
    
    sudo make install 
    

    And then test it with modprobe ath_pci
    If the module works for you, then go ahead and update your initrd with the following command:
    sudo update-initramfs -u

    Let me know how that turns out for you....
  • David1729David1729 Posts: 17
    OK, I did all that and it seemed to install things (albeit not on the first attempt, as I had to do some routine updates first). And it created the madwifi folder. But I still can't see how to actually access the internet wirelessly.
    When I go to "edit wireless networks" there are no wireless networks on the list. At the bit where you type in the Properties, everything is greyed out except "Name" and "bssids", and I can't type in bssids. (It was exactly like this before.) I've tried some of the commands from earlier in this conversation and the outputs are nearly the same, although the output of "ifconfig -a" has a few nonzero numbers where before they were 0.

    What do you think? Is it worth pursuing this line of enquiry, or do I need a new kernel?
  • gomergomer Posts: 158
    can you include the outpu of both of these commands:
    ifconfig -a
    sudo iwlist scan
  • David1729David1729 Posts: 17
    [email protected]:~$ ifconfig -a
    eth0      Link encap:Ethernet  HWaddr 00:1d:60:ec:47:75  
              inet addr:192.168.1.72  Bcast:192.168.1.255  Mask:255.255.255.0
              inet6 addr: fe80::21d:60ff:feec:4775/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:591 errors:0 dropped:0 overruns:0 frame:0
              TX packets:565 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:646666 (631.5 KB)  TX bytes:115766 (113.0 KB)
              Interrupt:20 Base address:0xdead 
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:1866 errors:0 dropped:0 overruns:0 frame:0
              TX packets:1866 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:78372 (76.5 KB)  TX bytes:78372 (76.5 KB)
    
    [email protected]:~$ sudo iwlist scan
    [sudo] password for david: 
    lo        Interface doesn't support scanning.
    
    eth0      Interface doesn't support scanning.
    
    
  • gomergomer Posts: 158
    David1729 wrote:
    OK, I did all that and it seemed to install things (albeit not on the first attempt, as I had to do some routine updates first). And it created the madwifi folder.

    Actually it seems to either not have installed the madwifi driver, or you may have other / more issues. Can you also provide the output of "lsmod | grep 802". I want to see if the driver is installed and active in your kernel.
  • David1729David1729 Posts: 17
    I get no output whatsoever. But when I type just "lsmod" I get the output listed below.

    You mention other issues. I do have other issues with Ubuntu, but I hadn't said anything about them because I thought you had enough to deal with. But if they might be connected to this, then I might as well tell you:
    - I have no sound at all.
    - The screen resolution is 800x600, and the only other option is 640x480 which is even worse. (So, for instance, I can't see all of this webpage without scrolling horizontally.)
    - I have trouble installing things from source, it looks like part of the gcc package is missing or something.
    [email protected]:~$ lsmod
    Module                  Size  Used by
    xt_limit                3584  8 
    xt_tcpudp               4096  7 
    ipt_LOG                 7296  8 
    ipt_MASQUERADE          4608  0 
    ipt_TOS                 3200  0 
    ipt_REJECT              5632  1 
    nf_conntrack_irc        7576  0 
    nf_conntrack_ftp       10144  0 
    xt_state                3328  6 
    rfcomm                 41872  2 
    l2cap                  25728  13 rfcomm
    bluetooth              61028  4 rfcomm,l2cap
    ppdev                  10372  0 
    acpi_cpufreq           10796  1 
    cpufreq_stats           7104  0 
    cpufreq_ondemand        9740  1 
    freq_table              5536  3 acpi_cpufreq,cpufreq_stats,cpufreq_ondemand
    cpufreq_userspace       5284  0 
    cpufreq_powersave       2688  0 
    cpufreq_conservative     8712  0 
    container               5632  0 
    dock                   11280  0 
    sbs                    15112  0 
    sbshc                   7680  1 sbs
    ipv6                  268036  10 
    af_packet              23812  2 
    ppp_generic            29588  0 
    slhc                    7040  1 ppp_generic
    parport_pc             36260  0 
    lp                     12324  0 
    parport                37832  3 ppdev,parport_pc,lp
    joydev                 13120  0 
    evdev                  13056  7 
    psmouse                40336  0 
    pcspkr                  4224  0 
    serio_raw               7940  0 
    snd_hda_intel         346264  3 
    snd_pcm_oss            42144  0 
    snd_mixer_oss          17920  1 snd_pcm_oss
    ath_pci               101152  0 
    wlan                  207216  1 ath_pci
    ath_hal               194256  1 ath_pci
    snd_pcm                78724  2 snd_hda_intel,snd_pcm_oss
    snd_page_alloc         11400  2 snd_hda_intel,snd_pcm
    snd_hwdep              10500  1 snd_hda_intel
    video                  19856  0 
    output                  4736  1 video
    snd_seq_dummy           4868  0 
    ac                      6916  0 
    battery                14212  0 
    snd_seq_oss            35584  0 
    snd_seq_midi            9376  0 
    snd_rawmidi            25760  1 snd_seq_midi
    snd_seq_midi_event      8320  2 snd_seq_oss,snd_seq_midi
    asus_laptop            19064  0 
    snd_seq                54224  6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
    led_class               6020  1 asus_laptop
    snd_timer              24836  2 snd_pcm,snd_seq
    snd_seq_device          9612  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
    button                  9232  0 
    snd                    56996  17 snd_hda_intel,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_hwdep,snd_seq_dummy,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
    soundcore               8800  1 snd
    sis190                 22020  0 
    mii                     6400  1 sis190
    shpchp                 34452  0 
    pci_hotplug            30880  1 shpchp
    iptable_nat             8324  0 
    nf_nat                 20396  2 ipt_MASQUERADE,iptable_nat
    nf_conntrack_ipv4      19208  8 iptable_nat
    nf_conntrack           66752  7 ipt_MASQUERADE,nf_conntrack_irc,nf_conntrack_ftp,xt_state,iptable_nat,nf_nat,nf_conntrack_ipv4
    iptable_mangle          3712  0 
    iptable_filter          3840  1 
    ip_tables              14820  3 iptable_nat,iptable_mangle,iptable_filter
    x_tables               16132  9 xt_limit,xt_tcpudp,ipt_LOG,ipt_MASQUERADE,ipt_TOS,ipt_REJECT,xt_state,iptable_nat,ip_tables
    ext3                  136968  1 
    jbd                    48404  1 ext3
    mbcache                 9600  1 ext3
    loop                   18948  2 
    sd_mod                 30720  2 
    sg                     36880  0 
    sr_mod                 17956  0 
    cdrom                  37408  1 sr_mod
    ata_generic             8324  0 
    pata_acpi               8320  0 
    sata_sis                9732  1 
    ehci_hcd               37900  0 
    pata_sis               15236  1 sata_sis
    libata                159728  4 ata_generic,pata_acpi,sata_sis,pata_sis
    scsi_mod              151692  4 sd_mod,sg,sr_mod,libata
    ohci_hcd               26640  0 
    usbcore               146412  3 ehci_hcd,ohci_hcd
    thermal                16796  0 
    processor              36616  4 acpi_cpufreq,thermal
    fan                     5636  0 
    fbcon                  42912  0 
    tileblit                3584  1 fbcon
    font                    9472  1 fbcon
    bitblit                 6784  1 fbcon
    softcursor              3072  1 bitblit
    fuse                   50708  5 
    
  • mfillpotmfillpot Posts: 2,180
    Based upon the type of issues you are having it sounds like your installation medium was corrupt, which resulting in incomplete packages.

    What did you use to install Ubuntu, a home written disk, a flash driver, a purchased disk, etc.. ?
  • David1729David1729 Posts: 17
    I downloaded it and burned it onto a CD. (Or do I mean DVD?)
  • mfillpotmfillpot Posts: 2,180
    Did you verify the checksum of the iso file prior to burning it and also use the disk verify utility in your disk burning software to confirm the integrity of the file?
  • David1729David1729 Posts: 17
    I don't remember.
  • mfillpotmfillpot Posts: 2,180
    David1729 wrote:
    I don't remember.

    I highly recommend re-installing the OS, which includes re-downloading the iso, doing a md5sum integrity check, on the iso and verifying the disk when it is burned.
  • David1729David1729 Posts: 17
    Will I lose stuff I've installed?
  • mfillpotmfillpot Posts: 2,180
    Yes you will, as with any reinstall you should write down all apps you installed and back up your files first.
Sign In or Register to comment.