Welcome to the new Linux Foundation Forum!

[Resolved] ARG..... HELP PLEASE c:bob.txt filename

Hi Guys / Girls,

Im in serious need of assistance here, and Im hoping there is a solution thats relatively easy from the command terminal not gui interface....

I had a ^#$(^(#$^%&($ user generate a SQL script with a windows path and filename, and lovely SQL just converted it to one HUGE filename in the SQL execution directory this case /home/root

Now the problem exactly, the output filename is now in the /home/root diretory as c:bobsoutput.txt and I can not do a thing with it. I need to get it off server or something but using a scp or cp or even mv t try rename keeps giving me this error

{[email protected]}# scp c:osaso_security_rules.txt [email protected]:/home/gareth.thompson/
ssh: c: Name or service not known
{[email protected]}#


Any suggestions or assist would be greatly appreciated thanks,:S

Comments

  • jabiralijabirali Posts: 157
    Does this help?
    scp "$PWD/c:osaso_security_rules.txt" [email protected]:/home/gareth.thompson/
    
  • DigizaDigiza Posts: 11
    Thanks jabirali,

    Was just going to log on to ask about that system function :)

    kept trying "pwd/c:osaso_security_rules.txt" and was giving strange errors :P

    forgot the $

    Thanks though,
    -For everyones interest this works 100% alows moving and renaming without giving you errors.
  • jabiralijabirali Posts: 157
    I'm glad it worked!

    Digiza wrote:
    kept trying "pwd/c:osaso_security_rules.txt" and was giving strange errors :P
    Aha... If you want the output of the environment variable PWD, you use $PWD. If you wanted the output of the command pwd, you could have used $(pwd) instead. They both would have done the same :)
  • marcmarc Posts: 647
    Doesn't "pwd" actually look for the $PWD variable? ;)
  • jabiralijabirali Posts: 157
    marc wrote:
    Doesn't "pwd" actually look for the $PWD variable? ;)
    I believe you're right... I just wanted to show how to use the output of a command too, since he first tried using something like "pwd/filename" and not "PWD/filename" :-)
Sign In or Register to comment.