Welcome to the Linux Foundation Forum!

Amazon kills my IRC connection??!!!??

Goineasy9 Posts: 1,114

OK, it doesn't get any weirder than this.

My home network has quite a few computers on it. A Cablevision Motorola cable modem, attached to a Linksys router which has a few computers attached to it as well as a Linksys 8-Port workgroup switch (hub) in my office, which also has a few computers attached to it. Most of the machines run Fedora 13, although I keep one Windows 7 box attached for experimenting. OK.

One of the computers running Fedora 13 is dedicated as a print server and a 24/7 IRC box which runs Konversatiion. Over the past 2 weeks I have noticed something strange. Everytime I go to the Amazon website and either try to log on, or, search the site, oftc, freenode and now linuxdotcom disconnect. It's been a couple of weeks because I couldn't believe this was happening. I've had this IRC box running 24/7 for a couple of years and have visited Amazon any number of times and this has never happened before.

I can try using Firefox or Chrome. I can try on any of the Linux boxes and today I decided to try on the Windows box with the same result, IRC channels get disconnected. I can try to access using bookmarks, or googling Amazon and entering that way, same result.

I've tried restarting the modem, router and hub. I've checked DNS. I've tried accessing all sorts of other websites, pinging them, searching on them and Amazon is the only one that knocks out my IRC.

I've looked over my router settings and didn't find any clues, but, I'm not nearly proficient enough with networking to know where to look next.

BTW - I can disconnect oftc/freenode and then reconnect again without restarting any hardware, I finally figured this out today. I'm just so puzzled, why would accessing only Amazon cut off Konversation's access to the IRC servers?

Does anyone have any ideas?

Thanks in Advance



  • mfillpot
    mfillpot Posts: 2,177
    Lets see what wireshark tells you about the traffic during that scenario.
  • gomer
    gomer Posts: 158
    Tom, my best guess is that you have an issue in the network itself. Either a bad NIC or a bad cable, or some other oddity. Do you think you could whip up a simple network diagram that explains how everything is wired and mark which PC has the irc client running, and which PC you are using to browse Amazon.

    Also, out of curiosity, does it happen regardless of which machine accesses Amazon, or is it only a single machine accessing Amazon that seems to cause it? Do any other web sites or any other kind of network traffic seem to cause it?

    What model is the router, what model is the switch? Is the switch connect to the router using a cross over cable, or a "straigh-through" cable? Are all of the links on your LAN 100/full? 10/half? Gigabit? Is everything autosensing, or statically configured? Can you also grab either a wireshark or tcpdump capture from both machines involved during the outage? That would go a long way to identifying the problem.

    This is indeed quite the puzzle.
  • Goineasy9
    Goineasy9 Posts: 1,114
    Hey Adam,

    Haven't played with it for awhile, especially during the workday, I don't want the network going down. But, to answer your question, yes, it doesn't matter which box on the network I access Amazon from, it causes IRC to go down, and then, as I remember, other network effects. Sometimes I can recover just by rebooting, sometimes I have to reboot starting at the cable modem. I guess tonight after the market closes I'll try to access Amazon again and see it the problem persists. LOL.. thanks for reminding me, I haven't looked at it in a while. BBL


    p.s I'll collect part & model numbers and post later.

    Edit: Didn't get a chance to test network, cable cut out a couple of times today and I didn't want to reset everything again, but, I did collect part numbers etc.
    Cable Modem - SB5100 Surfboard
    Linksys Router - BEFSR81 (4 connections used, one to workgroup switch)
    Linksys 8 port workgroup switch - EZXS88W (6 connections used)
  • woboyle
    woboyle Posts: 501
    Very strange! It may be possible that Amazon has been pwnd and someone is trying to break into your systems. Definitely take a look at what wireshark shows you.
  • Goineasy9
    Goineasy9 Posts: 1,114
    Believe it or not, this is still going on, but not for long I hope. I've narrowed it down to the hub. If I restart the hub, it's not necessary to reboot router or computers.
    So, I purchased a Cisco Desktop Switch to replace the hub, hoping that will solve the problem.
  • mfillpot
    mfillpot Posts: 2,177
    Keep up posted, I look forward to seeing it it was a hardware problem in the hub or if it was acting that way in response to network traffic that may re-spawn the issue.


Upcoming Training