Welcome to the new Linux Foundation Forum!

Disabling Nepomuk

So basically what I want to do is to let Nepomuk burn in a fire.

Now my situation is like this: I am running Debian Squeeze which is the current testing. I am using the Trinity fork of KDE 3.5 which installs KDE into /opt separate from everything else. Now for some reason, what I do not know, Nepomuk is always running when I log into KDE. This does not happen when I log into XFCE for example, only when logging into KDE.

So where can I disable this memory hogging monster that is eating up my CPU for seemingly no good reason since it as far as I know is not at all used in KDE 3 but was only introduced in KDE 4. What is it that spawns nepomukserver and all those nepomukservicestub on login?

Comments

  • marcmarc Posts: 647
    Why don't you just uninstall it? I don't understand why you even have it on your system if you do not use KDE4...

    Anyway, given that you have it... can you launch the kde4 systemsettings? if so, you can disable nepomuk in there: Systemsettings->Advanced->Desktop Search
  • mfillpotmfillpot Posts: 2,180
    Nepomuk is enabled when you log into kde because the KDE4 elements have been loaded into your .kde directory within your profile.

    Since it appears you at trying to use KDE3 and the Nepomuk options do not exist in that implementation you may have to do into ~/.kde/share/config/nepomukserverrc and chahe the line that says "Start Nepomuk=true" to "Start Nepomuk=false".
  • RovanionRovanion Posts: 73
    Thanks a lot for the help.
    I will look into it once I get home to my laptop again.
  • RovanionRovanion Posts: 73
    Interestingely enough I think it helped slightly but not the whole way.
    Changing or in my case, adding that line stopped the nepomukservicestubs to be spawned. Tough it did not stop the nepomukserver itself from being spawned. Note that I changed both the nepomukserverrc in .kde and .kde3 since I wasn't sure which one was used, and which one was a backup and whatnot.

    I could live with having nepomukserver running. Of course it consumes a bit of RAM and some cycles, but if there is noone else has any idea I'll stick with this.
  • marcmarc Posts: 647
    Under .kde/share/config/ksmserverrc check for lines like this
    program2=/usr/bin/nepomukserver
    restartCommand2=/usr/bin/nepomukserver,-session,10127d7d5df000127488536300000021100005_1275003491_162689
    

    And remove them (the number 2 is probably different on your system)

    You can also make sure you have disasble it for the krunner interface and the plasma desktop. Files:
    .kde/share/config/krunnerrc
    .kde/share/config/plasma-desktoprc

    Lines:
    nepomuksearchEnabled=true
    

    And set them to:
    nepomuksearchEnabled=false
    

    You have to do this, of course, while you are *not* logged in KDE

    Then again, why don't you just uninstall them?
  • RovanionRovanion Posts: 73
    The reason why I haven't uninstalled nepomuk is because I cannot find the package. According to aptitude I have nothing installed that has nepomuk in it's name, yet it is there lurking. I can only assume that nepomuk was brought in by some other package in some way.

    Another person might not want to uninstall them because he or she occasionally uses KDE4, but that's not my case.
  • mfillpotmfillpot Posts: 2,180
    It is good to see that my modification stopped the spawning, but I don't think it would be advisable to completely remote it from the system.

    By my research the Nepomuk is part of the following packages (at least in Slackware, but I doubt it is different in other OSs because it is highly integrated.):

    kdebase-runtime
    kdebase-workspace
    kdebindings
    kdelibs
    kdepim-runtime
    oxygen-icons
    shared-desktop-ontologies

    Now I am curious about the large memory usage even when the spawning is disabled, can you tell me how much memory you are seeing in use and if it is using. When I reviewed nepomuk in top I only see 13M of resident memory used.
Sign In or Register to comment.