Welcome to the Linux Foundation Forum!

Yum not finding/listing installed rpms - missing dependency



I have a disk of all the rpms (just the rpms) of RH Ent. 5.1. I needed to intall some packages from it. For that I created a local repository. Following is what I did:

1. mounted DVD in /media

2. Issued createrepo on /media (Now the packages are in /media/mycdrom/RHE5Rpms and the repodata is in /media)

3. I added the following in the /etc/yum.conf





Now when I try to install, for example, qt4-devel, it can resolve the dependencies for one level. For example, it resolves libpng-devel (which is needed by qt4-devel), but it fails to resolve libpng (which is needed by libpng-devel). But libpng package is both available in the DVD and is already installed on the machine. Following is the tail of error messages I get after issuing the command 'yum install qt4-devel'





Error: Missing Dependency: libpng = 2:1.2.10-7 is needed by package libpng-devel

Error: Missing Dependency: mesa-libGLU = 6.5.1-7.2.el5 is needed by package mesa-libGLU-devel

Error: Missing Dependency: libX11 = 1.0.3-8.el5 is needed by package libX11-devel

Error: Missing Dependency: mesa-libGL = 6.5.1-7.2.el5 is needed by package mesa-libGL-devel

Error: Missing Dependency: freetype = 2.2.1-16.el5 is needed by package freetype-devel

All the above packages are available through the DVD and already installed on the machine.

As suggested by several forums I issued 'yum clean all' and 'rpm -rebuilddb'. But I still get the same error after doing so.

If anybody knows what it is, please let me know.

If any of the above is not clear, please let me know. I shall try to explain more clearly.



  • guna_pmk
    guna_pmk Posts: 2
    Thats my mistake. I had the Red Hat Enterprise 5.0 rpms in my repository but trying to update 5.1 machine. The version number for most of the packages were same/similar which cheated my eyes.

    Sorry about the confusion and thanks guys for your support



Upcoming Training