Welcome to the new Linux Foundation Forum!

Mounting USB wireless adapter and hard drive

grammjrgrammjr Posts: 35

Mounting USB wireless adapter and hard drive

I have a Linksys wireless G USB adapter. When I plug it in nothing happens, how do I install this hardware.

I also have a Vantec external USB hard-drive and when I turn it on it says it cannot mount the drive. How do I get this mount this drive. It is formatted NTFS, my windows back up drive.

I am very new to Linux and cannot find this information i the helps. Please keep it simple.. I can do command line :(

Thanks

Jim

«1

Comments

  • marcmarc Posts: 647
    grammjr wrote:
    Mounting USB wireless adapter and hard drive
    I have a Linksys wireless G USB adapter. When I plug it in nothing happens, how do I install this hardware.

    I also have a Vantec external USB hard-drive and when I turn it on it says it cannot mount the drive. How do I get this mount this drive. It is formatted NTFS, my windows back up drive.

    I am very new to Linux and cannot find this information i the helps. Please keep it simple.. I can do command line :(

    Welcome to the world of Linux Jim. Don't be afraid, every thing seems awkward when you start on this world and you come from the Windows world ;)

    First of all, it would help us a lot if you could tell us which linux distribution you are running.

    I will assume you are using ubuntu...

    For your wirless adapter... this is probably gonna be a bit difficult. First of all, make sure the device is detected by the kernel:
    sudo lsusb
    

    And check for your device. You can also have a look at:
    sudo cat /var/log/messages
    
    And check if the adapter is recognized or if it tells you any usefull information.

    If you are running a linux distribution using Networkmanager to manage your network(like ubuntu does), it should work out of the box unless there are any problems. You should be able to see wireless networks clicking on the networkmanager applet.

    Now, let's go for your external hard drive.

    Maybe there is a problem about permissions for mounting external devices. A good way to see if this is the real problem, is to check if you can mount the hard drive as root. For this we will do:
    sudo cat /var/log/messages
    
    And check for the output about yourr external hard drive. As an example, here you have the part you would need on my system.
    Mar 23 21:35:53 Telperion kernel: sd 4:0:0:0: Attached scsi generic sg2 type 0
    Mar 23 21:35:53 Telperion kernel: sd 4:0:0:0: [sdb] Attached SCSI removable disk
    Mar 23 21:36:32 Telperion kernel: sd 4:0:0:0: [sdb] 7744512 512-byte logical blocks: (3.96 GB/3.69 GiB)
    Mar 23 21:36:32 Telperion kernel: sdb: sdb1
    

    It says the device is known as "sdb" and it has one partition known as "sdb1".

    We would then mount it by:
    sudo mkdir -p /media/usb_disk
    

    To create the folder where we will mount the device.
    sudo mount /dev/sdb1 /media/usb_disk
    
    To actually mount the device.

    If this works, come again a will try to find a way to mount the hard drive as a regular user. It probably is just a matter of editing a line in /etc/fstab so don't worry ;)

    Good luck and I hope to hear good news from you soon!
  • grammjrgrammjr Posts: 35
    I just figured out the USB does recognize the WRLS adpater even by name, but will not connect to the wireless router.

    The USB HD even recognizes the HD name, but it gives me an Invalid mount option when attempting to mount volume "Jim Backup". So it knows it is my drive.

    Help
    Thanks..
    Jim
  • jabiralijabirali Posts: 157
    grammjr wrote:
    I have a Linksys wireless G USB adapter. When I plug it in nothing happens, how do I install this hardware.
    We first need to determine what driver you need for that adapter. Could you please open a terminal (it should be somewhere in the menu, if you use Ubuntu in Applications -> Accessories -> Terminal) and enter the following in the command line:
    lsusb
    
    If you copy the output of that command and post it here, it should help us figure out how to configure your wireless adapter.
    I also have a Vantec external USB hard-drive and when I turn it on it says it cannot mount the drive. How do I get this mount this drive. It is formatted NTFS, my windows back up drive.
    Try installing a package called ntfs-3g, restart your computer and try again. If you need help installing this package, please post what Linux distribution you are using ;)

    If the last suggestion didn't help, it could you please post some more information about your system? Two useful pieces of information would be what distribution you are using, and the literal error you get when you try to mount the harddrive.
  • grammjrgrammjr Posts: 35
    Ok I am getting smarter than a fifth grader.. I got the wireless adapter working. Yay.

    IS the issue with the external HD the fact that it is NTFS file format? So it will not mount?

    Thanks,
    Jim
  • jabiralijabirali Posts: 157
    Seems like Marc got here first with some great advice :)

    Congratulations on getting the wireless to work, that isn't always a trivial task.

    The external harddrive should mount just fine, but it might require a little bit of configuration first. Could you please post (1) what distribution you are using, and (2) the exact error message you get when you try to mount it? That should help us help you ;)
  • mfillpotmfillpot Posts: 2,180
    We will need the model information for both device to help you. Also when they are plugged in can you please copy the results of the following commands for us to see what is detected.

    sudo lshw
    sudo lsusb
    sudo lsmod
    sudo fdisk -l
  • grammjrgrammjr Posts: 35
    Very sorry.. Debian 5.0 I think not sure how to tell but I just loaded the current Debian install. Where can I find the exact install I have?

    Thanks.. I installed the package called ntfs-3g. It still did not work, but the detail guide was great, the problem after installing package called ntfs-3g was the drive was not shutdown safely in windows, was using as a SATA drive. I hooked it up to windows as a USB and safely disconnected and then Linux found it and mounted not problem.

    So the HD is is working thanks to this forum.

    The USB wireless adapter
    I thought I had it working but do not.. I am stupid and still have the cable plugged in LOL
    The USB wireless adapter, is found by linux, it is identified, I can set up the configuration to my router, but it just sits there, it will not turn to try to connect, light does not even flash. I am getting no errors. Linksys WUSB54GC
    It does everything, the wireless bars are at the top but it is just as if the adapter is not powered. This worked on this computer running windows, so I know it works.
    Here is what the USB viewer shows me

    Compact Wireless-G USB Adapter
    Manufacturer: Cisco-Linksys
    Speed: 480Mb/s (high)
    USB Version: 2.00
    Device Class: 00(>ifc )
    Device Subclass: 00
    Device Protocol: 00
    Maximum Default Endpoint Size: 64
    Number of Configurations: 1
    Vendor Id: 13b1
    Product Id: 0020
    Revision Number: 0.01

    Config Number: 1
    Number of Interfaces: 1
    Attributes: 80
    MaxPower Needed: 300mA

    Interface Number: 0
    Name: rt73usb
    Alternate Number: 0
    Class: ff(vend.)
    Sub Class: ff
    Protocol: ff
    Number of Endpoints: 2

    Endpoint Address: 81
    Direction: in
    Attribute: 2
    Type: Bulk
    Max Packet Size: 512
    Interval: 0ms

    Endpoint Address: 01
    Direction: out
    Attribute: 2
    Type: Bulk
    Max Packet Size: 512
    Interval: 0ms

    Not sure to to look at for this.

    Thanks,
    Jim
  • jabiralijabirali Posts: 157
    I'm glad you got your harddrive working! So the problem was basically that the harddrive was not unmounted cleanly, and therefore Linux didn't want to mount it? (It is possible to force it to mount when this happens, but I think your solution of mounting it in Windows first is a better one.)

    grammjr wrote:
    Debian 5.0 I think not sure how to tell but I just loaded the current Debian install. Where can I find the exact install I have?
    I think you've provided the information we needed, but for the record you can find the exact version you're using by running this command in a terminal:
    lsb_release -d
    

    As for the wireless, could you please try running the following in a terminal, and post the output here:
    iwconfig
    
    If the correct driver for your wireless adapter has not been loaded - meaning that Linux knows it is there, but not yet how to use it - all entries in the output should contain "no wireless extensions". If it has been loaded, the output might point us towards the source of error.
  • grammjrgrammjr Posts: 35
    First I found the build info in the System Monitor. Sad thing is I had to take screen shot and then move it to my windows computer to convert it to a PDF so I could make it searchable to be able to copy and paste the info in here. :) Hopefully I will figure out to do that here in this Linux computer.
    Debian
    Release 5.0.4 (lenny)
    Kernel Linux 2.6.26-2-686
    GNOME 2.22.3
    Hardware
    Memory: 504.1 MiB
    Processor: Mobile I ntel(R) Pentium(R) 4 - M CPU 2.00GHz
    System Status
    Available disk space: 24.8 GiB

    HD - yes once I installed the ntfs-3g, the issue then was the harddrive was not unmounted cleanly, it told me I could use the force unmount, but it was better to do a clean unmount from windows.


    Wireless adapter.

    debian:~# iwconfig
    lo no wireless extensions.

    eth0 no wireless extensions.

    Jim
  • jabiralijabirali Posts: 157
    OK, that last output was very helpful. Apparently, Linux hasn't loaded the driver for your wireless adapter yet. According to a quick lookup on linuxwireless.org, the correct driver to load for WUSB54G adapters is p54usb. Can you open that terminal again, and try running the following command:
    sudo modprobe p54usb
    
    When you've done that, try rerunning iwconfig in your terminal to check if it worked. If it did, is it then possible to connect to your wireless router from the panel applet?

    If the above works, you should make the driver load by default. To do that, first run the following command:
    sudo gedit /etc/modules
    
    That should bring up the file /etc/modules in gedit, a file that contains a list of drivers (kernel modules) to load when the system boots. To get the wireless driver mentioned above loaded automatically, add the following line to the end of the file and save it:
    p54usb
    

    Hope this helps :)
  • grammjrgrammjr Posts: 35
    debian:/home/jim/src# modprobe p54usb

    debian:/home/jim/src# iwconfig

    lo no wireless extensions.
    eth0 no wireless extensions.
    wmaster0 no wireless extensions.
    wlan0 IEEE 802.11 ESSID:"Hey"
    Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
    Tx-Power=0 dBm
    Retry min limit:7 RTS thr:off Fragment thr=2352 B
    Encryption key:BCFA-BDEA-CD
    Link Quality:0 Signal level:0 Noise level:0
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0

    debian:/home/jim/src# gedit /etc/modules
    cannot open display:
    Run 'gedit --help' to see a full list of available command line options.
    debian:/home/jim/src# gedit --help

    I did get the p54usb in the modules file with the text editor, could not do it with the gedit command.
    Rebooted and I get the same results.

    Now what is missing.. :-) there is a space between gedit and /
    also it acted like it was connecting, but the light still did not turn on and it did not connect.
    Jim
  • grammjrgrammjr Posts: 35
    I did get the p54usb in the modules file with the text editor, could not do it with the gedit command.
    Rebooted and I get the same results.
  • jabiralijabirali Posts: 157
    If you use su - instead of sudo, I think a working command would have been:
    DISPLAY=":0.0" gedit /etc/modules
    
    But the point of the gedit command was just to launch a text editor as root (you could well have used nano, vim, etc instead). As long as you managed to write p54usb in the modules file, the job is done :)

    Now, the new output of iwconfig clearly shows that this was the correct driver to load, and that it is working. Compared to the earlier output, notice the entry called wlan0 - that is the name that Linux now has assigned to your wireless adapter.

    Did you try using the panel applet to connect to your wireless router? If it didn't work, did you get any errors? If the panel applet doesn't do anything, do you get any output from the following command:
    iwlist scan
    
  • grammjrgrammjr Posts: 35
    Screenshot_Network_Settings.png

    The applet seems to work per this images. But it will not turn the light on or even try to connect. If I unplug it, it goes away and when I plug it back in it comes back with my router settings but never tries to connect.
    debian:~# iwlist scan
    lo        Interface doesn't support scanning.
    eth0      Interface doesn't support scanning.
    wmaster0  Interface doesn't support scanning.
    wlan0     Interface doesn't support scanning : Network is down
    

    Jim

    PS BTW :laugh:
    Do Not know how to put myself in the sudoers file... I reported my incident to myself... :laugh:
    [email protected]:~$ sudo gedit /etc/modules
    sudo: unable to resolve host debian
    
    We trust you have received the usual lecture from the local System
    Administrator. It usually boils down to these three things:
    
        #1) Respect the privacy of others.
        #2) Think before you type.
        #3) With great power comes great responsibility.
    
    [sudo] password for jim: 
    jim is not in the sudoers file.  This incident will be reported.
    [email protected]:~$ 
    
    [file name=Screenshot_wlan0_Properties.png size=43442]http://www.linux.com/media/kunena/attachments/legacy/files/Screenshot_wlan0_Properties.png[/file]
  • jabiralijabirali Posts: 157
    grammjr wrote:
    debian:~# iwlist scan
    wlan0 Interface doesn't support scanning : Network is down
    Try this command as root:
    ifconfig wlan0 up
    
    Did that help? Does iwlist scan give some output now? If not, any errors?

    By the way, the configuration utility you took a screenshot of was not really the applet I was talking about earlier... You might want to install a program called NetworkManager. Since I believe you used Debian with Gnome, take a quick look here:
    http://wiki.debian.org/WiFi/HowToUse#GNOME
    Do Not know how to put myself in the sudoers file... I reported my incident to myself... :laugh:
    If you want to give sudo permissions, you should first run this command as root:
    DISPLAY=":0.0" EDITOR="gedit" visudo
    
    That should bring up a text editor, displaying the sudo configuration file. To give a user called grammjr permission to run all commands as root, add a line like this to the file and save it:
    grammjr	ALL=(ALL) ALL
    
  • grammjrgrammjr Posts: 35
    Try this command as root:
    Code:
    ifconfig wlan0 up
    Did that help? Does iwlist scan give some output now? If not, any errors?
    debian:~# ifconfig wlan0 up
    SIOCSIFFLAGS: No such file or directory
    debian:~# iwlist
    Usage: iwlist [interface] scanning [essid NNN] [last]
                  [interface] frequency 
                  [interface] channel 
                  [interface] bitrate 
                  [interface] rate 
                  [interface] encryption 
                  [interface] keys 
                  [interface] power 
                  [interface] txpower 
                  [interface] retry 
                  [interface] ap 
                  [interface] accesspoints 
                  [interface] peers 
                  [interface] event 
                  [interface] auth 
                  [interface] wpakeys 
                  [interface] genie 
                  [interface] modulation 
    debian:~# 
    
    By the way, the configuration utility you took a screenshot of was not really the applet I was talking about earlier... You might want to install a program called NetworkManager.
    This is installed, but does not show any networks.
    Screenshot_Wireless_Networks.png

    Sorry I am laughing.. seems I get something like this everytime.....
    debian:~# DISPLAY=":0.0" EDITOR="gedit" visudo
    No protocol specified
    cannot open display: 
    Run 'gedit --help' to see a full list of available command line options.
    visudo: /etc/sudoers.tmp unchanged
    debian:~#
    

    ?????

    Like I said.. I am in forth grade.. LOL

    Thanks
    Jim
  • jabiralijabirali Posts: 157
    grammjr wrote:
    debian:~# ifconfig wlan0 up
    SIOCSIFFLAGS: No such file or directory
    I think we're getting closer to solving your problem. If I'm not mistaken, that error usually means that the firmware for your wireless adapter hasn't been loaded yet. Could you please post the output of the following command?
    dmesg |grep -i firmware
    
    debian:~# iwlist
    The command was "iwlist scan" ;). It's a way to test if your adapter was working; if it was, that command would scan for nearby access points and list their ESSIDs.
    debian:~# DISPLAY=":0.0" EDITOR="gedit" visudo
    No protocol specified
    cannot open display:
    Run 'gedit --help' to see a full list of available command line options.
    visudo: /etc/sudoers.tmp unchanged
    debian:~#
    Now that's weird, after a "su -" on my machine that command worked fine... Oh well, you might as well try nano instead. The following command should work without problems:
    EDITOR="nano -w" visudo
    
    That will open the sudoers file in the command line text editor named nano instead of gedit. Nano is quite an intuitive editor, and should be as user friendly as gedit except for lacking mouse support ;)
  • grammjrgrammjr Posts: 35
    EDITOR="nano -w" visudo

    This actually worked :woohoo:

    I had read that you needed the firmware file and I have isl3887usb and isl3886usb in the lib/firmware folder.
    Screenshot_firmware.png
    debian:/home/jim/src# dmesg |grep -i firmware
    [    1.047296] pci 0000:02:08.0: Firmware left e100 interrupts enabled; disabling
    [   21.665199] IBM TrackPoint firmware: 0x0b, buttons: 2/3
    
    
    debian:/home/jim/src# iwlist scan
    lo        Interface doesn't support scanning.
    eth0      Interface doesn't support scanning.
    

    Maybe I have the wrong firmware, but this is what the site told me.

    Again thanks for sticking with me...

    Jim
  • jabiralijabirali Posts: 157
    grammjr wrote:
    debian:/home/jim/src# iwlist scan
    lo Interface doesn't support scanning.
    eth0 Interface doesn't support scanning.
    Is that all the output of iwlist scan? It doesn't show wlan0 anymore, which means that the driver wasn't loaded automatically at boot (probably because p54usb was not added in the file /etc/modules before the last reboot..?)

    Try reloading the module manually:
    su -c "modprobe p54usb"
    
    And then make sure wlan0 exists again, and check that the firmware is loaded correctly:
    iwconfig
    ifconfig wlan0 up
    dmesg |grep -i firmware
    
  • grammjrgrammjr Posts: 35
    Ok clean reboot..
    /etc/modules
    # /etc/modules: kernel modules to load at boot time.
    #
    # This file contains the names of kernel modules that should be loaded
    # at boot time, one per line. Lines beginning with "#" are ignored.
    # Parameters can be specified after the module name.

    loop
    p54usb

    So I ran this code..
    iwconfig
    ifconfig wlan0 up
    dmesg |grep -i firmware
    

    This is what I got..
    [email protected]:~$ su -
    Password: 
    debian:~# iwlist scan
    lo        Interface doesn't support scanning.
    
    eth0      Interface doesn't support scanning.
    
    wmaster0  Interface doesn't support scanning.
    
    wlan0     Interface doesn't support scanning : Network is down
    
    debian:~# iwconfig
    lo        no wireless extensions.
    
    eth0      no wireless extensions.
    
    wmaster0  no wireless extensions.
    
    wlan0     IEEE 802.11  ESSID:"Hey"  
              Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated   
              Tx-Power=0 dBm   
              Retry min limit:7   RTS thr:off   Fragment thr=2352 B   
              Encryption key:BCFA-BDEA-CD
              Link Quality:0  Signal level:0  Noise level:0
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    
    debian:~# ifconfig wlan0 up
    SIOCSIFFLAGS: No such file or directory
    debian:~# dmesg |grep -i firmware
    [    1.043775] pci 0000:02:08.0: Firmware left e100 interrupts enabled; disabling
    [   23.239199] IBM TrackPoint firmware: 0x0b, buttons: 2/3
    [   38.835816] firmware: requesting rt73.bin
    [   38.908142] phy0 -> rt2x00lib_request_firmware: Error - Failed to request Firmware.
    [   38.908142] firmware: requesting rt73.bin
    [   38.922681] phy0 -> rt2x00lib_request_firmware: Error - Failed to request Firmware.
    [  100.177941] firmware: requesting rt73.bin
    [  100.188880] phy0 -> rt2x00lib_request_firmware: Error - Failed to request Firmware.
    [  234.901172] firmware: requesting rt73.bin
    [  234.932568] phy0 -> rt2x00lib_request_firmware: Error - Failed to request Firmware.
    [  445.187170] firmware: requesting rt73.bin
    [  445.203696] phy0 -> rt2x00lib_request_firmware: Error - Failed to request Firmware.
    [  537.647261] firmware: requesting rt73.bin
    [  537.669849] phy0 -> rt2x00lib_request_firmware: Error - Failed to request Firmware.
    [  935.187297] firmware: requesting rt73.bin
    [  935.203425] phy0 -> rt2x00lib_request_firmware: Error - Failed to request Firmware.
    debian:~# 
    

    I found these to sites, but do not really understand it all..
    http://marc-abramowitz.com/archives/2007/02/20/setting-up-a-linksys-wusb54gc-wlan-adapter-in-ubuntu/
    http://wwwu.uni-klu.ac.at/agebhard/WUSB54GC/

    tried it but no luck.
  • jabiralijabirali Posts: 157
    The links you found helped a lot. Upon closer inspection, it seems like I made a mistake earlier; I originally checked out this list to find a wireless driver for you, and noticed that Linksys WUSB54G Portable used p54usb - but further down it says that Linksys WUSB54GC-EU uses the driver rt73usb, which actually comes from the rt2x00 project mentioned in your first link.

    It seems like I was right about the missing firmware though:
    [ 38.835816] firmware: requesting rt73.bin
    [ 38.908142] phy0 -> rt2x00lib_request_firmware: Error - Failed to request Firmware
    In other words, you need the firmware rt73.bin to get your wireless working. Your earlier posts suggested that you're using Debian Lenny - the required firmware should then be provided in the package firmware-ralink:
    su -c "apt-get install firmware-ralink"
    

    Then edit your /etc/modules file to use rt73usb instead of p54usb:
    su -c "nano -w /etc/modules"
    
    # /etc/modules: kernel modules to load at boot time.
    #
    # This file contains the names of kernel modules that should be loaded
    # at boot time, one per line. Lines beginning with "#" are ignored.
    # Parameters can be specified after the module name.
    
    loop
    rt73usb
    

    And to avoid having to reboot, unload the p54usb module (just in case) and load rt73usb:
    su -
    rmmod p54usb
    modprobe rt73usb
    

    And then check that the wireless device is still named wlan0, try to enable it by using ifconfig up and check if iwlist scan has any effect now:
    iwconfig
    ifconfig wlan0 up
    iwlist wlan0 scan
    
  • grammjrgrammjr Posts: 35
    I have a rt73.bin file in my /home/jim/src/ this is just fyi..
    debian:~# apt-get install firmware-ralink
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    E: Couldn't find package firmware-ralink
    debian:~# 
    
    
  • jabiralijabirali Posts: 157
    It seems like the package wasn't available, perhaps you have the nonfree debian repositories disabled? Anyway, here is a direct link to the package:
    http://ftp.ca.debian.org/debian/pool/non-free/f/firmware-nonfree/firmware-ralink_0.14+lenny2_all.deb

    I personally prefer letting the package management utilities keep track of stuff, but you could of course just copy the file from /home/jim/src/ to /lib/firmware manually if you think that's easier :)
  • grammjrgrammjr Posts: 35
    OK getting closer..
    [email protected]:~$ su -
    Password: 
    debian:~# locate rt73
    /etc/Wireless/RT73STA/rt73.bin
    /etc/Wireless/RT73STA/rt73sta.dat
    /etc/udev/rules.d/50-ralink-rt73.rules
    /usr/share/doc/ralink-rt73
    /usr/share/doc/ralink-rt73-source
    /usr/share/modass/overrides/ralink-rt73-source
    /usr/src/ralink-rt73.tar.gz
    /var/lib/dpkg/info/ralink-rt73-source.list
    /var/lib/dpkg/info/ralink-rt73-source.md5sums
    /var/lib/dpkg/info/ralink-rt73.conffiles
    /var/lib/dpkg/info/ralink-rt73.list
    /var/lib/dpkg/info/ralink-rt73.md5sums
    debian:~# 
    
    

    It seems to be able to find the networks in iwlist wlan0 scan, but when I unplug the cable no connection, does not show up in the NETWORK MANAGER
    Screenshot_Wireless_Networks_1.png
    debian:~# locate rt73usb.ko
    debian:~# modprobe rt73usb
    FATAL: Could not open '/lib/modules/2.6.26-2-686/kernel/drivers/net/wireless/rt2x00/rt73usb.ko': No such file or directory
    
    debian:~# iwconfig
    lo        no wireless extensions.
    
    eth0      no wireless extensions.
    
    wmaster0  no wireless extensions.
    
    wlan0     IEEE 802.11  ESSID:""  
              Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated   
              Tx-Power=12 dBm   
              Retry min limit:7   RTS thr:off   Fragment thr=2352 B   
              Encryption key:off
              Link Quality:0  Signal level:0  Noise level:0
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    
    debian:~# ifconfig wlan0 up
    debian:~# iwlist wlan0 scan
    wlan0     Scan completed :
              Cell 01 - Address: 00:24:01:72:92:29
                        ESSID:"Hey"
                        Mode:Master
                        Channel:9
                        Frequency:2.452 GHz (Channel 9)
                        Quality=50/100  Signal level=-56 dBm  
                        Encryption key:on
                        Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                                  9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                                  48 Mb/s; 54 Mb/s
                        Extra:tsf=00000000c7f9c180
              Cell 02 - Address: 00:1B:11:A3:B8:D4
                        ESSID:"GA_CASA"
                        Mode:Master
                        Channel:6
                        Frequency:2.437 GHz (Channel 6)
                        Quality=46/100  Signal level=-80 dBm  
                        Encryption key:on
                        Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                                  9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                                  48 Mb/s; 54 Mb/s
                        Extra:tsf=000000397d3af179
              Cell 03 - Address: 00:15:D0:40:CC:55
                        ESSID:"Domingo"
                        Mode:Master
                        Channel:11
                        Frequency:2.462 GHz (Channel 11)
                        Quality=46/100  Signal level=-82 dBm  
                        Encryption key:on
                        Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                                  9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                                  48 Mb/s; 54 Mb/s
                        Extra:tsf=000004403a295043
    
    debian:~# 
    debian:/lib/modules/2.6.26-2-686/kernel/drivers/net/wireless/rt2x00# ls
    rt2400pci.ko  rt2500usb.ko  rt2x00pci.ko  rt61pci.ko
    rt2500pci.ko  rt2x00lib.ko  rt2x00usb.ko
    
    

    At one time I did have a rt73usb.ko in the :/lib/modules/2.6.26-2-686/kernel/drivers/net/wireless/rt2x00 directory but no more..

    I have tried everything and cannot get any install or package to put the rt73usb.ko into the kernal directory....
  • jabiralijabirali Posts: 157
    The driver rt73usb was present on my system... But anyway, it's not important anymore. Now that iwlist scan is working, it means that your Linux machine is autoloading some working kernel module, and your wireless adapter is now working! In other words, just ignore everything I said about /etc/modules, modprobe and rt73usb, and lets move on to configuring your adapter :D

    Try giving yourself the permissions to configure network interfaces:
    su -
    usermod -G netdev jim
    
    Then reboot, and try starting network manager again :)
  • grammjrgrammjr Posts: 35
    Well, I am screwed here... I tried to clean this up as it was now sort of working and now I have nothing at all and cannot for the life of me get it back. I have no clue what I had loaded that made this sort of work.
    USB sees it but it is red, what ever that means.. I know for sure it means it is not working.



    debian:~# iwlist
    Usage: iwlist [interface] scanning [essid NNN] [last]
                  [interface] frequency 
                  [interface] channel 
                  [interface] bitrate 
                  [interface] rate 
                  [interface] encryption 
                  [interface] keys 
                  [interface] power 
                  [interface] txpower 
                  [interface] retry 
                  [interface] ap 
                  [interface] accesspoints 
                  [interface] peers 
                  [interface] event 
                  [interface] auth 
                  [interface] wpakeys 
                  [interface] genie 
                  [interface] modulation 
    debian:~# iwconfig
    lo        no wireless extensions.
    
    eth0      no wireless extensions.
    
    debian:~# ifconfig
    eth0      Link encap:Ethernet  HWaddr 00:02:a5:c3:c4:fa  
              inet addr:192.168.0.190  Bcast:192.168.0.255  Mask:255.255.255.0
              inet6 addr: fe80::202:a5ff:fec3:c4fa/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:1517 errors:0 dropped:0 overruns:0 frame:0
              TX packets:1079 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:479521 (468.2 KiB)  TX bytes:187326 (182.9 KiB)
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:319 errors:0 dropped:0 overruns:0 frame:0
              TX packets:319 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:151541 (147.9 KiB)  TX bytes:151541 (147.9 KiB)
    
    debian:~# 
    
    

    Now I am getting frustrated I really do not know what I did to make this stop working.....
  • grammjrgrammjr Posts: 35
    Screenshot_USB_Viewer.png
    debian:~# lsusb
    Bus 003 Device 006: ID 13b1:0020 Linksys WUSB54GC 802.11g Adapter [ralink rt73]
    Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 001 Device 003: ID 093a:2510 Pixart Imaging, Inc. Hama Optical Mouse
    Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    debian:~# 
    
    

    Appears I have lost my firmware
    debian:/etc/network# dmesg |grep -i firmware
    [    1.059057] pci 0000:02:08.0: Firmware left e100 interrupts enabled; disabling
    [   21.980824] IBM TrackPoint firmware: 0x0b, buttons: 2/3
    
  • jabiralijabirali Posts: 157
    According to lsusb, the kernel knows there is something there - but ifconfig doesn't show wlan0 any more, meaning that the device is not recognized as a network device. For some reason, the system is no longer loading the driver necessary for the adapter to work.

    Before you got the wireless working, was p54usb the only driver that you loaded manually, or did you try to follow some guides to use e.g. the rt2x00 drivers? If the latter, can you provide links to those guides? And when you were cleaning up, do you remember if you uninstalled any packages? Or perhaps modified/removed any files?

    Can you also double-check that rt73usb is still missing:
    find /lib/modules/$(uname -r)/kernel/drivers/net/wireless/rt2x00/ -iname *.ko
    
    According to packages.debian.org, the latest package for the Linux kernel in the Debian Stable repositories should also provide the kernel module rt73usb.
  • grammjrgrammjr Posts: 35
    Jabir,
    OK, thanks so much for hanging in there with me.
    I finally had to go back to step one, I reinstalled DEBIAN Lenny 5.0 with the USB wireless adapter plugged in. I am actually sending this through the wireless connection. I really have no idea how this is working.
    But when I was done with the install it still did not work, although the rt73usb.ko was back.
    I had to ndiswrapper the rt73.inf file to get the rt73.bin file installed into the /lib/firmware folder.
    I then rebooted and it could see the adapter, I then followed you direction
    su -
    usermod -G netdev jim
    
    Again rebooted and the adapter started blinking and working.

    However the wireless-network manager still does not see it even though it is working.
    [file name=Screenshot_Wireless_Networks.png size=22789]http://www.linux.com/media/kunena/attachments/legacy/files/Screenshot_Wireless_Networks.png[/file]
    Screenshot_firmware-8c736e1f028e364558865b0ea3922557.png
    debian:~# dmesg |grep -i firmware
    [    0.961409] pci 0000:02:08.0: Firmware left e100 interrupts enabled; disabling
    [   21.032063] firmware: requesting rt73.bin
    [   21.253850] IBM TrackPoint firmware: 0x0b, buttons: 2/3
    
    

    What can I post here to help others since this is working, any other folder contents?
    Not ever sure I can get this going again if it stops tomorrow.. LOL
    Again thanks
    Jim
  • grammjrgrammjr Posts: 35
    Now my USB thumb drive will not mount and I have no sound, man,,,
    Screenshot_gnome_mount.png

    And how do I post 2 images, every time I try I get 2 the same?
    Jim
Sign In or Register to comment.