Welcome to the Linux Foundation Forum!

Live USB image does not complete the boot process

metaylor
metaylor Posts: 17

I use livecd-creator and a custom kickstart file to create F12 liveUSB images. I have created a few images which worked well until a month ago when I made some changes to allow root login and set selinux to permissive mode.

Now when I create an image, it does not work as expected in that the Fedora logo screen is not displayed and the Gnome Desktop does not launch on one of the 6 computers.

The senario is when I install the USB and turn on the power, the BIOS splash screen is displayed. Additionally, the Fedora count down screen is also displayed. However, after the count down has completed, the screen goes dark with only the cursor displayed. After a few seconds the monitor loses synchronization and the message "No input signal" is displayed and Gnome Desktop does not launch.

The liveUSB I previously created still works all 6 computers. This only happens with newer images I create. Also, I download the Fedora live image, burned it to a USB and tried it. It also exibited the issue.

In trying to diagnose this, I downloaded F12 and installed it on the computer which exhibits this issue and everything worked fine.

It seems to me that there should be a way to determine which (if any) of the boot scripts are executed before the message "No input signal" is displayed.

Any ideas?

Comments

  • Goineasy9
    Goineasy9 Posts: 1,116
    If you hit escape during the boot process, watching the boot scroll can give you the information you need. If not, try looking in /var/log/messages or /var/log/boot.log and see if anything looks interesting.
  • metaylor
    metaylor Posts: 17
    Thanks for the reply.

    Unfortunately when I hit the escape key, there was nothing displayed. Regarding checking /var/log/messages or /var/log/boot.log files, I should clarify that because after the count down has finished, nothing is displayed on the monitor due to the issue at hand I cannot login to check the files -see attachment.

    Is there a way that I can bypass the live countdown splash screen altogether? I would at least like to see whether the system getting to the startup mode which allows for interactive boot...
  • metaylor
    metaylor Posts: 17
    attachment is too large to upload but basically it is a picture of a blank monitor :(
  • Goineasy9
    Goineasy9 Posts: 1,116
    During my Live CD boots of fedora, during the countdown, if I hit ESC, it brings me to a screen where I hit TAB and modify the boot options. At this point I would add a 3 to the kernel line and boot up into terminal. I'm at a loss, unless it has to do with your customization, why that isn't working.

    I'm also having flashbacks to problems with unetbootin, I don't know if LiveCD creator uses that or not, but there was a problem with F12 and USB's created using unetbootin at one point.

    I'm also having memories of problems when turning off selinux with some who have tried to create Live USB sticks, but I did a quick search through bugzilla and the fedora forums and haven't found the posts I was looking for.

    When the screen goes dark with a flashing cursor, it's usually a graphics problem, and the only way I know of to work on that is to boot into init 3.

    Maybe someone else here can chime in with some new ideas, but, aside from that, you might just have to rebuild and see if reverting some of the changes helps.
  • mfillpot
    mfillpot Posts: 2,180
    It sounds like the SELinux modifications have effected the USB image creation process, most likely by restricting the script from modifying or copying the files that it created in the first place. Try reverting your SELinux settings and trying again to see if it was SELinux or maybe an update to the livecd-creator application that is causing the problems.
  • metaylor
    metaylor Posts: 17
    I did boot the USB on system which works and I edited the inittab to boot single user mode. Then I tried it on the system in question and this did not resolve the issue. However, I will still try doing this during the boot process and use init 3 instead of single user. It can't hurt ;)

    Regarding unetbootin and liveCD allow me to provide some clarification. I am using the livecd-creator program ( which can be installed with yum) to create the ISO file. Then I use Fedora Live USB Creator tool for Windows to burn the ISO file to USB.
    This process creates a USB which works on 5 of 6 pf my computer systems model. I can try the Fedora Live USB Creator for Linux to burn the ISO file to USB.

    Regarding SELinux, the reason I downloaded the Live image from Fedora was to see if it exhibited the same issue. If it did (and it does) then to me that says I did not induce this issue during the process of creating the ISO file.

    So I will do the following
    Try the Fedora Live USB Creator for Linux to burn the ISO file to USB.
    Use yum to see if there was an update the the livecd-creator program that I use to create the image.
  • Goineasy9
    Goineasy9 Posts: 1,116
    The last time liveusb-creator was updated was back in December.

    If I come up with any other ideas I'll post. FYI - I have a Live CD of F13 RC3 Gnome based that boots on 4 of 5 desktops. The KDE version boots on all 5. I'm just mentioning this because I'm curious as to what the problem is. That computer, unlike my others, has an ATI graphics card, though I wouldn't point to it as the problem, since the KDE version boots up fine. It's just interesting. It also ends up with a black screen like you describe.

Categories

Upcoming Training