Welcome to the Linux Foundation Forum!

starting ubuntu karmic from text edit box

dotgillies Posts: 5

I have installed ubuntu karmic and set it up nicely. I think it may have gone into hibernation while in the terminal. and then was restarted. It boots to terminal . I don't know how to start my desktop from there. Any help would be nice. Thanks

After doing some reading I'm wondering if xorg? is locked. I'm not sure I can figure out what to do


  • Goineasy9
    Goineasy9 Posts: 1,114
    Did you try to execute "startx" in the terminal?
  • dotgillies
    dotgillies Posts: 5
    yes but I don't know where to go after that
  • jabirali
    jabirali Posts: 157
    dotgillies wrote:
    yes but I don't know where to go after that
    Do you mean that "startx" launches the graphical system, but doesn't give you your desktop?

    In that case, you can try:
    echo "exec gnome-session" > ~/.xinitrc

    If your problem is that "startx" doesn't manage to launch the graphical system at all, it would be helpful if you could post any errors you receive, and perhaps upload a copy of the file /var/log/Xorg.0.log .
  • dotgillies
    dotgillies Posts: 5
    Thanks for the help but I'm stuck
    startx gives server not authorized to run x server
    I tried to give password and then try again

    so I tried sudo startx
    gives Fatal Server error
    Server is already active for display 0
    If server is no longer active, remove /tmp/.X0-lock and start again
    gives ddxsigGive Up xinit: server error

    My screen has a text box with my name@computer name

    no GUI

    I haven't tried your suggestion because I don't think I'm getting the right syntax

    I was hoping if I booted with a live cd that I could load whatever file I need to go on but....
  • jabirali
    jabirali Posts: 157
    Hmm... Apparently, your computer believes that the graphical system has already been started:
    Server is already active for display 0

    Here are a few suggestions you can try:
    1) Press Ctrl + Alt + F7. If it really is true that the graphical system is running in the background, this should bring it back.
    2) Try the following command:
    startx -- :1
    That should make startx ignore the already running version of the graphical system (display 0), and create a new instance (display 1). If that doesn't work, what error message do you then get?
    3) You should try booting up with a LiveCD, and paste the contents of the files /etc/X11/xorg.conf and /var/log/Xorg.0.log here. That will make it easier for us to help you, since it would provide us with all the technical details of (1) how your system is configured, and (2) what really happens when the graphical system tries to start.

    Good luck :)

    I just want to clarify that I meant the files /etc/X11/xorg.conf and /var/log/Xorg.0.log from your harddrive, not the versions on the LiveCD. The reason I mentioned a LiveCD was simply to make it easier to paste the entire contents of those files at the forums :)
  • marc
    marc Posts: 647
    sudo init 3

    To make sure you are on text mode and therefore you don't have any graphical session running
    sudo init 5

    To get back to graphical mode.

    However, the best way to go through these kind of problemes is to check the system logs. Those are on /var/log.

    Specially check the /var/log/Xorg.0.log and /var/log/messages.
  • Maude
    Maude Posts: 5
    You know what I'd do? I do a clean install and use 10.04. I have no idea how to get out of terminal or why it's doing that.
    It would be easier on you nerves to start over.
  • marc
    marc Posts: 647
    Maude wrote:
    You know what I'd do? I do a clean install and use 10.04. I have no idea how to get out of terminal or why it's doing that.
    It would be easier on you nerves to start over.

    That might "solve" the problem although it will *not* give him anything positive at all from the experience. If we find out what the problems is, he'll have a much richer knowledge about his/her system and we'll be able to find solutions for future posible problems much more easyly.
  • mfillpot
    mfillpot Posts: 2,177
    It does sound like the GUi is loaded under the root user, so you cannot call startx under a non-root user and changing the xinitrc won't help either.

    Does it also go into the terminal after a reboot?
    Have you tried the Alt-F7 key combination as was previously suggested?
  • Maude
    Maude Posts: 5
    I don't think going around in circles with the command line is fun.
    There is always an easier way to do things.
    The desktop has problems, that's why I said do a clean install. It solves the problem.
    After Dorothy uses ubuntu for a time, it will probably come to her what went wrong.
    It is possible the desktop was removed in Synaptic Package Manager.
    The gnome desktop comes up if everything is okay.
    ubuntu is for end users. To make it easier. User friendly.
    I do tech and what works is what I do.
    If you want difficult, use Windoz or Apple.
  • dotgillies
    dotgillies Posts: 5
    Thanks for the input

    If I am doing the commands right, then they don't work
    I looked at the var/log/xorg.0.log after loading from live cd

    I have the mouse and keyboard working but the final error seems to be the power button on the keyboard
    I have an older logitech wireless mouse and kb combo. So I am going to try booting with a wired keyboard
    and mouse.

    I just have to wait for the ballgame to be over as our new tv with a vga input is my monitor :)
    If anyone has an idea about that I'll be waiting. This is my project computer and we loaded Enna media
    center. Used it several times on and off. I don't think I loaded anything else. So I may be reinstalling
    Ubuntu in a couple of days
  • dotgillies
    dotgillies Posts: 5
    Thanks for all your help. I learned a few things but was not able to fix my problem so I reinstalled. I am sure
    that one of these days I will understand what to do :)
    Thank you


Upcoming Training