Welcome to the Linux Foundation Forum!

problems with Tomcat (not working)


I use Debian and want to use Tomcat for web applications (JSP).

So I installed Apache, Tomcat and OpenJava from the Debian repository.

But it doesn't work on my local machine -> apache is running but Tomcat doesn' work.

What I have to do to use Tomcat for my WebApplications?


  • Goineasy9
    Goineasy9 Posts: 1,114
    I think you need to be more specific than "it doesn't work". Do you get error messages? What are the symptoms of "it doesn't work?
  • pixel
    pixel Posts: 7
    I tried out some instructions but I failed.

    Apache works properly (web pages were delivered).

    I can start Tomcat with OpenJava (from Debian repository); but the start failed (output: "failed" ) as I tried it with SUN Java JDK.
    # /etc/init.d/tomcat start
    Using CATALINA_BASE: /opt/apache-tomcat
    Using CATALINA_HOME: /opt/apache-tomcat
    Using CATALINA_TMPDIR: /opt/apache-tomcat/temp
    Using JRE_HOME: /usr/lib/jvm/java-6-sun/jre
    Using CLASSPATH: /opt/apache-tomcat/bin/bootstrap.jar

    I cannot find the name "Tomcat" in any of my running processes. Is there a separate process or is there apache only?

    I couldn't find some more helpful output. How can I check the services to find out what the problem is?
    Thanks for any help.
  • Goineasy9
    Goineasy9 Posts: 1,114
    I'm not an apache user, but wouldn't something like "services --status-all" or "chkconfig --list" give you a rundown on what services are installed and what their status is?
  • mfillpot
    mfillpot Posts: 2,177
    Please checkout http://www.debianadmin.com/how-to-setup-apache-tomcat-55-on-debian-etch.html that guide may tell you what is necessary to get it completely installed and running.
  • pixel
    pixel Posts: 7

    This and other links I found before. And I tried to do so but it failed.
    Maybe Tomcat is running and my applications are not correct.

    So I will learn more how to run applications with Tomcat.


Upcoming Training