Welcome to the Linux Foundation Forum!

Folder Permission through Samba Access


I tried to research the forum to see if there is already a written solution for this problem but I see that there is none yet.

So, here it goes :

I connect my winxp computer to an ubuntu server through samba connection. The connection works.

In my linux home directory, there is a softlink to another root directory, it does not open.

I checked the permission of the actual directory and it has a 777 permission, I do wonder why can't I access it.

I tried to log in to the server, i opened the softlink, it opens.

What seems to be the problem?

Please advise.


  • woboyle
    woboyle Posts: 501
    A soft link can point to a directory or file that is not in your share. If you could navigate to it, then you would be exploiting an escalation of privileges - not a good thing. So, the behavior is as intended, and "a good thing".
  • agentrenegade
    It seems that this is still left unresolved.

    I do wonder if ubuntu has released a patch to the samba version it uses.

    Apparently, I encountered this after I responded to the update request of the linux server.

    As mentioned before, the samba connection is working.

    Unfortunately, one softlink does not open in the windows view.

    Checking the server, it shows that I can open the softlink.

    My speculation is this : samba has another set of permission that allows the samba user (which happens to be the same as my linux account) to open a softlink directed to another partition.

    Logging to the server using the linux account and linux method of authentication, the system recognizes that the account has permission to open the softlink.

    Connecting to the server through samba uses the permission of the samba account and apparently, the system does not allow the samba account to open the softlink.

    I hope someone can help me resolve this.
  • mfillpot
    mfillpot Posts: 2,177
    I agree with what rubberman stated. The symbolic link should work if it is in the same shared directory. However if the link is pointing to a directory that is outside of the said shared directory ,in another shared directory of an unshared location then it will not work.

    This is a security feature not a bug.

    If the destination directory is within the current share then it can be a problem, but you have not given us enough information to figure out if the links should or should not be working.


Upcoming Training