Welcome to the Linux Foundation Forum!

Wireless Networking Card


Howdido Linux community!

I'm using Debian Lenny and I'm here to try for a last time to get my wireless networking card working on my Dell Latitude C600.

My card is a D-Link AirPlus DWL-650+. As I've gotten it explained to me this card is especially tricky since it could actually be somewhere around five different peices of hardware. Yet I have trough excellent help from the Debian IRC been able to pin down exactly what type it is. It is an tiacx100 with the tiacx100r0D radio transmitter, atleast that's what I've been told.

Now this should have worked out well and looked as if it would, only that it doesn't. Once I try to connect to a wireless network with the help of KNetworkManager the process stops at 28%. I have no clue to what is going on on the dark side of the system, so that is what I'm wondering if you wonderful Debian lads could figure out.

One thing that makes the task additionally difficult is that the kernel message buffer, dmesg, seems to go ballistics as soon as the card is entered into the system. Before that the system could be going on for months without filling up the buffer but once the pcm-cia card is inserted it is over. So here is an example of what dmesg prints as soon as the card is inserted:


And that is the ammount of reporting that filled dmesg after the card being inserted for 2 seconds.

Now that may be a part of the problem tough the real issue really is when I try to connect to my local wireless network. I have tried connecting to my router with different types of encryption and bandwith but nothing seems to change the situation. This is dmesg after trying to connect to my unencrypted network:


One thing that should be mentioned is that my networking card very well finds wireless networks. So it's only connecting to them that is the issue. So what is wrong with this picture. Have I configured my interface wrong, do I have the wrong drivers in some wierd way? Should I post any other files to complete these dmesg outputs? Please help me work this issue out.


  • Goineasy9
    Goineasy9 Posts: 1,114
    At just a first look, I found a troubleshooting section at http://acx100.sourceforge.net/wiki/Main_Page with the following section:
    Edit: The module may generate in some cases many debug messages looking like: acx: unknown EID 45 in mgmt frame at offset 86...; causing sometimes a system freeze.
    You may disable these debug messages when loading the module:
    modprobe acx debug=0
    On a debian system, you may create a file /etc/modules.d/acx containing:
    options acx debug=0

    Which may stop the dmesg debug messages.

    I Googled "acx: unknown EID 45 in mgmt frame" and many hits came up. Why don't you take a look and see if something looks familiar. I might be that the driver is close but not exactly what you need.

    There are some real experts that look at these forums, one might be able to do a better job diagnosing the errors.

    Hope this helped a little.
  • Zanpaktou
    Zanpaktou Posts: 30
    Hi Rovanion,
    The chances of your card working are quite slim unfortunately. Sorry to break it to you. By the looks of it, your adapter maybe has a version of the wireless chip which the driver cannot operate corectly on or you are experiencing the locking bug on smp systems (If you have more than one processor core.)
    If you have followed these instructions :
    And the output from dmesg is that, I don't think it's going to work for you.

    I can only recommend that you buy a Linux compatible usb wireless adapter instead. Anything with a RaLink chip inside it will definitely work. Like this one :
    Tenda Wireless-G USB Adapter - (W541U 54M Wireless USB Adapter)

    Blame Texas instruments for not engaging in Linux development. But then again, it's their loss and/or stupidity for not doing so.:silly:
    Lesson learned. Don't buy hardware from vendors which do not engage in Linux development. Shun them instead. :laugh:
  • Rovanion
    Rovanion Posts: 73
    To be completely honest. I got this computer for free.
    Anyhow thanks for the help. I will try getting a new kernel running on my box, due to someone on the Debian forums suggesting it. He mentioned that the driver was marked as experimental and that maybe it would have reached a more stable state in a newer version.


Upcoming Training