Welcome to the new Linux Foundation Forum!

I can´t connet to WLAN-Network with any Linux!

Hello,

I am beginner with Linux. I have loaded with unetbootin several Linuxt distributions, Knoppix, Ubuntu, CD-Linux a.s.o.

They booting from my USB Flash, they are workin very well, some of them are also playing movies or mp3 but no one does connect to Internet (WLAN). They show a lot of SSID ´s, that means, my WLAN is working. It´s working with Win7 or WinXP pretty well, but not with Linux. It´s trying to connect, but it doesn´t.:(

Can anybody explain and help me?

my SKYPE is (apata12). Thanks very much.

from Germany.

Comments

  • mfillpotmfillpot Posts: 2,180
    Please post the output of "sudo lspci|grep -i wire" here so we can see what kind of wireless card you have. I am thinking that there may be some stability issues with the wireless card, but until we know what kind of card it cannot be confirmed.
  • Hello,

    and thanks very much for your reply! Sorry I´m back in win7, so I can´t post it from Live-ubuntu, but I know very well
    the hardware:

    It´s a Realtek RTL 8187B USB 2.0 Wireless Network Adapter

    Driver Version from Win7 is: 62.1181.1105.2009

    And its working and connecting with my WLAN Router very well. But not with Linux.

    The report was: " its connecting ....... and after 10 sec.: "You are now offline"

    I hope this info is enough, because I am a beginner. But I try again to boot from USB and try with sudo to send you the report.

    Thanks
    from Germany
  • mfillpotmfillpot Posts: 2,180
    ah realtek, I was having some issues with a similar realtek wifi chip a while back. The primary issue was that it does not correctly interface with a 64-bit operating system. If you were trying to run ubuntu 64-bit then I recommend trying the 32-bit version.
  • Hello,

    I tried with: Ubuntu, Kubuntu lucid-i386, 9.10 Ubuntu, knoppix 6.2, puppy 4.31, linux Mint 8, all the same result with x86!

    I think that the standard driver in linux doesn´t give enough power to the USB WLAN adapter! Because with Win7x64 and WinXPprof. 32-bit works fine and connects good. And linux is finding a wireless network but it doesn´t connect....:(

    I would like to try a driver from Realtek Linux, but I have never done it, because I dont understand such things with: sudo etc....
  • Goineasy9Goineasy9 Posts: 1,116
    I hate to say it, but I have never found a Linux driver that works with the rtl8187B. I have one on an Asus motherboard that I bought a few years back, tried the Windows driver with ndiswrapper that came on the disk with the motherboard, tried the drivers from the Realtek site (also Windows drivers with ndiswrapper) with no luck. One of the problems with this chip IMHO is that it was designed to act as a wireless access point, and does with Windows drivers, but will not work under Linux because drivers were not created to take into account that functionality. That's just my guessing. Chips like the 8187SE which were designed to do simple wireless tasks, are having luck running with some Linux drivers.

    BTW - If anyone has found a working driver for the rtl8187B, please prove me wrong and let us know. This is the only hardware fail I've had since Linux became my main OS.
  • Thanks very much to: "Goineasy9 ".

    I think you are right, because in the meantime I looked to the website of Realtek and saw that other chips like you said 8187SE have Linux driver.

    So I give up and try to change the Network adapter.

    My last question from a beginner to a linux guru is: What is the best linux distro for Internet, xvid/dvd/3gp2 movies, and easy WLAN configuration with a easy desktop?

    Thanks and greetings from Germany. (sorry for my bad english!)
  • Goineasy9Goineasy9 Posts: 1,116
    I was in Germany for LinuxTag 2 years ago, and, I'm sure your English is way better than my Tourist German, so, don't apologize.
    As far as a recommendation for a Linux beginner, I still would start out with Linux Mint. This way your DVD's, music and videos will play right out of the box. I'm not familiar with xvid or 3gp2 formats, but, your best bet would be Mint. You can always experiment after that.
  • woboylewoboyle Posts: 501
    If your Linux system is showing the SSID's of available access points, then the driver is working. You need to go into the network configuration tool and specify the AP you want to communicate with, as well as the sercurity type (WEP, WPA) and key or passphrase.
  • Hello again,

    yesterday I tried again Knoppix, Ubuntu lucid 10.04 alpha the newest, and Igelle on USB Flash. Knoppix is very quick, Ubuntu nearly fast as Knoppix but Igelle doesn´t boot from USB. My experience with USB Linux is: I am well suprised with Knoppix, CD-Linux, Puppy and Slax, they are all working fine. :) Some big Distros like: Open Suse or Fedora doesn´t boot from USB!? :S

    Knoppix and Ubuntu is showing me nearly all SSID´s. I try to donnect with one open network with no encryption (as I was connected with win7 and winxp very well, also with no Encryption!!!) but after 10 sec. the answere ist " Disconnected - You are now offline!"

    Therefore I say, maybe the linux driver doesn´t give to the network adapter enough power ??? Sorry but thats my feeling.

    Thanks to woboyle and to Goineasy9. My last question is: If I have istalled on a HDD 1. WinXP, 2. Win7, 3. DATA, 4.Empty (for Linux), how can I Install Linux? I have never done this. Do they all start without problems? I have 500GB HDD, AMD X2 4200+, 2GB RAM. VGA ATI4350 512 MB.

    Thanks for your Help.
    Greeting from Germany
  • Goineasy9Goineasy9 Posts: 1,116
    At present I'm using Fedora, and I know that during the install process it asks how you would like to install Linux. In you case choosing "Install to Free Space" should work. Different distros have different setups during the partitioning process, but somewhere during the Disk setup is should give you a choice.
    I am also a fan of EasyBCD, which was useful with creating my dual boots of Vista and Fedora. Version 1.7.2 was great for Vista, and I hear version 2.0 works well with Windows 7 and Grub2, although I haven't tried version 2 yet. Link is here:
    http://neosmart.net/dl.php?id=1
    Having 2 versions of Windows on your computer and then installing Linux might be a little tricky with the bootloader, so, I'd read up on how the bootloader in Windows is handling the 2 versions. I know that legacy Grub adds Vista to it's choices, but I've never had 2 Windows versions on my HD at the same time (LOL- Always thought that even one was too much).
    Read the forums at neosmart, those folks deal with the dual windows versions a lot, and some interesting answers are available there.
  • mfillpotmfillpot Posts: 2,180
    Generally you only need to point your boot loader to the first installed instance of windows. When you install a second version of windows it automatically adds the necessary lines to the windows boot loader, you will want to have grub point to the first windows instance to let windows' boot loader tackle the windows options.

    As for installing Linux on that machine, as GoinEasy9 stated most distros have the option to install to freespace, after that is done they generally automatically build the boot loader to point to all installed OSs, this works most of the time, but there is still a chance that you will have to turn the boot loader yourself.
Sign In or Register to comment.