Welcome to the Linux Foundation Forum!

Desktop environment doesn't work


Today I discovered that I can't see my desktop (GNOME), but a terminal, text mode environment. I don't know why did that happen.

I want to use again GNOME, but what can I do to use it?


  • mfillpot
    mfillpot Posts: 2,177
    It sounds like your system rolled back to cli mode, have you tried typing startx?
  • Thanks.

    I'll try that, and I'll inform about my results.

    In fact, this is the first time I've heard that command :blink:
  • gomer
    gomer Posts: 158
    Did this happen after a software update? It's odd for it to just stop working. If startx fails, try manually starting gdm (maybe /etc/init.d/gdm start) and see if that works. If both fail, you'll probably have to check for error message in the X server's log file (probably /var/log/Xorg.log orsomething similar) and see if we can figure out what happened.
  • mfillpot
    mfillpot Posts: 2,177
    The startx command is used to start the X11 server from a CLI login, rather than starting the system in full CLI Mode.

    The system has an init file that tells it to start in CLI or GUI mode, but I do not know the file name opensuse. If startx works the next step would be to check that file to make sure the right run level is set.

    After that it would be about digging into log files to see exactly what went wrong as Adam stated.
  • Well, I don't know why happens that.

    But it's strange. Because sometimes openSUSE starts well, and another times it starts with text mode :S

    Because of problems with Internet on it, I downloaded some games from sourceforge with my Vista (Rigs of Rods, Vega Strike, No Gravity and Freeorion) and tried to install them on openSUSE. Maybe that is the cause.
  • mfillpot
    mfillpot Posts: 2,177
    Are you getting any artifacts on the screen when it fails to load the GUI and defualt to CLI?

    Also becuase of the random events it is time for you to review the xorg log that adam recommended, in that file you should be find error message that we can help you to translate into remedial actions.
  • Mmm, I think that I found a solution.

    I have to install KDE. When I used KDE, it works very well, with no problems. But with GNOME I have that problem.
  • mfillpot
    mfillpot Posts: 2,177
    Then I believe the issue may be with the gnome utilities, I would recommend reinstalling gnome and gdm, rather than forcing yourself to adapt to a new desktop environment.


Upcoming Training