Welcome to the Linux Foundation Forum!

ubuntu self reset

so, i switched computers, am using a desktop, and have ubuntu on a 40 GB HD.

everything was going good, and when downloading a ISO file and installing/finding drivers for my printer, the screen went to only the linux background as well as the two panels being completely empty. trash popped back up, and then the other things on my panel did. well, the four workspaces i had open and the various things spread around them all moved to one workspace and i was set back to my two default workspaces instead of 4. and then my wobbly window and 3D desktop cube i had checked in the compiz settings are still checked but dont work. and i tried to uncheck them and recheck them and they still dont work. no wobbly window and no 3D cube.

anyone know at the least why this may have happened and how to fix it? it seems it reset to more original settings.



  • mfillpot
    mfillpot Posts: 2,177
    It sounds like something caused and application fault, in which the X11 server and compiz crashed and restarted. Due to the fact that the compiz functions do not work it seems as though the crash was related to your video card or video driver having problems. Have you restarted the computer to see if it has corrected itself?
  • i have not done this as i had some things open, will do after school today. i also uninstalled and removed compiz, but when reinstalling it same thing, as it was still at the settings from last time.
  • i restarted my computer and it worked. with all the settings.

    im wondering why it did this on my laptop but even restarting it didnt set back all the default settings, the cube didn't work. neither would the workspace number change, it was stuck on two.

    that computer is broke now so it doesnt matter but it is strange.

    thanks for the help mfillpot, where did you learn so much about computers and linux systems?

    im no stranger to computer myself, i build them, and am great on windows, linux is just new to me. but i am loving it!!!
  • mfillpot
    mfillpot Posts: 2,177
    If a restart and reinstalling the drivers did not work then most likely your video card is failing, which is why even pushing the settings will not bring it back. I had seen this before on another machine in which the network chip was close to the video chip on the motherboard, while it was downloading the ISO the heat generated by the activity on the network chip was so intensive that it caused the video chip to partially fail.

    My background is in networking, security, operating systems, database, scripting and overclocking. While helping people all around the world with issues in all of those categories I have experienced or helped to addess many issues that I would not have seen on my own systems.
  • well on this computer it is all working, and a simple restart did it.

    on my laptop which is the one broken right now it wouldn't fix on my account but on the guest one it worked. some info on the problem is in my other thread asking about fixing wireless or system restore. all settings were messed up on my old computer with my account and they all worked on guest session.

    but the HD was failing so im guessing that has something to do with it, as that laptop is no longer in service;)

    thank you a ton for your help!
  • mfillpot
    mfillpot Posts: 2,177
    If the problems are isolated to a specific profile then it may be a case of a corrupt user profile or user settings, with your hard drive failing that tells us what files are corrupt.


Upcoming Training