Welcome to the new Linux Foundation Forum!

How do I install Nvidia drivers

How do I install the nvidia drivers for Fedora 11?

Comments

  • Goineasy9Goineasy9 Posts: 1,116
    First thing we need to know is what card your using. If you don't know what Nvidia card your using we can find out by doing in a terminal:
    lspci | grep VGA
    

    I know you told me in the other thread that the new kernel came in when you tried to install kmod-nvidia, so that is the most recent kernel. But you might want to do an update just to make sure that everything else is up to date also. We don't want to have to restore nouveau again because we're using an older version of something needed to set up the nvidia graphics.

    In a terminal, Applications-->System Tools-->Terminal, do:
    su (hit enter)
    enter your root password, hit enter
    then type "yum update" (without quotes) and press enter again
    Then hit "y" when it prompts you and let your machine update.

    When that's completed, let me know what the output from the lspci command is and we can continue.

    P.S. It might take a while if you haven't updated that machine yet.
  • Here is the output (yay I can copy and paste again!)
    01:00.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5200] (rev a1)

    I hesitate to do an entire machine update as I only have 1.6 GB free (I have 2.2 GB of unallocated disk space but the palmdisk disk utility does not allow me to expand my /(root) partition.

    Another note: the nvida driver has left some nvidia utilities on my system such as NVIDIA X server settings.

    ps It's 11:45 pm here in the eastern US time zone so I'll be off to bed soon.
  • Goineasy9Goineasy9 Posts: 1,116
    I'm in the Eastern time zone also, so bedtime is indeed near. I understand about your lack of disk space, let me see if I can figure out what is needed so we can narrow it down. Plus, I think I know why your last attempt failed. You have an older Nvidia card that needs an older driver. So, if you want, we'll continue tomorrow or at a later date. I'll post again after I look up some things.
    See you soon.

    p.s. don't worry about nvidia settings.
  • Ok great.
  • Goineasy9Goineasy9 Posts: 1,116
    Sorry I got a little delayed with my posting.

    Your video card requires the 173 driver, so, if you want to try, here goes.

    From a terminal:
    su (press enter)
    put in you user password (press enter)
    yum install kmod-nvidia-173xx xorg-x11-drv-nvidia-173xx-libs.i586
    
    To make sure that the new kernel blocks nouveau do:
    dir /etc/modprobe.d/ 
    
    and see if the file blacklist-nouveau.conf is there. If it isn't do:
    nano /etc/modprobe.d/blacklist-nouveau.conf
    
    and add "blacklist nouveau" (without quotes) to the empty file. Then save the file with ctrl-x and then answer "y"

    then reboot

    That's all it takes. Now, if it fails to work, it could be due to the machine needing to be updated, or, we could get rid of the new kernel, and install nvidia drivers on the old kernel. We won't know until you try.

    If it doesn't work you can always use the four commands at the end of the last thread to bring nouveau back. Let me know how you do.
  • Thanks it worked Great!. I got the Fedora cube now :).
  • Goineasy9Goineasy9 Posts: 1,116
    Excellent, have fun.
  • I prefer to install the drive myself. So, knowing what my card is,
    1)I download the excellent driver from nVidia.com.

    2)Then I do ctrl+alt+2 for ttyl2 (which is a command terminal, full screen).

    3)I then log into root.

    4)I immediately type init 3 (this will kill everything that is up in your GUI, close unneeded programs).

    note: Right now is a good time to backup your xrog.conf file (it controls your general driver settings).
    Go to /etc/X11/ and do a cp xorg.conf xorg.conf.backup
    This will backup your xorg.conf file to xorg.conf.backup

    4)I then go to the place on the hard drive where the driver is. (Usually /home/*Your User*/Downloads)

    5) I then chmod 777 the drive (not needed, you can do a chmod 700) - this is to give it excute permissions.

    6) I then do a ./*driver name* (this is like typing in *program*.exe in Windows command prompt)

    7) I follow the directions, if there is problems it will auto-abort. I usually install the 32-bit libraries so that I don't have to install them later.

    8) After install I reboot the computer if it doesn't automatically

    9a) During reboot, pay attention to the boot log by pressing on the down arrow when you see the Fedora Logo.
    9b) Open /var/logs/boot.log

    note: If the driver fails and your desktop looks like crap, replace the xorg.conf with xorg.conf.backup by doing a
    cp xorg.conf.backup xorg.conf
    This will overwrite your xorg.conf file.

    10) I then test to make sure the 3d effects are working by going to a Terminal and running glxgears.
    If the program comes up and runs - great. If not go through your boot.log and your nvidia-install.log.
  • Goineasy9Goineasy9 Posts: 1,116
    Installing the Nvidia driver from their source might work well on some distros, but, it is the easiest way to bork graphics in Fedora. Especially since Fedora now ties the Nouveau driver so tightly into it's kernel.
  • pjpdevpjpdev Posts: 11
    Goineasy9 wrote:
    Installing the Nvidia driver from their source might work well on some distros, but, it is the easiest way to bork graphics in Fedora. Especially since Fedora now ties the Nouveau driver so tightly into it's kernel.

    I agree with you... I just managed to make it all go up in flames after installing drivers from RPMFusion. :angry:
  • Goineasy9Goineasy9 Posts: 1,116
    Well, when installing the drivers from rpmfusion, you have to go through all 4 steps that also blacklist nouveau and add an option for the same to the kernel line in grub.conf. You also have to make sure the rpmfusion drivers that you install match the kernel you are using, whether x86, x86_PAE or x86_64, and, match the nvidia card model.

    We have a thread on how to revert the driver back to nouveau, so one can start the nvidia driver install from scratch here:
    http://www.linux.com/community/forums?func=view&catid=6&id=4334
  • pjpdevpjpdev Posts: 11
    Managed to get the GUI up and running again, but still no luck with drivers.

    Here's the output of "lspci | grep VGA"
    00:0d.0 VGA compatible controller: nVidia Corporation GeForce 6150SE nForce 430 (rev a2)
    

    My system is up-to-date and I'm currently using kernel version 2.6.31.12-174.2.3.fc12.i686. Don't know where to go from here.
  • pjpdevpjpdev Posts: 11
    Nevermind, problem solved. I tried this guide - http://forums.fedoraforum.org/showthread.php?t=204752 and it worked 100%.
  • Goineasy9Goineasy9 Posts: 1,116
    You found the right guide. I'm glad you found it. When I have a new Fedora install I always bring up the first post from that thread and do a copy/paste of the commands there in order to install Nvidia binary blobs. It's worth a bookmark, because as Red Hat/Fedora keeps binding its Open Source graphics drivers like Nouveau tighter into their kernel, Leigh's How-To is a must to get things installed correctly.
    BTW - Experimental mesa-dri drivers are already reporting 3D rendering with some Nvidia cards. Open Source is getting close to not needing proprietary graphics drivers at all. I can't wait for an alpha of F13, I'm dying to try them.
  • win2tankwin2tank Posts: 25
    I just decided to check back on this thread, I'm glad to see that it has helped other out. Does anyone know if you can get the Fedora cube effects under VMware which uses its own virtual graphics card?
  • Goineasy9Goineasy9 Posts: 1,116
    I'm currently running Fedora 13 with nouveau graphics (No Nvidia blob) using the mesa-dri-drivers-experimental, and I'm able to use 3D desktop effects. I don't know what virtual graphics VMware is using, or whether they're covered by the Open Source drivers, but it be worth trying. I'd love to hear the results.

    BTW - This thread has helped out more than you know, I've given the link out many times.
Sign In or Register to comment.