Welcome to the Linux Foundation Forum!

Problems booting up a presistant USB install


I have recently attempted to install Backtrack 4 on my 4 gig flash drive. It is in many ways similar to ubuntu and runs KDE.

On the flash I created two partitions. one is fat32 and the other ext3 following this tutorial on how to do it.


I made the fat32 with a bootable flag, copied the entire dvd over to the partition and ran the grub-install on the same partition.

when I tried booting it, all the screen said was grub at the top left corner and appeared frozen. I think tried to reinstall grub with the same command and it was saying "unknown Partition table signature" about 8 times but the said it was successful with out any errors. This is obviously wrong cuz it doesnt boot.

the menu.lst appears to be fine all though I was required to modify it a little

if anyone has any ideas I would appreciate

I'm a bit stuck


  • Goineasy9
    Goineasy9 Posts: 1,114
    Unetbootin is in one of the steps needed for install onto a USB stick. But, I've heard that Unetbootin is broken currently. I know Backtrack is based on Ubuntu 8.04, was Unetbootin already installed, or, did you have to download it from new repos? Just one idea, I still haven't booted up my d/l of Backtrack, many other things to do first.
  • Bloodhoundr
    as I understood Unetbootin is optional. you could use a bootable DVD, which is what I did, to format the 4 gig flash drive and make the 2 partitions through the use of fdisk command.

    Before I burned the ISO to the DVD I did try to use Unetbootin on a 2 gig flash so that I wouldn't have to use a disk at all but It didn't want to boot up ether so maybe it is broken.


Upcoming Training