Welcome to the Linux Foundation Forum!

backintime not opening in gnome ubuntu

when i use the menu i see it open for a second then it closes. when i use the command line i get

[email protected]:~$ backintime-gnome

Back In Time

Version: 0.9.26

Back In Time comes with ABSOLUTELY NO WARRANTY.

This is free software, and you are welcome to redistribute it

under certain conditions; type `backintime-gnome --license' for details.

/usr/share/backintime/gnome/app.py:1051: Warning: g_set_prgname() called multiple times

gnome.program_init( 'backintime', cfg.VERSION, properties = gnome_props )

Traceback (most recent call last):

File "/usr/share/backintime/gnome/app.py", line 1056, in

main_window = MainWindow( cfg, app_instance )

File "/usr/share/backintime/gnome/app.py", line 281, in __init__

self.update_all( True )

File "/usr/share/backintime/gnome/app.py", line 388, in update_all

self.update_folder_view( 1, selected_file, show_snapshots )

File "/usr/share/backintime/gnome/app.py", line 1000, in update_folder_view

new_iter = self.store_folder_view.append( [ item[0], rel_path, item[3], item[5], item[1], item[2], item[4] ] )

TypeError: value is of wrong type for this column

[email protected]:~$

how do i fix this? I completly uninstalled it and reinstalled the program

for some reason the program will work if i do the gnome root option for backintime but i want to use it without having to use root

Comments

  • Goineasy9Goineasy9 Posts: 1,116
    You just might have to run backintime as root. I would assume that as it is restoring the computer to a previous state it will also have to access files that need root access. I have never used backintime on my Fedora install, so I'm just guessing. For example, when I run nvidia-settings from the menu, it won't save the xorg.conf file because it needs root access, I have to run it as root to do that. Why the developers of these apps don't take this into account puzzles me, unless there is some configuration setting that we are missing.
    Maybe filing a bug report to the developer is in order.
  • kowostkowost Posts: 1
    Hi,

    I had the same problem. I took the config file - it is located in /home/<yourname>/.config/backintime - and removed all entries that started with gnome.<xxx>

    my config looked like this

    ...
    gnome.last_path=/
    gnome.main_window.height=528
    gnome.main_window.hpaned1=200
    gnome.main_window.hpaned2=200
    gnome.main_window.width=782
    gnome.main_window.x=289
    gnome.main_window.y=332
    gnome.show_hidden_files=false
    ...

    after removing the UI displayed well

    cheers

    kowost
  • Same here using Debian 7 Jessie, GNOME 1.0.36, BackInTime 1.0.36. Another option to resolve this is to delete the "app.lock.pid" file.

    Steps

    1. Using Nautilus, navigate to this folder

      /home/<USERNAME>/.local/share/backintime
    2. Backup this file

      app.lock.pid
    3. Delete this file

      app.lock.pid
    4. Using GNOME, try to open “BackInTime” again
    5. Done. Enjoy :)

    The most likely cause of this challenge is that BackInTime was open, but somehow to computer was not shutdown cleanly. Such as during power outage or a crash. As a result BackInTime is still in a locked state. This lock state is set by the file "app.lock.pid". If this file contain a code. BackInTime will not open. Because it believes it's already open. But it's not. Thus you need to manually delete this file.

Sign In or Register to comment.