Welcome to the Linux Foundation Forum!

installing and using a saa7231 TV card


I bought a new computer a few days ago and I have a lot of trouble in installing and using my TV card.

My card is a saa7231 triple capture device from CTX and lspci identifies the card as:

01:07.0 Multimedia controller: Philips Semiconductors Device 7231 (rev 11)
Subsystem: Creatix Polymedia GmbH Device 0002
Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 64 (1000ns min, 4250ns max), Cache Line Size: 64 bytes
Interrupt: pin A routed to IRQ 11
Region 0: Memory at f9800000 (64-bit, non-prefetchable) [size=4M]
Region 2: Memory at f9400000 (64-bit, non-prefetchable) [size=4M]
Capabilities: [40] Power Management version 3
Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=55mA PME(D0+,D1+,D2+,D3hot+,D3cold-)
Status: D0 PME-Enable- DSel=0 DScale=0 PME-
Capabilities: [48] Message Signalled Interrupts: Mask- 64bit+ Queue=0/4 Enable-
Address: 0000000000000000 Data: 0000

I found something that seems to be a driver for that card on http://www.jusst.de/hg/saa7231/ but I do not understand how to use it. I installed it using make -i && make install but I have no idea what to do next. Programs like tvtime oder kaffeine still do not get any signals.

So maybe someone can give me some hints on using this TV card.

Thanks a lot and a happy new year,



I am using Debian Lenny with a kernel version 2.6.26-2-amd64.


  • Thanks a lot for your tip, but I tried tvtime already. It just gives me a blue window with the text it cannot find /dev/video0. I checked it and this device does not exist. Unfortunately there is no device at all that looks like a TV card. I think the saa7231 driver is not installed or loaded correctly. My problem is, that I do not understand how to use this driver.
  • motd
    motd Posts: 2
    it seems that i have the same problem =(

    driver from http://www.jusst.de/hg/saa7231/ fails to compile:

    *** No rule to make target `/root/saa7231-c6048b34be66/v4l/saa7231_pci.o', needed by `/root/saa7231-c6048b34be66/v4l/tda18271.o'. Stop.

    slackware 13.0 x86_64 kernel:
  • I also got this error message. I could avoid it by using make -i instead of make all, but I do not think that this makes any sense because the driver didn't work either.
  • motd
    motd Posts: 2
    make -i make gcc to ignore errors which doesnt help cause the error is in saa7231,....

    it looks like there are missing some files ( saa7231_avis.h, saa7231_avis_req.h )

    i tried to remove those files,...
    which made it compile without errors but the the module dint load into kernel =(


    saa7231_drv: Unknown symbol saa7231_cgu_init
    saa7231_drv: Unknown symbol saa7231_device_add
    saa7231_drv: Unknown symbol saa7231_i2c_exit
    saa7231_drv: Unknown symbol saa7231_pci_exit
    saa7231_drv: Unknown symbol saa7231_vfl_exit
    saa7231_drv: Unknown symbol saa7231_pci_init
    saa7231_drv: Unknown symbol saa7231_i2c_init
    saa7231_drv: Unknown symbol saa7231_vfl_init
    saa7231_core: Unknown symbol videobuf_streamoff
    saa7231_core: Unknown symbol videobuf_poll_stream
    saa7231_core: Unknown symbol videobuf_dma_free
    saa7231_core: Unknown symbol videobuf_reqbufs
    saa7231_core: Unknown symbol videobuf_waiton
    saa7231_core: Unknown symbol videobuf_dqbuf
    saa7231_core: Unknown symbol videobuf_queue_sg_init
    saa7231_core: Unknown symbol videobuf_dma_unmap
    saa7231_core: Unknown symbol videobuf_read_stream
    saa7231_core: Unknown symbol videobuf_querybuf
    saa7231_core: Unknown symbol videobuf_qbuf
    saa7231_core: Unknown symbol videobuf_read_one
    saa7231_core: Unknown symbol videobuf_iolock
    saa7231_core: Unknown symbol videobuf_streamon
    saa7231_core: Unknown symbol videobuf_mmap_mapper
    saa7231_core: Unknown symbol videobuf_to_dma
    saa7231_core: Unknown symbol videobuf_mmap_free

    and i fear im not good enough at c to have any ideas how to fix this =(
  • Hi Martin,

    how did you identify those two files (saa7231_avis.h, saa7231_avis_req.h)? I thought that the file saa7231_pci.o (or the related c or h file) is missing.


  • Hi,

    I wrote the developers of the driver a few days ago and they told me, that the driver is not ready for usage now. The work is still in progress and it needs some more time till we can use the code.


  • MichaelK
    MichaelK Posts: 20
    Does anybody knows something new about the card? I still do not find anything usefull and the card is still not working.
  • robert_s
    robert_s Posts: 1
    I contacted Trident Microsystems, now owner of the SAA7231 (NXP sold it off), and they flat out refused to give out any information on this chip to Linux developers. I asked them to reconsider, and they came back a day later with the same result.

    So Trident Microsystems has a clear "No Linux" policy in place for the SAA7231. That's it. Linux support won't happen. The SAA7231 is for the trashcan, as is any TV card with this chip on it. That's the manufacturer's will.
  • MichaelK
    MichaelK Posts: 20
    Thank you very much for this information. It is sad to hear, that the manufacturer does not like Linux. So I have to look for a new TC card.
    But thanks again four your help.


  • MichaelK
    MichaelK Posts: 20
    Thank you very much for this information. It is sad to hear, that the manufacturer does not like Linux. So I have to look for a new TV card.
    But thanks again four your help.


  • mfillpot
    mfillpot Posts: 2,177
    If any developers are interested in trying to develop drivers for this manufacturer's cards, I recently found that the Linux Foundation has an NDS program (http://www.linuxfoundation.org/programs/developer/nda) which will help negotiate NDA agreements to facilitate development of open source drivers for proprietary hardware.


Upcoming Training