Welcome to the new Linux Foundation Forum!

Knoppix 6.2 doesn't complete the load process.

I've tried re-burning multiple times using different burners and programs. It goes to the boot screen, I hit enter. It decompresses the system files and then goes to blank screen. I've tried the suggestions listed in the cheatcodes wiki but no luck. Any ideas on how I can get it going?

Thanks

Bryan

Comments

  • Goineasy9Goineasy9 Posts: 1,116
    Can you tell us what hardware your trying to boot it on. Videocard, processor, how much ram etc.
  • There are 2 machines its not working on. Both have Nvidia cards. One is a geforce mx with a Asus-A7A266 MB, 1gig ram and a 1.4 gig AMD processor. The other is a Asus A7V-333 MB with 2 gig ram, model 4400 AMD processor with a EVGA 7800GT video card. I've burned the cds multiple times with different burners on 2x. Same results. The DVD version doesn't work either. I've tried other Live cds and most aren't working but Nimblex does. I've done a complete install of Win2k and all is working there so I believe the system is in good shape. The faster machine is running dual boot of XP and Ubuntu with no problems there. I've read everything I can find about the problem but had no success using the cheat codes.

    Thank you for taking the time to respond.

    Bryan
  • mfillpotmfillpot Posts: 2,180
    It sounds like the system is unable to properly initialize the GUI, which is really weird since the video cards aren't too new.
    Here are a couple of recommendations:
    1. when the screen goes black hit Ctrl+Alt+Backspace to restart the gui, if it cannot restart then it should show an error message stating the reason.
    2. Have you been verifiying the md5sums of the ISOs after they are downloaded and have you verified the disks after they were burned? In both the downloading and burning processes the data can become corrupt you must check both.
  • Yes I have verified the downloads and also tried the torrent download that does a auto check. The problem is consistant. I can take the same cd to the laptop and it works. I have used nero and cdrecord to burn the disks. Nero verified the write but I don't know how to get cdrecord to verify. I have 6 or 7 disks laying around that have been burnt at different speeds,burners,and different iso's. I will try ctrl+alt+bksp and see what I get.
  • I've tried the ctl+alt+bksp with no results. Its not booting that far. Whatever happens after it upacks the .gz file is causing the machine to stop. The cd never continues after it loads the boot screen. boot.JPG
    boot.JPG 144.8K
  • mfillpotmfillpot Posts: 2,180
    If the key sequence I listed did not work then it crashed prior to starting the GUI. So far it sounds like a kernel panic, except that usual kernel panics display some output stating the reason. I have not used knoppix for some time so please work with me on this, does knoppix have a single user or recovery mode option in the boot screen or is it possible to modify the grub parameters to force it into single user mode? If you can get it to boot into cli mode then it should give you more information.

    I will download and test knoppix 6.2 this evening to try to find the boot option you need, hopefully you will find it before me.
  • It has a failsafe mode and expert mode. I believe the problem I'm having is that after it first loads the boot screen, it does something to cause it to loose the location of the cd drive. I get "could not mount to disk /mnt-system" on the other computer I'm trying to get knoppix to work on( when I use failsafe mode). It does get to the gui, but then it freezes. It does have a cheat code that says "knoppix_dir=" I've tried using it but I don't know what to tell it to equal...
  • mfillpotmfillpot Posts: 2,180
    In some sites that I have searched for this error they talk about bad CD-ROMs, unwritable file-systems and other such issues. But the one that makes the most sense to me is that the operating system is unable to mount the CD-ROM to extract the rest of the required information. Can you go into failsafe or expert mode and attempt to mount the cdrom to a new directory to see if it can be mounted? Also since this issue happens alot one constant fix it to use the USB live distro instead, you might have better luck with that.
  • I've tried the usb key. I made it using the laptop. It works fine there so I moved it to the desktop with the same error.
    To change the way it boots has to be done on the boot menu. The only other screen I see (and thats using failsafe) is the screenshot on the previous page. The faster computer makes it to the gui before it shuts down but when I run it in failsafe, it gives the "can not mount to disk" error.. I've tried tweaking the settings in the bios to get it to work but nothing I've tried gets me any further along." failsafe debug -b" is supposed to put in in "emergency mode" where it is suppose to give me a terminal promt with no hardware detection. I can't make it to this point. How do I force it to look at a specific location for the kernel file and what would the location for the cdrom be?
  • mfillpotmfillpot Posts: 2,180
    I am at a loss in this topic, I don't know knoppix well enough to tell you were to point. But sine issue seems to be constant with knoppix I would like to recommend that you try slax, hopefully if it is not a hardware based issue it should work a lot easier.
  • The slax distro boots up as it should. It is more of a general use version. I'm looking for more of a computer mechanic's toolbox version. I've still had no luck with the knoppix version. Very frustrating. Think I'm going to try a older version.

    Thanks again for taking time to help. You were the only one on 4 different forums that even posted. Where'd everyone go??
  • mfillpotmfillpot Posts: 2,180
    It has been a very quiet weekend as I noticed. It is good that slax is not giving the same errors, If slax is too general for you in it's current state then you can use the Build Slax link to take the base slax image and add whatever applications you like to make it for you specific uses.
  • yegnayegna Posts: 1
    Knoppix 6.2 doesn't boot straightaway if the computer has one of the newer wide TFT screens as the monitor eg 1366x768 or 1920x1080 pixel ratio = i have tried these two. You have to specify the screen size option in boot option


    boot: knoppix screen=1920x1080 etc for the boot process to complete. knoppix has to invoke the video adapter software from the packed on CD/DVD software.


    yegna
Sign In or Register to comment.