Welcome to the Linux Foundation Forum!

HP printer low on ink error


I'm starting to pull my hair out with this one. I have a HP 2575 Photosmart all-in-one printer that has just started giving me low ink level errors. According to the driver, it has no ink level function, although, when I installed hplip-gui it shows me the ink level. Anyway, at first I thought the cartridge may be low, so I let it go until the cartridge actually ran out of ink, but, even with the new cartridge I still get the low ink error. I could live with the warning, but it sporadically stops the printout mid page, and, it's starting to become very annoying. There seems to be no way I can remove or stop the ink level function. I'm thinking that there's a config file with a flag set somewhere, but, for the life of me I can't find it.

I've tried reinstalling the printer driver, changing the cartridge, rebooting, restarting cups, etc. etc. etc. I'm open to any ideas, I've had this printer for years and never had a problem with it. It may be an updated driver that was installed (there have been recent cups updates in Fedora 11). It may have something to do with my moving the printer to a Fedora machine after the old Mepis box died, but I moved it weeks ago. It may be that the printer is just old, and needs to be replaced.

Has anyone seen a spurious ink level error before, or know of a way to shut off the ink level monitoring function?




  • mfillpot
    mfillpot Posts: 2,177
    Tom, I agree it may be a dirty cartridge. If it is not then you may be able to modify the related lines in the used ppd files for the hplip manager driver or the installed cups driver.
  • Goineasy9
    Goineasy9 Posts: 1,114
    Thanks for the responses. The problem still exists. Even though I just changed both cartridges (at the same time). HPLIP is installed and says it can't monitor the ink level, then in another area reports the ink level. Cups shows me the ink level error when I check jobs. Most interesting is that occasionally the print stops mid page, and I have to reinitialize the printer queue to get it to start printing again.
    a) I'm going to take a look at the ppd file.
    b) hook the printer up to a new Mepis install and see if I have the same problem. First without HPLIP, then with, I never had this program just using cups.
    c) clean out the printer, to see if ink build up somewhere is causing the problem.
    d) Hook up the new printer that has been sitting under my desk that I haven't had time to hook up.

    That is, as soon as I get some more time. Thanks for the new ideas.



Upcoming Training