Welcome to the Linux Foundation Forum!

Nvidia Geforce only detected on live CD

BarryM Posts: 23

I've got a bit of a wierd one here. I've got a Geforce G102M video card on my laptop which is recognised when I run the live CD but when I run Ubuntu (9.10) it doesn't seem to recognise that I need proprietry drivers any more therefore I can't set up my card.

Anyone else get this problem or know how I can get around it?

I'm only a newbe but willing to learn so don't be afraid to ask for more info or give me a complicated solution.

Thanks guys


  • Goineasy9
    Goineasy9 Posts: 1,114
    I have Ubuntu 9.10 running in KVM right now (yaaay, I wanted to do that for a while). If you go to
    Applications-->Ubuntu Software Center and type nvidia into the search field, one of the choices is NVidia binary X.Org driver ('version 185' driver). If you click on that and then the arrow to the right, it should install the driver for you (after you click install). Your card is one of the newer cards and should be handled by this driver. I'm fully updated and I see that the 190 driver is still not listed in the choices in Ubuntu, even though it is the most recent stable driver. I guess that will come in time, it's been only listed as stable for about 2 weeks.
    See if that works. If it says it's already installed, or still doesn't work, let us know and we'll take it to the next step.
  • mfillpot
    mfillpot Posts: 2,177
    I experienced the same issue, unfortunately ubuntu 9.10 was unable to detect the nvidia dirvers through the "hardware drivers" tool. After I used the software center to manually install the 185 driver, then it started showing up in the "hardware drivers" tool.

    Go as GoingEasy9 recommended and you will have it up an running.
  • BarryM
    BarryM Posts: 23
    Thanks guys. I managed to get it going now. It has thrown up another problem now though. Under these drivers, my screen is not being detected properly. it's being detected as an unrecognised screen only 640 pixels high. The result is that everything is being displayed six times on my screen.
    I'm gonna go and see what I can find out about this now. any suggestions are much apperciated.
  • Goineasy9
    Goineasy9 Posts: 1,114
    See if you can locate the nvidia-settings app and run it and see if you can adjust the settings. If that doesn't help it may have not been installed correctly, or, the xorg file might need to be adjusted.
    Let us know what happens.


    Edit: sorry, it's under the system tools in fedora, if I can get into my Ubuntu install later, I'll tell you where to look. It can also be run in terminal by typing "sudo nvidia-settings" (without quotes). It will even write a new xorg for you when you save it.

    2nd Edit: Since I have Ubuntu running in KVM I can't install the nvidia graphics drivers, hence, I can't tell you where in the menu the nvidia-settings app can be found. But, in Applications-->Ubuntu Software Center if you type nvidia-settings into the search box, it does come up and is available. Once again, if you need more help, just ask.
  • Yeah, I had a similar problem with an Intel on-board video chip, but for me the solution was easier: I just swapped out the motherboard. Good thing I had the other board and the knowledge to swap!
    Incidentally, XP (Nova Logic) games had problems with that video chip, too.
  • BarryM
    BarryM Posts: 23
    lol, I think I'll try to change the settings first - the laptop's only a month old and I don't want to ruin my two year warranty. besides I don't have a spare board.
    I'll let you know how I get on.



Upcoming Training