Welcome to the Linux Foundation Forum!

Getting started again.

I tried switching to Linux awhile back, but there was only one thing in my way; getting my wireless adapter to work.

I have a Linksys WUSB54GSC Usb wireless adapter. Last I checked, there was virtually no support for it, but now that I'm back, Im wondering, is there a distro that supports it?


  • mfillpot
    mfillpot Posts: 2,177
    That device appears to be using a ralink chipset, I have not found any of their drivers to be included in a Linux distribution. What you will need to do is install ndiswrapper and download the windows xp drivers for the device, ndiswrapper will allow you to use the windows drivers to setup support in your chosen distribution.

    Post back when you have the windows drivers downloaded and ndiswrapper installed so we can give you further guidance.
  • I already did that, installed the ndiswdm.inf that came in the drivers on my Disc. i also installed Wicd network manager, not sure if i should've done that. After that I checked the Windows Wireless Drivers(ndiswrapper) and it just froze on me. when I typed in 'ndiswrapper -l' it came out 1737:0075 Present.
  • mfillpot
    mfillpot Posts: 2,177
    Did you also run the commands to append the ndiswrapper configuration as modules and launch the ndiswrapper module in modprobe?
  • Im using Ubuntu, im not sure how to do that, is it:

    sudo depmod -a

    sudo modprobe ndiswrapper
  • mfillpot
    mfillpot Posts: 2,177
    read "man ndiswrapper" to get instructions, I believe it would be "sudo ndiswrapper -mi", but after the commands are loaded for ndiwrapper run "sudo modprobe ndiswrapper" and it should appear. But there are some issues with drivers that are badly written for windows so their stability under ndiswrappers is poor.
  • so you want me to try that command 'sudo ndiswrapper -mi'? and then do the 'sudo modprobe ndiswrapper'? What message should i get?
  • mfillpot
    mfillpot Posts: 2,177
    You should not get a message from loading ndiswrapper. however if you run "sudo lsmod|grep ndiswrapper" you should get see that ndiswrapper is loaded.

    I don't remember the output from "sudo ndiswrapper -l", but that should confirm that your driver is loaded.
  • Well I did that sudo ndiswrapper -l, and t said present, but my Wi-fi adapter still doesn't work.

    I'll try those commands you just posted and post what it sends back.
  • Well apparently, after the whole ndiswrapper freezing, ubuntu doesnt work anymore. So I give up, im tired of this crap, If it takes this much energy just to get my wi-fi to work, it hurts to think about how hard other thing are. Thank for your help.

    But no thank you.
    Im sticking with good 'ole reliable, stable, Windows.
  • mfillpot
    mfillpot Posts: 2,177
    Unfortunately the failure of your device is not due to issues within the Linux kernel but with the wireless card manufacturer's disregard for standards and universal compatibility. Just because one piece of hardware is difficult is no reason to go back to the system that you must constantly maintain.

    Look at it as a comparison you had to search for your wireless driver to make a Linux distro work on your system, how much time do have to spend looking for the drivers in windows that just work in a Linux distro?

    But if you give up so easily then you will be happy with windows where you assume things work rather than being able to confirm proper operations.


Upcoming Training